English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 16 February 2016, 16:00   #1
jacob1990
 
Posts: n/a
Amiga 500 plus floppy drive fail.

I will add there is no sound of clicking from the floppy drive.

I have recently purchased an Amiga 500 plus - which was sold with a 'broken' floppy drive. When I first opened (took apart) the Amiga I noticed the floppy power cable was not installed properly, so I brought a new one and installed it. But the Amiga floppy disks continued not to function properly, moreover, I added a fully working floppy drive, but again the floppy disks don't do anything?

More Info:
When I install all the floppy cables - power cable and floppy cable into the motherboard no floppy drive light shows on the keyboard. But when I uninstall the floppy power cable and restart the Amiga - the floppy drive light shows on the keyboard?
 
AdSense AdSense  
Old 16 February 2016, 16:10   #2
SkulleateR
Registered User

SkulleateR's Avatar
 
Join Date: Jan 2016
Location: Germany
Posts: 243
Maybe one CIA chip is broken ... Change the CIA A ans CIA B on the board and see if floppy works again
SkulleateR is offline  
Old 16 February 2016, 16:10   #3
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 59
Posts: 3,861
Sounds like some kind of short. Maybe that's why the power cable was disconnected.

Failing that it might be one of the CIA's.

Other than those two, I can't say.
Arnie is offline  
Old 16 February 2016, 16:18   #4
liviux76
Registered User

liviux76's Avatar
 
Join Date: Jan 2014
Location: BO/Italy
Posts: 711
Quote:
Originally Posted by jacob1990 View Post
(...) But when I uninstall the floppy power cable and restart the Amiga - the floppy drive light shows on the keyboard?
This is normal, no light if the floppy drive is connected properly.
You should hear a tic from it and it should start working when you insert a floppy disk (and when reading the light should turn on) while, if the floppy drive is missing or badly connected, the light initially turns on and then turns off.
liviux76 is offline  
Old 16 February 2016, 21:54   #5
jacob1990
 
Posts: n/a
I have changed both the CIA A and CIA B chips on the motherboard - I swapped the chips from my working 500 with the chips from the 500 plus. The chips I thought were damaged are fully working. But the disk drive is still not functioning properly (I can hear the sound of the drive motor).

*update*
I have noticed the battery has leaked (pic1), the gary socket has been affected (pic2), as you can see there is green residue in the socket when I lift the chip out. Any ideas on how to fix this or should I look for another motherboard?


pic1.

pic2.

Last edited by jacob1990; 17 February 2016 at 21:46.
 
Old 17 February 2016, 22:26   #6
Overdoc
Commodore Collector
 
Join Date: Aug 2001
Location: Austria
Age: 47
Posts: 824
My main concern would not be only the Gary's socket, but more the traces below it ?
Some of these seem to have been dissolved by the acid of the leaked battery.
I would check them with an ohm-meter, if they are still ok or not ? If they are broken, you would need to replace them with some small wires on the underside of the board. (it is best to take a look at the schematics to see where the lines start and where they end)
Overdoc is offline  
Old 17 February 2016, 23:49   #7
jacob1990
 
Posts: n/a
I'm actually going to give up on this one...

May I ask - how much do you think I would get for this Amiga (plus working psu and modulator)?
 
Old 20 February 2016, 08:57   #8
Jope
-
Jope's Avatar
 
Join Date: Jul 2003
Location: Helsinki / Finland
Age: 37
Posts: 6,357
Send a message via Skype™ to Jope
15? Not much.
Jope is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 500 Panasonic floppy drive only spinning sometimes. h4tt3n support.Hardware 5 24 January 2016 17:20
Wanted Amiga 500 internal Floppy disk drive sardine MarketPlace 0 22 November 2014 02:22
PC floppy drive for adf files transfer to amiga 500 Galder support.Hardware 9 20 November 2014 00:59
Amiga 500+ floppy drive problem Aldoarvici support.Hardware 13 01 November 2014 17:38
Wanted: External floppy drive for Amiga 500 mrcomputer MarketPlace 7 10 September 2010 15:27

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:45.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.28149 seconds with 14 queries