English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 30 March 2018, 15:39   #1
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,310
Send a message via ICQ to Foul Send a message via MSN to Foul
Exclamation JIT still crash ! Prob found ?!?

Just to remember :

http://eab.abime.net/showthread.php?...09#post1124009
http://eab.abime.net/showthread.php?t=84876
http://eab.abime.net/showthread.php?t=86521
http://eab.abime.net/showthread.php?t=80079

Activation of JIT causes me problems for a long time with my configuration. On my A1200/060 Setup... RAM is filled when I browse the directories and never free it ! from where at a given moment a crash due to lack of memory!
With latest dev fs-uae.. fs-uae boot and stop at mount command failled.



This does not happen with JIT disabled.

I decided today to make a minimal system config to test this prob.

I provide a small .hdf with a fresh install of WB3.1 .. nothing added !!!
+ fs-uae logs + default.fs-uae cfg...

run FS-UAE with JIT = Crash of the emulator
delete JIT lines =FS-UAE boot normaly

With some discutions with Frode, we found the prob is gone when i modify this line in the sources : src/jit/gencomp.cpp

Code:
*/
#define DISABLE_I_MVEL
/*
With this small change.. compiled myself, everything is working perfect !!! but iI do not know if it affects anything else.

Maybe can be corrected on next FS-UAE (WinUAE ?) release !!!

Thx for listening !

Amigatest.hdf : https://goo.gl/48FEA8 5.3 Mo
Attached Files
File Type: zip Default.fs-uae.zip (417 Bytes, 9 views)
File Type: zip Logs.zip (8.0 KB, 8 views)

Last edited by Foul; 30 March 2018 at 18:56.
Foul is offline  
AdSense AdSense  
Old 30 March 2018, 18:03   #2
jbl007
Registered User
 
Join Date: Mar 2013
Location: Leipzig/Germany
Posts: 370
Hi,

you should clean your configuration first. Use "official" options wherever possible. Remove
uae_cachesize
. Replace
uae_cpuboard_type = Blizzard1260
with
accelerator = blizzard-1260
and
uae_cpuboardmem1_size = 128
with
accelerator_memory = 131072


With these changes FS-UAE does NOT crash. Your Amigatest.hdf boots straight into a guru. This also happens with JIT disabled and in WinUAE. Probably due to CPU instructions/68060.library stuff - I don't know... [Edit: removed LIBS:68040.library, provided LIBS:68060.library, now it works fine]
It appears to work with your config with jit disabled. But if you look closely you'll see, the Blizzard (and the 060) isn't emulated at all.

Next: I don't think the Test Drive II issue is JIT related. It also happens without jit on my system. Looks like the typical cpu-is-to-fast-problem.

Last edited by jbl007; 30 March 2018 at 18:24.
jbl007 is offline  
Old 30 March 2018, 18:15   #3
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,310
Send a message via ICQ to Foul Send a message via MSN to Foul
replaced uae_cpuboard_type = Blizzard1260 with accelerator = blizzard-1260 and
uae_cpuboardmem1_size = 128 with accelerator_memory = 131072

Still crash (Mount error) on my System here...
I'm sharing my CF card on FS-UAE and my A1200/060 with same config...
Foul is offline  
Old 30 March 2018, 18:34   #4
jbl007
Registered User
 
Join Date: Mar 2013
Location: Leipzig/Germany
Posts: 370
So real CF/physical device like /dev/sdX? Is this even supported?
What happens if you slow down the cpu? Try
uae_cpu_throttle = -900.0

If this works we have our cpu-is-to-fast-problem again....
jbl007 is offline  
Old 30 March 2018, 18:46   #5
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,310
Send a message via ICQ to Foul Send a message via MSN to Foul
hard_drive_0 = /dev/sdx is working very well on an CF/usb reader

uae_cpu_throttle = -900.0 ... much slower to boot but same :



it would have been too good

ps : and working as usual with the modified compiled fs-uae
Foul is offline  
Old 30 March 2018, 18:51   #6
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 626
Failed returncode 20 is NOT a crash.
Hedeon is offline  
Old 30 March 2018, 18:54   #7
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,310
Send a message via ICQ to Foul Send a message via MSN to Foul
The Crash is with the "test" hdf.. here i'm using my real CF card. but it's not normal anyway...

Just for info : all starting from here : http://eab.abime.net/showthread.php?...09#post1124009
Foul is offline  
Old 31 March 2018, 11:09   #8
Foul
Registered User

Foul's Avatar
 
Join Date: Jun 2009
Location: Perigueux/France
Age: 43
Posts: 1,310
Send a message via ICQ to Foul Send a message via MSN to Foul
I'm not a coder but i think the question is : why with the little modification in the sourcecode, everything is working well ! and if it affect something else...
Foul is offline  
Old 31 March 2018, 14:12   #9
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 626
I'm not into the source, but it looks like the define does something with disabling illegal movs or something and fails if you try one. With commenting the define it's executed anyway, illegal or not.
Hedeon is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crash with JIT and ReSource mark_k support.WinUAE 1 14 April 2017 12:48
WB 1.3 BindDrivers crash with JIT mark_k support.WinUAE 8 23 April 2012 18:32
Shapeshifter and Fusion crash without JIT enabled clauddio support.WinUAE 3 12 March 2012 11:44
Happy Xmas all (or happy holidays) + crash prob Mclane support.WinUAE 2 29 December 2004 22:34
JIT Emulation Doozy support.WinUAE 2 17 January 2002 07:14

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.97602 seconds with 16 queries