English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware > Hardware pics

 
 
Thread Tools
Old 16 February 2020, 16:07   #1
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Elbox Power Tower LED Board

I recently bought an A1200 in a power tower for a very good price. Don't really need one as I already havea fully kitted out tower but I couldn't pass up the price.

unfortunately the previous owner did some rather questionable mods to the tower. Bits of the frame have been hacked away, a cludge of a power cable has been put in, obviously the previous user didn't get the AT to Amiga power cable and the LED board connector was missing.
Fortunately I still had the power cable from my other power tower which doesn't need it as I am powering off a Mediator board.

I removed the LED board and connector from my working tower and attempted to reverse engineer it in KiCAD.

I'm currently waiting for the fabricated boards to arrive from PCBWay and since I only need the one (minimum order is 5) Is anyone interested in taking hte spares off my hands (If they work that is)?
Attached Thumbnails
Click image for larger version

Name:	Elbox_1200_LED_Board.jpg
Views:	70
Size:	88.8 KB
ID:	66192   Click image for larger version

Name:	Elbox_1200_LED_Board_bottom.jpg
Views:	47
Size:	78.8 KB
ID:	66193   Click image for larger version

Name:	Elbox _1200_LED_Connector_Board.jpg
Views:	52
Size:	74.3 KB
ID:	66194  
Vypr is offline  
Old 16 February 2020, 20:52   #2
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 792
I'd be interested in a set
indigolemon is offline  
Old 16 February 2020, 22:08   #3
wiz12
Registered User

 
Join Date: Feb 2017
Location: Ireland
Posts: 223
Interesting, I'd also like to buy a set if you can spare it.
wiz12 is offline  
Old 20 February 2020, 00:47   #4
AmigaHope
Registered User
 
Join Date: Sep 2006
Location: New Sandusky
Posts: 572
My LED panel works fine but I almost want one to keep as spare just in case. x.x; (pun not intended) I have the A4000 tower though so I think the panel might be different.
AmigaHope is offline  
Old 20 February 2020, 11:07   #5
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Well, the interface boards that sit on the A1200 headers should arrive later on today, the LED boards are still being fabricated. Hopefully I will find out today if I have routed the circuit board properly.

Regards the A4000D, I think the LED board is the same but it probably uses a different interface board. The only way to find out ids to crack open the case and take a look at the board Which I don't think anyone would be willing to do.
Vypr is offline  
Old 23 February 2020, 01:27   #6
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Well,t he bad news is the little interface board that feeds up to the LED board is a no go. Spent several hours checking and double checking the routing on the boards and making sure I was using the right components and the right orientation but there is no signal getting to the known working LED board I have.
Maybe someone better than me at electronics can check my schematic?

Edit, I think I found the problem, it looks like D1 should be a Zener diode.
Attached Thumbnails
Click image for larger version

Name:	LED_Schematic.PNG
Views:	36
Size:	50.0 KB
ID:	66284  

Last edited by Vypr; 23 February 2020 at 01:54. Reason: Additional information
Vypr is offline  
Old 26 February 2020, 20:27   #7
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Update:

header board that sits on the Amiga mainboard will need refabbed, it turns out I missed a connection to ground, once I put a jumper wire on the missing connection, the known working LED board lit up as it should, I've resubmitted a new design to PCBWay so new boards should be in in 3 weeks. The new LED Boards should arrive at the end of this week for assembling and testing.

I slightly redesigned the header board to move the connection pins so they weren't sitting under the passive components as they were a headache to solder properly and I've widened the tracks as well.
Attached Thumbnails
Click image for larger version

Name:	header_1.JPG
Views:	32
Size:	28.3 KB
ID:	66312   Click image for larger version

Name:	header_2.JPG
Views:	30
Size:	25.6 KB
ID:	66313  
Vypr is offline  
Old 26 February 2020, 20:37   #8
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 792
Good work man
indigolemon is offline  
Old 28 February 2020, 20:11   #9
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
LED boards arrived today, they appear to work, the only minor issue is the mounting holes are slightly off, nothing a few minutes work with a small drill can't fix. I'll have to order some more LED's though. Thought I had enough to populate all 5 boards, turns out I used them for other projects.
Vypr is offline  
Old 01 March 2020, 13:22   #10
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 792
Oops, missed this last update. I don't mind getting a set of naked boards if you're out of LEDs etc, as I've swapped my LEDs for ultrabright ones in my Power Tower already (The originals didn't cut it after I used vinyl dye to make it black).

Plus building these things is half the fun
indigolemon is offline  
Old 01 March 2020, 13:27   #11
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 4,539
Nice work!
Daedalus is offline  
Old 01 March 2020, 14:13   #12
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Quote:
Originally Posted by indigolemon View Post
Oops, missed this last update. I don't mind getting a set of naked boards if you're out of LEDs etc, as I've swapped my LEDs for ultrabright ones in my Power Tower already (The originals didn't cut it after I used vinyl dye to make it black).

Plus building these things is half the fun
I've already populated the board with the resistors, transistors and the header pin, if you want I can send you one of these boards and you can add the LED's yourself?

I have also made the PCB avaiable at PCBWay - https://www.pcbway.com/project/share...LED_Board.html

Once I have confirmed the connector board works I'll make that public too.
Vypr is offline  
Old 01 March 2020, 14:27   #13
indigolemon
Bit Copying Bard

indigolemon's Avatar
 
Join Date: Jan 2017
Location: Kelty, Fife, Scotland
Age: 37
Posts: 792
Quote:
Originally Posted by Vypr View Post
I've already populated the board with the resistors, transistors and the header pin, if you want I can send you one of these boards and you can add the LED's yourself?

I have also made the PCB avaiable at PCBWay - https://www.pcbway.com/project/share...LED_Board.html

Once I have confirmed the connector board works I'll make that public too.
No worries man, I'm happy to wait and grab a full set from you once you have both confirmed
indigolemon is offline  
Old 05 March 2020, 10:14   #14
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
New LEDS are in and added to the board. They look nice and bright compared to the previous board as well.






New connector boards are now on their way from China and should be here by Monday

Last edited by Vypr; 05 March 2020 at 10:18. Reason: edited image URLs
Vypr is offline  
Old 10 March 2020, 00:27   #15
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 213
Good news everyone! [/farnsworth]

The new connector boards arrived this evening. Assembled the first one and spent a couple of hours scratching my head as although the board lit up, the Power LEd stayed dim and never brightened up. Turned out I had mistakenly put the wrong rating zener diode at D1 (5V instead of 3V) After swapping the diodes out the LEDs lit up properly. HD activity light works a treattoo.

I have 5 connector and LED boards built and tested, just need to make up the cable to connect them all.
I am keeping two for my own two towers but the other three are available on a first-come, first-serve basis. Drop me a PM if you're interested. I will only be charging the component cost (most of which was shipping from China) as I did not design these boards and I will be making the gerbers available for download if you want to build them yourselves.



Last edited by Vypr; 10 March 2020 at 00:30. Reason: edited images to reduce size
Vypr is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power / Elbox Tower 4000 CU_AMiGA MarketPlace 0 16 November 2011 17:36
Wanted - Blanking plates for Elbox Power Tower fitzsteve MarketPlace 0 21 October 2010 11:49
FS: Elbox Power Tower/PS w/ A4000D busboard, Mediator MMCD nlandas MarketPlace 1 13 July 2009 12:29
Elbox Tower Keyboard Adapter paul773car support.Hardware 5 14 June 2009 13:28
The LED's on ELBOX tower!??! BarrySWE support.Hardware 27 23 September 2005 12:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:47.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.14380 seconds with 16 queries