English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 14 November 2018, 20:05   #1
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Strange incompatibilities between CF on IDE and Apollo 1230 turbo

Hello

Bought a 3.5 IDE to CF adapter with a Transcend x133 4GB CF
Transfered my old 800MB WD disk to that card
There is 4 partitions the boot is OFS, the other are FFS
Without apollo, It boots ok and I can launch anything from FFS
With apollo it boots, but IO hangs as soon I access FFS partitions (no guru)
If I try to install a PFS3 partition it hangs on boot as soon the pfs3 partition is accessed, and if I remove apollo card, it works again
Apollo card works ok with my old drive even with FFS partitions
Tried another scsi.device and encountered that the latest loadmodule make guru (with not enough memory) but with an older loadmodule its ok, but latest scsi are not better than the original scsi from KS 3.0
Tried cache nocache burst noburst combinations with no success using setcpu, but I get sometimes success with fastrom (i’m able to load things from ffs orher than icons) !
PSU is currently replaced with ATX PSU
Amiga is not recaped, but there is no apparent leak and apollo battery seems ok (it keeps clock)
Maxtransfer is correctly set to 1fe00, the only things that change is setting filesystem to OFS
Tried to diagnose the 16 MB memory on apollo : got no errors
Cpu and fpu benchmark from aibb is ok
MMU seems to work but there is no blizkick or acatune for that card included and I have never been able to load kickstart 3.1 with skick or setcpu

Any advices?
gatti is offline  
Old 14 November 2018, 20:17   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,728
CF cards require MaxTrasfer to be limited to 128KB. Did you do that?
thomas is offline  
Old 14 November 2018, 20:21   #3
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Quote:
Originally Posted by thomas View Post
CF cards require MaxTrasfer to be limited to 128KB. Did you do that?


Yes all partition’s MaxTransfer values are set to 0x1fe00 and even tried today with just 0xfe00... with no success (and yes I pressed enter to validate each value and double checked after boot)
gatti is offline  
Old 14 November 2018, 20:30   #4
supaduper
Registered User
supaduper's Avatar
 
Join Date: Oct 2012
Location: Birmingham UK
Posts: 854
I would try another CD card might be picky with the combination of the Apollo also try another IDE to cf adapter if you can just process of elimination I think
supaduper is offline  
Old 14 November 2018, 21:45   #5
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Quote:
Originally Posted by supaduper View Post
I would try another CD card might be picky with the combination of the Apollo also try another IDE to cf adapter if you can just process of elimination I think


Ok I will seek for a 2.5 ide to cf adapter (the current one is a 2.5 to 3.5 + 3.5 to double CF)

What Is the recommended 4GB CF (believed that Transcend x133 was a good one because I saw it sold by many amiga dealers)?

Just to be sure : Could it be related in any way with a capacitor tolerance problem ?
gatti is offline  
Old 15 November 2018, 06:41   #6
supaduper
Registered User
supaduper's Avatar
 
Join Date: Oct 2012
Location: Birmingham UK
Posts: 854
I only use sandisk extreme or ultra CF, also I would try a single 44 IDE pin to cf adapter first
supaduper is offline  
Old 16 November 2018, 15:55   #7
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Hum! I wonder if it could be in some way related to the infamous a1200 timing problem...

It's an A1200 Rev 1B with an Apollo 1230@50+68882@50
gatti is offline  
Old 16 November 2018, 16:17   #8
supaduper
Registered User
supaduper's Avatar
 
Join Date: Oct 2012
Location: Birmingham UK
Posts: 854
Certainly, it wont hurt to remove the two capacitors E123c and E125c on the motherboard anyway
supaduper is offline  
Old 16 November 2018, 18:10   #9
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
OK, Removed E123C and E125C but no better result...
btw, maybe something : I use an 450W ATX PSU, and it is *supposed* (lol) to to deliver 40A for 5V, but here is the measured voltage (measured on atx connector) :
- when Amiga has booted without Apollo : +5, +12, -11.6V
- and now with Apollo is onboard : +4.9, +12, -11.6
Could it be sufficient without creating instabilities?
gatti is offline  
Old 23 November 2018, 10:49   #10
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Finally, C821 is mostly blown (rifted on the head), and C822 is curved on the head, according the schematics they are involved in +12V and -12V power input filtering, so I will send for recap the MB before searching elsewhere...
gatti is offline  
Old 30 November 2018, 23:33   #11
gatti
Registered User

 
Join Date: Jul 2018
Location: France
Posts: 30
Bought another adapter with another CF this time at AmigaStore and the problem was the Transcend CF, work like a charm under winuae at full speed but fail on Amiga as soon it is used with ffs or pfs (worked only with OFS from kickstart 3.0) with an Apollo 1230 otherwise it works without the accelerator card
gatti is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this an Apollo 1230 Turbo Mk3 powrslave support.Hardware 4 02 April 2016 03:16
Turbo Turbo 1230-MK2 Schematics IrY100Fan support.Hardware 8 20 August 2015 15:31
Apollo 1230 Turbo (SCSI onboard) ElectroBlaster support.Hardware 0 01 February 2013 15:39
For sale: Apollo 1230 Mk-III Turbo 8MB keropi MarketPlace 15 16 November 2004 15:48
Wanted: 8MB RAM for Apollo 1230 Turbo LC 030 Accelerator Macca MarketPlace 0 09 August 2004 18:18

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:30.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.12775 seconds with 14 queries