English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 02 May 2010, 15:54   #1
Zandig
Registered User
 
Join Date: May 2009
Location: NY / USA
Posts: 226
AGA/ECS centering

Quote:
Originally Posted by Toni Wilen View Post
AGA overscan Workbench = weird display configuration, probably because of horizontal scrolling and AGA fetchmode DDFSTRT limits.
I also have a problem with AGA (fullscreen) and the workbench with every beta and release past 1.6.1

OCS and ECS modes display workbench properly, but AGA messes up the positioning of the workbench screen no matter the settings used. However when a game loads up the positioning of the screen is fine.

Windows XP / SP3
Nvidia 9800GT
Zandig is offline  
AdSense AdSense  
Old 02 May 2010, 16:10   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 20,911
Quote:
Originally Posted by Zandig View Post
I also have a problem with AGA (fullscreen) and the workbench with every beta and release past 1.6.1

OCS and ECS modes display workbench properly, but AGA messes up the positioning of the workbench screen no matter the settings used. However when a game loads up the positioning of the screen is fine.

Windows XP / SP3
Nvidia 9800GT
Does this really have something to do with autoscale? "messes up" isn't a bug report either..
Toni Wilen is online now  
Old 02 May 2010, 16:36   #3
Zandig
Registered User
 
Join Date: May 2009
Location: NY / USA
Posts: 226
Quote:
Originally Posted by Toni Wilen View Post
Does this really have something to do with autoscale? "messes up" isn't a bug report either..
It could be, I'm not really sure?

With 1.6.1 fullscreen with AGA centers the workbench properly. With anything past that the workbench screen is not correct with no filter, null filter, no scaling, automatic scaling, etc. Each setting produces a different and incorrect result for me displaying the workbench. Like I said when a game loads up the screen is fine.

I'll post some pics soon of the different settings so you can see what I'm saying.
Zandig is offline  
Old 02 May 2010, 17:06   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 20,911
Moved. Post "working", "non-working" screenshots and config file.
Toni Wilen is online now  
Old 02 May 2010, 17:11   #5
Zandig
Registered User
 
Join Date: May 2009
Location: NY / USA
Posts: 226
Fullscreen/no filter:


Fullscreen/Null Filter/No autoscale:


Fullscreen/Null Filter/autoscale:


Fullscreen/Null Filter/automatic resize:


Hopefully these will help?
Please let me know if you would like more info.

Thanks Toni.
Zandig is offline  
Old 02 May 2010, 17:57   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 20,911
If you mean border in left side when autoscale is enabled: thats how AGA WB is setup, display really starts earlier than it looks like..

As a workaround you can try adjusting WB overscan and display size preferences.
Toni Wilen is online now  
Old 02 May 2010, 19:18   #7
nikvest
Vertigo User
 
Join Date: Oct 2005
Location: Belgrade/Serbia
Age: 40
Posts: 314
This is the same problem I had.
nikvest is offline  
Old 02 May 2010, 20:12   #8
SailorSat
Registered User
 
Join Date: Jun 2009
Location: Hanau / Germany
Age: 35
Posts: 65
Send a message via ICQ to SailorSat
Hm... The first screenshot looks fine to me, though the workbench seems to be running in 640x512, and the window is only 640x480px
SailorSat is offline  
Old 02 May 2010, 21:31   #9
Zandig
Registered User
 
Join Date: May 2009
Location: NY / USA
Posts: 226
Thank you for the suggestion Toni.

I was able to make my workbench screen perfect using autoscaling and adjusting the overscan and screen size from the workbench preferences.

Happy
Zandig is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
fpga for ecs -> aga turrican3 support.Hardware 17 14 August 2013 00:09
give your best 10 ecs and aga demos turrican3 support.Demos 5 07 November 2010 06:11
Wheelspin ECS & AGA mai HOL contributions 1 05 March 2009 20:36
Rally Championships (ECS/AGA) Bamiga2002 Games images which need to be WHDified 31 30 January 2009 19:33
Heimdall 2 AGA vs ECS PiCiJi support.Games 0 28 September 2005 19:04

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:41.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.22990 seconds with 12 queries