English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 11 August 2018, 00:44   #121
nonarkitten
Registered User

 
Join Date: Jun 2018
Location: Calgary/Canada
Posts: 1
Quote:
Originally Posted by JimDrew View Post
Faster, I believe so. Mike has dropped the FPGA based CPU core idea for Replay 2. It is a hybrid now - using a readily available (upgradeable), high speed, multi-core CPU module to handle CPU core emulations, and a larger FPGA to do just the chipset emulations. <snip>
Jim, the Raspberry Pi CM3 is not high-speed nor even slightly comparable to even a mid-range Core i5 or i7. It is, at best, able to produce a SysInfo score a little better than the Vampire (integer only, it fails rather horribly in FPU). But this does not account for JIT-lag. JIT-lag makes the whole UAE experience feel quite sluggish, despite what the benchmarks might indicate. And without JIT, it runs at least an order of magnitude slower, making it virtually useless unless all you want is a new A1200.
nonarkitten is offline  
AdSense AdSense  
Old 11 August 2018, 07:16   #122
JimDrew
Registered User

 
Join Date: Dec 2013
Location: Lake Havasu City, AZ
Posts: 558
Quote:
Originally Posted by nonarkitten View Post
Jim, the Raspberry Pi CM3 is not high-speed nor even slightly comparable to even a mid-range Core i5 or i7
Yeah, I am glad that idea was scrapped early on.
JimDrew is offline  
Old Yesterday, 00:01   #123
KONEY
Vampire 2 Amiga Musician

KONEY's Avatar
 
Join Date: Jan 2009
Location: Venice - Italy
Posts: 357
Today I flashed this new core and updated SAGA drivers. The procedure went OK but afterwards the system has become very unstable. Basically it would boot normally, work a few minutes then start hanging, mostly during long disk access. This is always ending with a guru, a reboot, a shorter working time then again guru reboot etc. until it freezes completely without booting at all. Switching it off and waiting for some 10 minutes before re-powering will lead again to the begin of the loop.

I never paid too much attention at heat before but I'm pretty sure it's hotter than usual.

It's a Vampire v2 in a A600. Not using HDMI al all.

Any suggesion?
KONEY is offline  
Old Yesterday, 01:02   #124
sean_skroht
Gimmemore Commodore

 
Join Date: Apr 2016
Location: Australia
Posts: 106
Quote:
Originally Posted by KONEY View Post
Today I flashed this new core and updated SAGA drivers. The procedure went OK but afterwards the system has become very unstable. Basically it would boot normally, work a few minutes then start hanging, mostly during long disk access. This is always ending with a guru, a reboot, a shorter working time then again guru reboot etc. until it freezes completely without booting at all. Switching it off and waiting for some 10 minutes before re-powering will lead again to the begin of the loop.

I never paid too much attention at heat before but I'm pretty sure it's hotter than usual.

It's a Vampire v2 in a A600. Not using HDMI al all.

Any suggesion?

You could try adding a self adhesive passive heat sink on top of the FPGA.

You may also need to do the recommended capacitor mod to fix your issue. The video on it can be found here:

[ Show youtube player ]

Add two electrolytic 22uF 10v capacitors (observe the polarity), one at C3 and one at C6.
sean_skroht is offline  
Old Yesterday, 01:16   #125
KONEY
Vampire 2 Amiga Musician

KONEY's Avatar
 
Join Date: Jan 2009
Location: Venice - Italy
Posts: 357
ok, thanks! I didn't know there was such a mod.

However, is it possible that the problem started with the new core?
KONEY is offline  
Old Yesterday, 05:16   #126
sean_skroht
Gimmemore Commodore

 
Join Date: Apr 2016
Location: Australia
Posts: 106
Quote:
Originally Posted by KONEY View Post
ok, thanks! I didn't know there was such a mod.

However, is it possible that the problem started with the new core?

From Gold 2.7 onwards I believe the FPGA is pushed a bit harder and some weaker FPGA's may require the capacitor mod in order to cope. The problem was that the capacitors used at C3 and C6 weren't high enough values and so the fix has become pretty much mandatory for some. This was fixed in Majsta's Vampire 600 V2.1.

With each successive core release things get a bit faster so it becomes more and more apparent that the capacitor fix is necessary.
sean_skroht is offline  
Old Yesterday, 06:22   #127
Kitch
Registered User
 
Join Date: Sep 2011
Location: Christchurch / New Zealand
Posts: 45
Do the "Black edition" Vampires require the capacitor mod as well?
Kitch is offline  
Old Yesterday, 08:43   #128
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 436
"Black Editions" should require it less than normal ones. However, the fix is recommended for all kipper2k and early majsta cards.
grond is offline  
Old Yesterday, 10:42   #129
KONEY
Vampire 2 Amiga Musician

KONEY's Avatar
 
Join Date: Jan 2009
Location: Venice - Italy
Posts: 357
Quote:
Originally Posted by sean_skroht View Post
From Gold 2.7 onwards I believe the FPGA is pushed a bit harder and some weaker FPGA's may require the capacitor mod in order to cope.
Thanks. Digging thru youtube comments I found this link http://forum.apollo-accelerators.com...php?f=9&t=1867 which pretty much summarizes it.

I wish there were more warnings about installing newer cores in early boards because at this point it will take time for me to have the mod done and in the meantime I cannot roll-back to a previous version since flashing takes some two minutes and I cannot trust the system to be stable long enough to finish without crashing and bricking the Vampire... so no Vampire for me for a long time
KONEY is offline  
Old Yesterday, 11:25   #130
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 436
You need a 5€ USB blaster to flash an older core. This works even when the Vampire is bricked.
grond is offline  
Old Yesterday, 14:10   #131
KONEY
Vampire 2 Amiga Musician

KONEY's Avatar
 
Join Date: Jan 2009
Location: Venice - Italy
Posts: 357
Ok, I think any Vampire owner should grab one of these sooner or later. Thanks
KONEY is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vampire Gold Core v2.9 released Sinphaltimus News 39 11 June 2018 11:03
GOLD core released for Vampire 600 V2 guibrush News 23 16 September 2016 04:34
SILVER9 core released for Vampire 600 V2 TuKo News 1 04 August 2016 13:13
SILVER8 core released for Vampire 600 V2 TuKo News 3 02 August 2016 04:13
SILVER3 core released for Vampire 600 V2 TuKo News 4 03 April 2016 14:01

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07338 seconds with 15 queries