English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General

 
 
Thread Tools
Old 10 June 2015, 06:37   #1
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
Question Svn+ssh

Hi all!

I am trying to checkout some code directely from my Amiga to SourceForge (because of SVN) using SVN found on Aminet But everytime I try to checkout using the command given by SF (svn checkout --username=tygre svn+ssh://tygre@svn.code.sf.net/p/amimodradio/code/ amimodradio-code), SVN replies:

Quote:
SSH: Error reading public key packet.
SSH: Connection to 'tygre@svn.code.sf.net:22' failed.
and then the Guru visits me

SnoopDOS tells me that:

Quote:
Count Process Name Action Target Name Options Res.
----- ------------ ------ ----------- ------- ----
7 [18] Shell Process Open svn Read OK
8 [18] svn OpenLib utility.library Ver 37 OK
9 [18] svn GetVar SVN_STACK_SIZE Any OK
10 [18] svn Open CONSOLE: Write OK
11 [18] svn OpenLib mathieeesingbas.library Ver 33 OK
12 [18] svn OpenLib mathieeedoubbas.library Ver 33 OK
13 [18] svn OpenLib mathieeedoubtrans.library Ver 33 OK
14 ramlib Load LIBS:mathieeedoubtrans.libr OK
15 ramlib Open LIBS:mathieeedoubtrans.libr Read OK
16 ramlib OpenLib mathieeedoubbas.library Ver 0 OK
17 [18] svn OpenLib bsdsocket.library Ver 3 OK
18 [18] svn OpenDev timer.device Unit 0 OK
19 [18] svn FindVar DISABLE_COMMANDLINE_WILDCAR Local Fail
20 [18] svn OpenDev timer.device Unit 1 OK
21 [18] svn OpenLib locale.library Ver 38 OK
22 [18] svn OpenLib usergroup.library Ver 0 OK
23 [18] svn Open subversion:servers Read Fail
24 [18] svn Open subversion:config Read Fail
25 [18] svn OpenLib amisslmaster.library Ver 3 OK
26 ramlib Load LIBS:amisslmaster.library OK
27 ramlib Open LIBS:amisslmaster.library Read OK
28 [18] svn OpenLib libs:amissl/amissl_v097g.li Ver 3 OK
29 ramlib Load libs:amissl/amissl_v097g.li OK
30 ramlib Open libs:amissl/amissl_v097g.li Read OK
31 [18] svn OpenLib intuition.library Ver 36 OK
32 [18] svn OpenLib utility.library Ver 37 OK
33 [18] svn OpenLib locale.library Ver 38 OK
34 [18] svn GetVar SVN_SSH Any Fail
35 [18] svn Open subversion:sshconfig Read OK
36 [18] svn Open S:GuruHistory Read OK
What am I doing wrong? Has anyone succeeded in using SVN+SSH from the Amiga? Maybe I am using the wrong OpenSSH version?

Thanks in advance!
tygre is offline  
AdSense AdSense  
Old 11 June 2015, 18:49   #2
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
Hi all!

Anyone has an idea? Or an alternative?

Cheers!
tygre is offline  
Old 11 June 2015, 19:21   #3
phx
Natteravn

phx's Avatar
 
Join Date: Nov 2009
Location: Herford / Germany
Posts: 1,041
This svn port only supports SSH v1, but maybe SourceForge requires SSH v2?

Do you really need SSH encryption when checking out from a public SVN server? Did you try without?
phx is offline  
Old 11 June 2015, 19:29   #4
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
Hi Phx!

Thanks for your reply!

Yes, as far as I understand from this page, SF accepts SSHv1 and it seems that I need SSH to commit but maybe I am mistaken?

What do you think?
tygre is offline  
Old 12 June 2015, 12:44   #5
phx
Natteravn

phx's Avatar
 
Join Date: Nov 2009
Location: Herford / Germany
Posts: 1,041
Yes, the page you are referring to says that v1 should be supported. But there from the error message there seems to be a problem in the protocol. Looking at the source I would say that the SSH-connection with SF does not return the number of bytes for a public key packet which your svn-client expected.

From time to time I am using CVS on SF and this works. No chance to change to CVS?

When you can, you should also check if your svn-repository works with svn-clients on other operating systems.
phx is offline  
Old 12 June 2015, 16:23   #6
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
@phx

Thanks for your answer! Yes, of course I could use CVS, why didn't I think about it, will try tonight!

(Will also try my repo with another SVN client on Windows...)

Cheers!
tygre is offline  
Old 13 June 2015, 19:23   #7
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
Hi there!

So, I tried further SVN+SSH and HTTPS and CVS and I seem to hit a wall each time

Following the instructions here, I generate my public/private key pair and submitted my public key at SourceForge.

SVN+SSH
Interestingly, I can connect to a shell on SourceForge using
Code:
ssh -t tygre,AmiModRadio@shell.sourceforge.net create
So I think that I have installed everything correctly, including the certificate 594f1775.0 that I found here at SourceForge to replace the one supplied with AmiSSL.

But:
Code:
SetEnv SVN_STACK_SIZE 500000
svn checkout --username=tygre https://tygre@svn.code.sf.net/p/amimodradio/code .
returns
Code:
svn: PROPFIND request failed on '/p/amimodradio/code'
svn: PROPFIND of '/p/amimodradio/code': Certificate verification error: certificate failure (https://svn.code.sf.net)
And:
Code:
SetEnv SVN_STACK_SIZE 500000
svn checkout --username=tygre svn+ssh://tygre@svn.code.sf.net/p/amimodradio/code .
returns
Code:
Password for tygre@svn.code.sf.net:
SSH: Error reading public key packet.
SSH: Connection to 'tygre@svn.code.sf.net:22/ failed.
and then the Guru comes for a visit: task "svn", cause "Illegal instruction"

CVS
Following the instructions, I execute the command
Code:
SetEnv CVS_RSH=ssh 
cvs -z3 -d:ext:tygre@amimodradio.cvs.sourceforge.net:/cvsroot/amimodradio checkout code
and get:
Code:
cvs checkout: :ext: method not supported by this port of CVS
cvs [checkout aborted]: try :server: instead
So, I try using both :server: and : pserver: (without space, I put a space here not to have a smiley) but to no avail... anyways, I cannot add CVS to my project, it is not available in the admin page of the project, only Git and SVN are (and Mercurial and other stuff) as confirmed here.



I would appreciate any help/suggestion! How can I share my code? I actually don't care about SourceForge or GitHub or whatnot... just want to share my code from my Amiga

Thanks!
tygre is offline  
Old 13 June 2015, 23:08   #8
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,125
maybe not the solution, but something you can try as written here.
on that page look for the "(28) ... .subversion/auth" issue - not the whole unix stuff, but the auth file / the cached server in that folder/file you try to connect to.
if this exists, delete the entry and reconnect.

Last edited by emufan; 13 June 2015 at 23:13.
emufan is offline  
Old 14 June 2015, 12:21   #9
phx
Natteravn

phx's Avatar
 
Join Date: Nov 2009
Location: Herford / Germany
Posts: 1,041
Bad news... but I think the mystery is solved!

Today I tried my CVS client with SSH to check out a SF project and got the same error as you do: "SSH: Error reading public key packet (0, )." Even "cvs update" on my existing source on local disk no longer worked. And I am sure that I committed code to the sditools/fd2pragma project in May!

So it must be broken at the SF-side since a few days. My guess is that they finally disabled SSHv1, because it is exactly the same error message which I get with a private CVS-server which allows SSHv2 only...
phx is offline  
Old 15 June 2015, 00:39   #10
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
@emufan

Thanks for your suggestion! Unfortunately, it did not help :-(

@phx

Aaaargh! So, any idea how/where I could commit my code?

I thought that AmiSSL supported up to v3?

Thanks!
tygre is offline  
Old 15 June 2015, 01:21   #11
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,125
Quote:
Originally Posted by tygre View Post
@emufan
Thanks for your suggestion! Unfortunately, it did not help :-(
*removed the ssl/tls test , since not usefull here*

Edit: i guess i confused myself over those protocols.
at least you can try to make the console ouput a bit more verbose by using something like: ssh -v // ssh --verbose // svn -v ... if available.

Last edited by emufan; 15 June 2015 at 02:04.
emufan is offline  
Old 15 June 2015, 13:32   #12
phx
Natteravn

phx's Avatar
 
Join Date: Nov 2009
Location: Herford / Germany
Posts: 1,041
Quote:
Originally Posted by tygre View Post
Aaaargh! So, any idea how/where I could commit my code?
I'm using my own server, which is sitting on a static internet connection.
I wonder why nobody is offering a public CVS/SVN service for Amiga users/projects. Alternatively you can set up your own server. It is not difficult to make a CVS- or SVN-server work.

Quote:
I thought that AmiSSL supported up to v3?
I didn't need AmiSSL at all, when it still worked. And I also didn't create and upload a key, but typed the SSH password everytime.
phx is offline  
Old 15 June 2015, 20:53   #13
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
@phx

Quote:
Originally Posted by phx View Post
I'm using my own server, which is sitting on a static internet connection. I wonder why nobody is offering a public CVS/SVN service for Amiga users/projects. Alternatively you can set up your own server. It is not difficult to make a CVS- or SVN-server work.
Thanks for the idea! But I would have really preferred some "known" service... maybe there is a business to start right there: hosting for Amiga projects

Quote:
Originally Posted by phx View Post
I didn't need AmiSSL at all, when it still worked. And I also didn't create and upload a key, but typed the SSH password everytime.
Ah, but still it does not work anymore, does it?

Cheers!
tygre is offline  
Old 06 September 2015, 06:55   #14
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 537
PS. I am now using AMTelnet and a Raspberry PI to version...
tygre is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSH with NapsaTerm says "no pwentry" tygre support.Apps 12 21 December 2015 21:54

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:07.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.28697 seconds with 14 queries