English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 02 October 2019, 03:04   #1
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Where is the history of mounted CDs saved?

Where is this list saved?

hexaae is offline  
Old 02 October 2019, 08:19   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,123
Registry or ini file (if in use).
Toni Wilen is offline  
Old 02 October 2019, 12:04   #3
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Found in HKEY_CURRENT_USER\Software\Arabuusimiehet\WinUAE\CDImageMRUList
How do I enable INI instead of Registry?
hexaae is offline  
Old 02 October 2019, 12:11   #4
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 42
Posts: 15,117
Quote:
Originally Posted by hexaae View Post
Found in HKEY_CURRENT_USER\Software\Arabuusimiehet\WinUAE\CDImageMRUList
How do I enable INI instead of Registry?
Tick "Portable mode" from under the "Paths" section
DamienD is online now  
Old 02 October 2019, 12:20   #5
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Thank you!
hexaae is offline  
Old 02 October 2019, 16:06   #6
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Errr… I switched to INI and cleaned up the list (deleted lines), and have no idea what happened but WinUAE now won't read .nrg CD images anymore (CD0: Uninitialized)… other formats (ISO, bin, etc.) are ok. Both in SCSI and SCSI + SPTI
Ideas?

Last edited by hexaae; 02 October 2019 at 16:15.
hexaae is offline  
Old 02 October 2019, 16:48   #7
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
@Toni
Looks like a Relative and Absolute path issue. Unticked Releative paths and NRG are correctly opened again!

EDIT:
From INI file…

Working example:
[CDImageMRUList]
Image01=C:\Users\Luca\WinUAE\WinUAE files\download - amiga\cds\LandOfGenesis.nrg

NOT working:
[CDImageMRUList]
Image01=.\WinUAE files\download - amiga\cds\LandOfGenesis.nrg

Last edited by hexaae; 04 October 2019 at 13:59.
hexaae is offline  
Old 04 October 2019, 13:59   #8
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
...It's not even a problem with saved path for images. WinUAE fails to read .nrg CD images in general when in WinUAE GUI I set Paths\Use relative paths and launch the emulation. Seems a WinUAE bug in short.
hexaae is offline  
Old 04 October 2019, 17:45   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,123
I think you are forgetting something 100% required. There surely is something in the log..
Toni Wilen is offline  
Old 05 October 2019, 12:23   #10
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Attached the file log: https://gofile.io/?c=Sltul0

Repro steps:
- tick from WinUAE GUI Paths/Use relative paths
- start emu and boot into WB
- insert from CD & Hard drives an .nrg CD image (I have Land of Genesis and Genetic Species)
Results: unrecognized data CD part.




Last note… I use to store Amiga CD images in a compressed folder under Windows, but all other bin, iso etc. images from this dir are correctly opened by WinUAE even with Use relative paths enabled:


Last edited by hexaae; 05 October 2019 at 12:37.
hexaae is offline  
Old 05 October 2019, 16:13   #11
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,123
Should be fixed now.
Toni Wilen is offline  
Old 05 October 2019, 18:36   #12
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,344
Confirmed!
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help getting a OS X Panther directory mounted skateblind support.OtherUAE 15 20 February 2009 17:59
Mounted CD32 Images Viceroy support.WinUAE 2 25 January 2009 11:21
Shell: test if a volume is mounted z00mba support.Apps 2 17 June 2006 12:28
Double Harddrives mounted icreadence support.WinUAE 5 21 April 2005 19:28
Socketed vs Surface mounted mobos Firthy2002 support.Hardware 6 06 September 2004 20:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:50.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09786 seconds with 13 queries