English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 13 January 2017, 11:00   #1
WildW
 
Posts: n/a
WinUAE Galaga 92 screen glitching

Has anyone any experience with the minor masterpiece game Galaga 92 on WinUAE? While my real A1200 is waiting for repairs I thought I'd see how emulation feels again and fired up this game only to get game-breaking screen glitching. I updated WinUAE to the latest with no improvement.

The whole screen is flashing green every few frames, both on the title screen and during gameplay. Additionally, scrolling text at the bottom of the screen is being pushed off the bottom of the screen and only the top of the letters is visible. I tried tweaking many display settings in WinUAE but nothing improved matters. Fullscreen and windowed is the same.

This was on a WHDLOAD version of the game that runs perfectly on my real A1200. WinUAE is set to emulate an A1200, and I haven't yet tried running a different version of the game or emulating an A500.
 
Old 13 January 2017, 12:22   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,107
What kind of A1200 config? Too fast emulation mode (at least without immediate blitter) can break lots of games.
Toni Wilen is offline  
Old 13 January 2017, 12:34   #3
WildW
 
Posts: n/a
Couldn't give any real details until I'm home, but nothing exciting. I seem to think I have just standard A1200 / AGA / 2MB Chip + 8MB Fast / normal A1200 speed selected, but I don't remember what settings there are. Will report back when I know more.
 
Old 13 January 2017, 12:47   #4
Steve
Truth seeker...
Steve's Avatar
 
Join Date: Jul 2001
Location: UK
Age: 40
Posts: 2,235
Try turn off JIT setting.
Steve is offline  
Old 14 January 2017, 00:43   #5
WildW
 
Posts: n/a
Enabling Cycle-Exact under Chipset has solved this. Not sure why I didn't have this checked before. Messing with the Filters page has sorted the remaining display issues, guess it was an overscan thing.
 
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Deluxe Galaga on Amiga Forever 2013/WinUAE problem letsplayac support.Games 3 29 August 2013 21:22
Black screen in full screen but not full window Winuae all versions Mixter support.WinUAE 18 30 June 2013 01:45
Deluxe Galaga on WinUAE 2.3.0 Coagulus support.WinUAE 2 12 January 2012 22:00
winuae screen otro support.WinUAE 2 18 April 2005 16:56
WinUAE screen LaundroMat support.WinUAE 5 06 April 2002 18:08

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:19.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.09130 seconds with 15 queries