English Amiga Board


Go Back   English Amiga Board > Support > support.Amiga Forever

 
 
Thread Tools
Old 21 January 2017, 15:28   #1
chocsplease
Registered User

 
Join Date: Dec 2016
Location: london
Posts: 168
[Solved] Amiga explorer wont recognise a USB to serial adaptor on com 3:

Hi

The title kind of says it really. I have installed Amiga explorer on a windows 10 laptop which does not have a com: port. I've plugged a USB to serial adaptor in and this has been recognised as com3: in device manager.

However when I try to configure Amiga explorer to use serial it only gives the option of tcpip in the drop down. Try as I might I cannot get it to recognise the USB to serial adaptor on com3

Can anyone suggest how to get around this? Are there any switches I can use to force Amiga explorer into serial mode?

Thanks in advance.

<edit>

OK I've managed to solve this, though I am not quite sure why.

It appears that I have to run Amiga Explorer in an Admin account in order for it to pick up the USB to serial com3. Doing this now sets the communication option to just com3 (you cannot select tcpip).

I have no idea why this should be but leave this post just in case someone has a similar problem in future.

System:
OS Name Microsoft Windows 10 Home
Version 10.0.14393 Build 14393
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name <redacted>
System Manufacturer TOSHIBA
System Model SATELLITE L50-B
System Type x64-based PC
System SKU Type1Sku0
Processor Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz, 1800 Mhz, 2 Core(s), 4 Logical Processor(s)

Last edited by chocsplease; 21 January 2017 at 21:18.
chocsplease is offline  
Old 30 January 2017, 01:28   #2
ancalimon
Supernormal

ancalimon's Avatar
 
Join Date: Jul 2007
Location: Istanbul / Turkey
Age: 37
Posts: 1,229
When it does not work, start as admin. You never know what windows has in mind
ancalimon is offline  
Old 13 February 2017, 10:38   #3
amiga_Forever
Users Awaiting Email Confirmation
 
Join Date: Mar 2011
Location: kkhkj
Posts: 323
From memory : COM1 shared with COM3, and COM2 shared with COM4..

Not sure if these issue still exists today. or PCI eliminated them.
amiga_Forever is offline  
Old 21 June 2017, 05:57   #4
jlin_au
Registered User
 
Join Date: Nov 2016
Location: Fadden ACT Australia
Posts: 25
Try
1) rebooting your laptop with the USB to serial adapter still inserted see if amiga explorer can see the device COM port after the reboot.
2) selecting the usb to serial device in Windows 10's device manager and change the assigned com port from COM3 to COM1, 2, 4, or even COM5 and see if amiga explorer can now see the device's new com port.
If the above fails then the issue is probably with your version of Amiga Explorer looking for the physical COM port hardware instead of the virtual COM port created by the USB to serial interface Windows 10 driver. Try installing the latest version of Amiga Explorer.

See http://www.amigaforever.com/ae/ to download latest Amiga Explorer; make sure that
a) you download the 32 bit or 64 bit version to match your Windows 10 32 bit or 64 bit version (see http://www.amigaforever.com/kb/14-109 ).
b) you only install Amiga Explorer via a Windows 10 administrator account.

The license key to use for the new install is either your current key for Amiga Forever or your separate Amiga Explorer key.

Last edited by jlin_au; 21 June 2017 at 06:10. Reason: Additional info
jlin_au is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best USB serial to use with Amiga Explorer..? spannernick support.Hardware 6 27 April 2016 10:32
usb (rs232) to amiga serial cable - no COM selection in amiga explorer Galder support.Hardware 5 04 May 2014 17:14
Serial to usb + Amiga Explorer? r0ber7 support.Hardware 2 14 August 2011 14:20
i have a CD32 that wont recognise expansions Gordon support.Hardware 4 29 March 2011 17:49
Amiga Explorer wont work right! chaoticjelly New to Emulation or Amiga scene 4 10 September 2004 22:38

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.05851 seconds with 15 queries