English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 19 March 2018, 23:59   #1
chiark
Needs a life

chiark's Avatar
 
Join Date: Jan 2008
Location: England
Posts: 1,629
3.6.1 RTG Crashes winUAE...

My config crashes and creates a crash dump on 3.6.1 32 bit when I enable RTG for Piccolo SD64 in Z3 mode. The hard file has EGS installed. With 3.6.1 x64 WinUAE crashes and windows stops execution of WinUAE.

Works fine on 3.6.0 32 bit.

None of the 64 bit versions seem to give me anything with my config that works on 32bit: I just get a black screen whenever Piccolo SD64 RTG card is enabled with the hardfile. All boot fine without that card...

The 64 bit versions prior to 3.6.0 show a black screen but emulation is still running as df0: is changing from track 2 to 3 repeatedly.

Logs and dmp attached for 32 bit crash of 3.6.1.
Attached Files
File Type: txt winuaelog.txt (41.8 KB, 18 views)
File Type: txt winuaebootlog.txt (11.0 KB, 17 views)
File Type: dmp winuae_3.6.1_R_2018.03.19_21.51.54.dmp (153.6 KB, 14 views)
chiark is offline  
Old 21 March 2018, 15:11   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
It is a stupid bug in 3.6.1 introduced bounds checking, EGS apparently does blits quite differently, at least when using SD64 driver.

I'll check other problems later, which EGS version?
Toni Wilen is offline  
Old 22 March 2018, 12:40   #3
chiark
Needs a life

chiark's Avatar
 
Join Date: Jan 2008
Location: England
Posts: 1,629
Thanks Toni! egs.library is v7.9, and the readme.egs has the date 27 May 1994 in it. Cutting edge - it's from the install disks with the SD64, and I can zip/send it if it helps.
chiark is offline  
Old 25 March 2018, 13:46   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
I don't have working EGS installation (I had one but it got broken..).

Does http://www.winuae.net/files/b/winuae.7z and winuae64.7z at least fix the crash?
Toni Wilen is offline  
Old 25 March 2018, 18:55   #5
chiark
Needs a life

chiark's Avatar
 
Join Date: Jan 2008
Location: England
Posts: 1,629
Thanks Toni, I'll check this evening and let you know. I can send you a working HDF if that would help?
chiark is offline  
Old 26 March 2018, 21:52   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,129
If HDF is "plain" enough and does not have too much extra stuff.
Toni Wilen is offline  
Old 26 March 2018, 23:34   #7
chiark
Needs a life

chiark's Avatar
 
Join Date: Jan 2008
Location: England
Posts: 1,629
That beta fixes the crash in 3.6.1 - thanks! 32 bit works right out of the box.
If I run 64 I still get a black screen, but on checking settings the A3k quickstart based setup I'd created was using AGA - I daresay that didn't help things much. Putting that back to ECS and all is good, the beta works. Weird that it works on the 32 bit with AGA.

The config file was written with 3.6.1 (config version=3.6.1) but checking again it seems that quickstart a3k correctly sets chipset to full ECS. Not quite sure what happened there.

I'll strip the HDF back to something more plain - let me know where to put it - as it may be useful for testing in the future if you ever need to test EGS again.
chiark is offline  
Old 08 April 2018, 19:36   #8
methodman
Registered User
 
Join Date: May 2010
Location: Redding USA
Posts: 103
Should I be running both a 32 and 64 bit version on Winuae. I am only using the 64 bit. I didn't think the 32 bit would even run on my computer and I don't see an option when installing uae to load it as a 32 bit.
methodman is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
rtg.library 40.3994 crashes if uaegfx is not loaded thomas support.WinUAE 3 24 April 2011 22:48
WinUAE crashes tahseen support.WinUAE 7 13 November 2007 21:48
Two WinUAE crashes thor support.WinUAE 5 06 November 2007 21:15
WinUAE 1.2 Crashes Anubis support.WinUAE 6 27 February 2006 20:05
Winuae 0.8.24 crashes... Piramania support.WinUAE 8 08 February 2004 17:33

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:38.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06847 seconds with 14 queries