English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. AMOS

 
 
Thread Tools
Old 28 July 2016, 02:56   #1
Blackgoat
Registered User
 
Join Date: Feb 2016
Location: Czech Republic
Posts: 26
Still some bad flickering remains...

[ Show youtube player ]

Generally, it run ok, only characters bob flicker if it appears in area approx. 100 pixels from top of the screen. Don't have any idea why. If I mess with order of bob update, screen swap, wait vbl etc. it only get worse. Why only in top border of the screen? Screen have size 800*656 pixels, its okay for AMOS to handle, imho.
Blackgoat is offline  
AdSense AdSense  
Old 28 July 2016, 03:29   #2
Retro1234
Bo Bo

Retro1234's Avatar
 
Join Date: Jun 2006
Location: 5150
Posts: 3,872
I like your demo - ive never seen that type of flicker - all I can say is I am having some flicker since I updated my graphics driver recently but I use a different emulator, so maybe emulator issue.
Retro1234 is offline  
Old 28 July 2016, 10:57   #3
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,327
Are we talking about emulation or a real machine?
idrougge is offline  
Old 28 July 2016, 13:43   #4
roondar
Registered User

 
Join Date: Jul 2015
Location: The Netherlands
Posts: 273
Now, I can't be 100% sure, but this looks a lot like you got the order of the double buffer swaps wrong. It looks like you're showing the buffer you are drawing to instead of the one that is ready to be shown.
roondar is offline  
Old 28 July 2016, 18:31   #5
Blackgoat
Registered User
 
Join Date: Feb 2016
Location: Czech Republic
Posts: 26
Solved, I made some monster of program which accidentally combine screen offset hardware scroll I am working with now, and "screen copy physic to logic" method with which I begin a I forgot that procedures from is is still active :-) when I clear program from old code, it run without flickering and fast enough.
Blackgoat is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kick off 2 flickering msayed1977 support.WinUAE 24 05 April 2013 20:42
Apologies for the language, the issue remains fmcpma2 support.WinUAE 2 19 October 2009 18:14
hires flickering... sometimes Tony Landais support.WinUAE 11 17 July 2006 16:10
Bad MCP, BAD! Akira support.Apps 14 22 August 2003 16:23
Flickering sprites Mr Softy support.WinUAE 2 17 December 2002 12:56

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:27.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.05938 seconds with 15 queries