English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 18 October 2019, 12:15   #1
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,390
WinUAE issue with Windows when "Minimize when focus is lost"

Hi Toni,
it happens sometimes that you can't switch back to Windows desktop because of special WinUAE settings:
  • you set in WinUAE Miscellaneous > Minimize when focus is lost + Pri. & Extensions like this





The problem is that WinUAE (in full-window) won't minimize when you closed ALL apps from Windows with a Alt+TAB, and sometimes it happened to me that keyboard from Windows wasn't detected anymore, not even Ctrl+Alt+Del (!) probably because WinUAE still got in control of keyboard input, but at the same time I couldn't switch back to WinUAE task with unresponsive keyboard from within Windows! Even mouse clicks to re-activate WinUAE window didn't work anymore!

Win10 tutorial to set mousewheel for all windows under mouse pointer:
https://www.tenforums.com/tutorials/...dows-10-a.html

WinUAE version 4.3.0 beta

Last edited by hexaae; 18 October 2019 at 12:58.
hexaae is offline  
Old 18 October 2019, 19:11   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 44
Posts: 23,291
Thats weird Windows behavior (nothing new), program immediately gets "you are active" message when there is no other program and program was switched with ALT-TAB. I am not sure if this is how it is supposed to work or if there is some weird trick that needs to be used.. There are other programs that have same behavior.

btw, don't mention betas unless it really only happens with it.
Toni Wilen is offline  
Old 21 October 2019, 19:07   #3
hexaae
Registered User
hexaae's Avatar
 
Join Date: Jul 2006
Location: Italy
Age: 43
Posts: 1,390
Quote:
Originally Posted by Toni Wilen View Post
program immediately gets "you are active" message when there is no other program and program was switched with ALT-TAB
...the strange thing is that in this case, Windows mouse pointer is not caught again by WinUAE... so I see Windows mouse pointer over WinUAE full-window but can't click and fully switch back to WinUAE actually. Still have to find a reproducible pattern but it happened at least 3 times...

Would be "ok" if the program from where you started ALT+TAB gets back "active status" in case there are no other windows to switch to, but the problem is that sometimes Win input (LMB, RMB, keyboard...) is suspended (looks like WinUAE input hook is handling them but you see moveable Windows mouse pointer and WinUAE window in not active, hence you can't reactivate it!).... weird Win issues indeed...

Last edited by hexaae; 21 October 2019 at 19:16.
hexaae is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
"Voices8" 8 Channel Soundtracker "DemoSongI" song - "This is the Amiga with 8 Voices" DemosongIHunter request.Music 44 27 October 2019 20:04
I've "lost" my floppy drive Retrofan support.Other 27 12 May 2012 22:44
Long "lost" A1200 reunited with his owner (!! lots of pictures !!) Zapotek Hardware pics 14 05 July 2011 15:52
HELP, lost my WORK: partition "not a dos disk" paul773car support.Hardware 34 25 June 2010 22:08
"The Lost Treasures of Infocom" Compilation (english) for SALE bastibs MarketPlace 0 12 December 2007 18:51

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06144 seconds with 15 queries