English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 08 August 2018, 15:31   #1
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
x86 Bridgeboard update (PCem core)

New bridgeboard thread. (old thread: http://eab.abime.net/showthread.php?t=76395)

Bridgeboard emulation now uses following PCem "parts":

- CPU
- Interrupt controller (PIC)
- Timer (PIT)
- DMA controller
- NVRAM (286+)
- Memory and IO mapping.
- PC Speaker (enable option in Bridgeboard expansion GUI)
- Sound Blaster (Multiple variants, Expansion GUI, see below)

Previously emulated hardware still supported:

- VGA.
- XTIDE.
- NE2000.
- Floppy controller. (may be replaced with PCem version later)

Notes:

- FPU is not available (it looks like PCem only supports it if 486+?)
- A2386SX probably still isn't any more compatible because VLSI chipset used is not yet emulated in PCem.
- Speed is slower than previously, most likely because previously it was far too fast. Speed adjustment will be added later.
- Sound Blaster is totally untested, PC Speaker confirmed to make sound.. Because all supported SB models are in single expansion panel hardware option, not all options are specific to selected SB model. You MUST know how to configure SB. Do not expect GUI defaults are valid!
- Because IO/memory mapping is more flexible in PCem, bridgeboard IO mapping is now fully dynamic which may fix some previously weirdly working PCPrefs bridgeboard configurations.
- Do not skip directly to SB and assume everything else still works! Make sure previously installed disks/HDs still work. PC Speaker must be tested first! It must be done step by step!

EDIT:

- Do not click Restart or load new config on the fly! Always quit and restart whole emulator!
- TODO: A2386SX shadow/ems mapping register support should be relatively easy to implement with PCem RAM mapping system.

EDIT2:

- A2386SX shadow/ems mapping implemented (mostly)
- SB16 MPU-401 interface added from PCem (maps to IO Ports panel selected MIDI out port)

EDIT3:

- RTC date sync
- CPU panel speed adjustment works now (except Max which probably can't work with PCem, it would break CPU/timer sync)

EDIT4:

- PC Speaker and Sound Blaster working.
- PC Serial mouse emulated, currently hardwired to selected Amiga mouse.

When using VGA board, remember to configure it to use Monitor 2 (RTG panel). No need for annoying END+F9 swapping.

WARNING: This is not PC/DOS/SB (configuration) help thread! You must know how to configure IO ports, IRQ etc!

http://www.winuae.net/files/b/winuae.7z

Last edited by Toni Wilen; 12 August 2018 at 20:35.
Toni Wilen is online now  
Old 08 August 2018, 17:57   #2
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Wow thanks Toni! Will test thoroughly and methodically and get back to you with results. BTW today is my birthday, can't think of a better bday present than to try out this stuff
superfrog is offline  
Old 08 August 2018, 23:38   #3
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Well on first inspection there seems to be a problem with the config file generation, because when I tried to use the WinUAE GUI to generate a brand new config with bridgeboard from scratch, I got the "Couldn't Find Library" error when trying to open a PC Window. When I used a config file generated by the latest stable version of WinUAE, the BridgeBoard behaved as expected. But when I changed that config to enable PC Speaker support, saved the config, and then booted the emulator, I again got the "Couldn't Find Library" error. Seems that the GUI is doing something to the config file that makes the BridgeBoard unrecognized? If you want I can try to create a working config with stable and a broken config file with beta and then diff them
superfrog is offline  
Old 08 August 2018, 23:38   #4
1time
Amiga Lover

1time's Avatar
 
Join Date: Jan 2010
Location: Stockholm / Sweden
Age: 40
Posts: 606
Ohh my god this will be fun to test =)

Thank you Toni!
1time is offline  
Old 09 August 2018, 08:12   #5
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Ok never mind my last post about the config file. I was making a dumb mistake that caused the library error. However, I am running into issues with the BridgeBoard not coming up when then PC Speaker is enabled. I need to do more testing to describe exactly what's going on. Will be back in a bit...
superfrog is offline  
Old 09 August 2018, 08:55   #6
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
More details? Freezes completely? Amiga side binddrivers call never returns but mouse still moves? VGA screen opened?

Probably sound emulation related, try switching off sound automatic switch (if enabled).

(Still implementing A2386SX memory mapping stuff. himem.sys and EMS386 probably should work when done)
Toni Wilen is online now  
Old 09 August 2018, 09:14   #7
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,373
Toni link does not work: http://www.winuae.net/files/b/winuae.7z
AMIGASYSTEM is offline  
Old 09 August 2018, 09:59   #8
lilalurl
Global Moderator
lilalurl's Avatar
 
Join Date: Aug 2001
Location: France
Age: 39
Posts: 2,894
Send a message via ICQ to lilalurl
Quote:
Originally Posted by AMIGASYSTEM View Post
It seems like www.winuae.net is not reachable right now.

So, you'll have to wait either until it is fixed or until someone uploads the archive to the zone.
lilalurl is online now  
Old 09 August 2018, 11:56   #9
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
Site works again. A2386SX shadowing/ems should at least in theory work now (another not really tested because I don't want to touch dos too much..)

EDIT: At least dos 6.22 himem.sys does not hang anymore.

Last edited by Toni Wilen; 09 August 2018 at 12:39.
Toni Wilen is online now  
Old 09 August 2018, 14:13   #10
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 557
Quote:
Originally Posted by Toni Wilen View Post
Bridgeboard emulation now uses following PCem "parts":

- CPU
- Interrupt controller (PIC)
- Timer (PIT)
- DMA controller
- NVRAM (286+)
- Memory and IO mapping.
- PC Speaker (enable option in Bridgeboard expansion GUI)
- Sound Blaster (Multiple variants, Expansion GUI, see below)

Very nice, Toni.
Sound Blaster support?!
As soon as I'm back from vacation I will test it.
AnnaWu is offline  
Old 09 August 2018, 17:03   #11
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Okay simplest test case comparison. Two configs, only difference is working has PC speaker disabled, broken has PC speaker enabled.


Working case, I boot with BB Install floppy v2.0 (Known Verified Dump [!] downloaded from Internet Archive TOSEC) and it boots, I open PC Mono, PC window opens as expected.


Broken case, I boot same floppy, long pause right after x86 in status bar switches from STOP to RUN (this is exactly when BindDrivers is trying to load janus.library because date displays immediately after long pause, and setclock is first command following BindDrivers in startup-sequence), after long pause continues to boot to WB screen. Then when I open PC Mono, I get Cannot Find Library error.

By "sound automatic switch" you mean "Automatic Switching" in sound config panel? Switching that off doesn't affect outcome of this test.
Attached Files
File Type: uae PC Speaker Test Broken.uae (12.1 KB, 30 views)
File Type: uae PC Speaker Test Working.uae (12.1 KB, 30 views)

Last edited by superfrog; 09 August 2018 at 17:16.
superfrog is offline  
Old 09 August 2018, 17:36   #12
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
Quick workaround: add Z2 Fast RAM (or any autoconfig board that is before Bridgeboard). Sound reset forgets that stream has been allocated and if there is no other boards, bridgeboard initializes before sound.

Correct fix comes later..
Toni Wilen is online now  
Old 09 August 2018, 19:05   #13
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Okay adding a Z2 autoconfig board before BridgeBoard fixes janus library init problem. I added Z2 fast RAM and also used custom ordering to move the A2091 SCSI controller above the A2088 in my test environment that includes HD. PC window opens and DOS boots. However, I still get no sound output from the speaker. Simplest test, just type "echo ^G" at DOS prompt, or start GWBASIC and print "^G". I hear no beeps.
superfrog is offline  
Old 09 August 2018, 19:14   #14
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
Quote:
Originally Posted by superfrog View Post
Okay adding a Z2 autoconfig board before BridgeBoard fixes janus library init problem. I added Z2 fast RAM and also used custom ordering to move the A2091 SCSI controller above the A2088 in my test environment that includes HD. PC window opens and DOS boots. However, I still get no sound output from the speaker. Simplest test, just type "echo ^G" at DOS prompt, or start GWBASIC and print "^G". I hear no beeps.
Should be fixed now. (Only AT systems had working speaker).
Toni Wilen is online now  
Old 09 August 2018, 19:37   #15
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Did you post a new binary? The link above still gives me the public beta from yesterday, nothing has changed.

I haven't even tried testing AT BridgeBoards yet. I'll do some testing with the AT boards and let you know what I find.

Last edited by superfrog; 09 August 2018 at 19:49.
superfrog is offline  
Old 09 August 2018, 19:38   #16
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 21,727
You got cached copy. It happens regularly. Use another browser etc.. I have no control of this.
Toni Wilen is online now  
Old 09 August 2018, 21:25   #17
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Quote:
Originally Posted by Toni Wilen View Post
Should be fixed now. (Only AT systems had working speaker).

The XT systems had a jumper (usually designated J2) for attaching a speaker. The A2386SX was the only BB model that had an actual speaker mounted on the PCB.
superfrog is offline  
Old 09 August 2018, 23:20   #18
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
With the new beta, I still get lockup and failure to load janus.library on boot without another Z2 before BB. With extra Z2, I can boot the BB startup disk, open PC Mono window, boot DOS 3.3 floppy and get a DOS prompt. When I type "echo ^G" I do get a beep, but I also get a little click sound with every keystroke. Also, it makes a strange bleeping noise on bootup. Not sure if that was normal behavior with real BB.
superfrog is offline  
Old 10 August 2018, 00:15   #19
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
When I try to boot up with same config, but with A2286 instead, it just crash dumps shortly after booting the BB Install floppy. Crash happens with speaker enabled or not. I've attached 2 config files and the crash dump file.
Attached Files
File Type: uae PC Speaker Test A2088.uae (12.0 KB, 31 views)
File Type: uae PC Speaker Test A2286.uae (12.2 KB, 30 views)
File Type: dmp winuae_4.1.0_b0_2018.08.09_15.09.36.dmp (125.3 KB, 25 views)
superfrog is offline  
Old 10 August 2018, 00:17   #20
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
What test environment/config did you use for testing PC speaker Toni? I figured using A2088/A2286 with just BB Install floppy and a DOS boot floppy and testing the bell would be the absolute simplest test case scenario.
superfrog is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
x86 Bridgeboard PC Speaker/SoundBlaster support? superfrog request.UAE Wishlist 30 09 August 2018 18:16
What is "x86 Bridgeboard VGA", and how does it work? Narf the Mouse support.WinUAE 7 22 January 2018 14:17
Indivision ECS core update 1.15 wmaciv Amiga scene 8 02 May 2017 19:30
Bridgeboard emulation (x86 CPU, for example A2286) GiuseppeC support.WinUAE 627 16 November 2016 15:42
Minimig firmware/core update Spellcoder News 1 27 April 2008 23:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:05.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.10478 seconds with 14 queries