English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 17 August 2018, 17:00   #221
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Toni Wilen View Post
I can't duplicate any crashes so i need all the files..
A2386SX.zip > The Zone!
AnnaWu is offline  
Old 17 August 2018, 17:01   #222
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,773
Quote:
Originally Posted by Toni Wilen View Post
It probably is Amiga reset not reseting PC side fully. (Probably same problem that causes config load/restart on the fly to break PC side). This will get fixed but has lowest priority..
If I understood the problem well, I can solve by clicking on "Clear disk history" and "Reset Default" (menu Path), OS side with PCReset, especially when I add new hardware to the emulator.For the rest I have not found any particular anomaly on the new beta only the network problem that I do not know how to proceed i continue to use the Serial COM1 Mouse

Last edited by AMIGASYSTEM; 24 August 2018 at 09:44.
AMIGASYSTEM is offline  
Old 17 August 2018, 17:09   #223
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by AnnaWu View Post
A2386SX.zip > The Zone!
It works with Public Beta 0, 2018.08.14 20:49 without any crash on my Vista 32-Bit OS.
AnnaWu is offline  
Old 17 August 2018, 17:26   #224
Zilog
Registered User

 
Join Date: May 2014
Location: Italy
Posts: 208
Quote:
Originally Posted by Toni Wilen View Post
Nope. Does it disappear if you disabled misc panel RTG on screen led option?



It boots normally, no hangs. But I have different xtide bios version (1.1.5) so try some other version. And make sure RDB mode is ticked!

You are on your own when using XTIDE in system that has built-in ATA support..
_Correct...if disabled misc panel RTG on screen led option...disappears.

Please, upload into the zone xt rom that use you. Thanks.
I have try download from internet but the x86 board do "Checkum extra rom error".

Thanks.
Zilog is offline  
Old 17 August 2018, 17:34   #225
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Zilog View Post
_Correct...if disabled misc panel RTG on screen led option...disappears.

Please, upload into the zone xt rom that use you. Thanks.
I have try download from internet but the x86 board do "Checkum extra rom error".

Thanks.
Try the version 2.0.0 which is working for me.
Attached Files
File Type: zip XTIDE Universal BIOS 2.0.0.zip (5.5 KB, 23 views)
AnnaWu is offline  
Old 17 August 2018, 17:42   #226
Zilog
Registered User

 
Join Date: May 2014
Location: Italy
Posts: 208
Quote:
Originally Posted by AnnaWu View Post
Try the version 2.0.0 which is working for me.
Thanks Anna,i try, but have alway problem with 2 disk. (if you use 2 disk have a problem?)

Tony use the other version....i waiting for rom.

Thanks a lot.
Zilog is offline  
Old 17 August 2018, 17:46   #227
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,022
Quote:
Originally Posted by AnnaWu View Post
A2386SX.zip > The Zone!
Fixed.


btw, XT IDE discussion isn't really going anywhere. No one has even said if same happens with dosbox code. (I assume it does and this is the usual Janus/XTIDE conflict that has always existed in some form or another)
Toni Wilen is offline  
Old 17 August 2018, 18:04   #228
Zilog
Registered User

 
Join Date: May 2014
Location: Italy
Posts: 208
Quote:
Originally Posted by Toni Wilen View Post
Fixed.


btw, XT IDE discussion isn't really going anywhere. No one has even said if same happens with dosbox code. (I assume it does and this is the usual Janus/XTIDE conflict that has always existed in some form or another)
I have try with uffical Winuae v4.0.1 with DosBox how core.
Result itself problem.
Zilog is offline  
Old 17 August 2018, 18:06   #229
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Toni Wilen View Post
Fixed.
Great, it is working again.
AnnaWu is offline  
Old 17 August 2018, 18:50   #230
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Windows for Workgroups 3.11
Cirrus Logic CL-GD5429
640x480
16M colors
Attached Thumbnails
Click image for larger version

Name:	blanc.png
Views:	62
Size:	486.1 KB
ID:	59343  
AnnaWu is offline  
Old 17 August 2018, 19:06   #231
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Windows for Workgroups 3.11
Cirrus Logic CL-GD5429
800x600
65K colors
Attached Thumbnails
Click image for larger version

Name:	blanc2.png
Views:	47
Size:	405.1 KB
ID:	59344  
AnnaWu is offline  
Old 17 August 2018, 19:32   #232
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,022
VGA screen not opening after on the fly restart/config load should be fixed.
Toni Wilen is offline  
Old 17 August 2018, 19:45   #233
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Toni Wilen View Post
VGA screen not opening after on the fly restart/config load should be fixed.
AnnaWu is offline  
Old 17 August 2018, 19:51   #234
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,022
Quote:
Originally Posted by rbm View Post
Someone can boot the dos drive with the sounblaster support enabled and the os39 ?
Do you also get hang if you enable PC speaker (and disable SB)?
Toni Wilen is offline  
Old 17 August 2018, 21:41   #235
rbm
Registered User
 
Join Date: Jul 2013
Location: CAT
Posts: 53
Now boots perfectly under os39 with or without sound blaster support and/or pc speaker.
rbm is offline  
Old 17 August 2018, 23:07   #236
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,022
Great. This is almost done, only two test cases left:

- SVGA linear frame buffer. Unfortunately Windows driver (at least 3.x) does not use LFB but uses banking via normal VGA range ($a0000-$bffff). UNIVBE.EXE + some SVGA game test needed. (Didn't for example Settlers 2 support SVGA 256 color mode?)

- EMM386. Janus disk has EMS driver. Need to test some program that requires EMS memory to confirm correct VLSI chip EMS mapping emulation.
Toni Wilen is offline  
Old 18 August 2018, 03:08   #237
superfrog
Registered User

 
Join Date: Jun 2015
Location: San Francisco, USA
Posts: 94
Quote:
Originally Posted by Toni Wilen View Post
Used HD controller should not make any difference, PC RAM is not visible in Amiga side and vice versa. Only communication is via shared RAM slots that appear in PC high mem space.

Yeah the HD controller shouldn't make any difference, though it could. I do remember a few years ago I tried using Bridgeboard with a GVP SCSI controller (because I used GVP back when I had a real A2000 and wanted to play around with emulated version) and it crashed but I didn't bother to report it because I knew what you would probably say
superfrog is offline  
Old 18 August 2018, 08:21   #238
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Toni Wilen View Post
- SVGA linear frame buffer. Unfortunately Windows driver (at least 3.x) does not use LFB but uses banking via normal VGA range ($a0000-$bffff). UNIVBE.EXE + some SVGA game test needed. (Didn't for example Settlers 2 support SVGA 256 color mode?)
You are right.
Attached Thumbnails
Click image for larger version

Name:	sdd.png
Views:	62
Size:	17.3 KB
ID:	59361  
AnnaWu is offline  
Old 18 August 2018, 09:42   #239
AnnaWu
Registered User
AnnaWu's Avatar
 
Join Date: Dec 2012
Location: Germany
Posts: 560
Quote:
Originally Posted by Toni Wilen View Post
- EMM386. Janus disk has EMS driver. Need to test some program that requires EMS memory to confirm correct VLSI chip EMS mapping emulation.
Is this utility program helpful?
http://aminet.net/package/misc/emu/AmigaEMS

The EMS is not a easy thing.
http://www.vcfed.org/forum/showthrea...ore-RAM-needed

Last edited by AnnaWu; 18 August 2018 at 10:31.
AnnaWu is offline  
Old 18 August 2018, 11:15   #240
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,022
Quote:
Originally Posted by AnnaWu View Post
Is this utility program helpful?
http://aminet.net/package/misc/emu/AmigaEMS
No, it is just a bonus. Official programs first!

Quote:
The EMS is not a easy thing.
http://www.vcfed.org/forum/showthrea...ore-RAM-needed
There is nothing difficult. It is not same thing. I only want EMS enabled and confirmed working. I don't need to save as much as possible base memory to run some memory hungry DOS program.

Quote:
Originally Posted by AnnaWu View Post
You are right.
So did you enable 16M of RAM or not? AFAIK just setting lower max extended RAM in BIOS should fix it because BIOS seems to configure VLSI chipset so that any extra non-configured RAM is not mapped to address space.

("Hardware problem". I don't think so. Those cards simply only decode 24-bit of address space = 16M max)

Upload SDD somewhere, I am not interested in hunting it, thanks
Toni Wilen is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
x86 Bridgeboard PC Speaker/SoundBlaster support? superfrog request.UAE Wishlist 30 09 August 2018 19:16
What is "x86 Bridgeboard VGA", and how does it work? Narf the Mouse support.WinUAE 7 22 January 2018 15:17
Indivision ECS core update 1.15 wmaciv Amiga scene 8 02 May 2017 20:30
Bridgeboard emulation (x86 CPU, for example A2286) GiuseppeC support.WinUAE 627 16 November 2016 16:42
Minimig firmware/core update Spellcoder News 1 28 April 2008 00:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:10.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.16106 seconds with 16 queries