English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 28 June 2020, 02:22   #1
cbmeeks
Registered User

 
Join Date: Dec 2015
Location: Soddy Daisy, TN USA
Posts: 85
Commodore A25000 RAM expansion not working

I have a Commodore A25000 RAM expansion board. I can't remember where I got it or if it ever worked.



I just restored my A2000 (rev4.1) and I thought I would give this board a shot. When I plug it in, all I get is a slow blinking from dark gray to light gray.


The card has two jumpers (J1 and J2). J2 says "2-MB" so when I jumper it, the computer will boot normally but the memory is not recognized.


I also have an 8MB Supra RAM expansion I bought when I was 16 (paid $440 for it!). I plugged that card in and the computer shows 9 MiB of RAM.



So the motherboard will recognize the extra RAM. Just not from the Commodore A25000 card.


Any ideas on this one? I've searched online but cannot find the manual.


I have no other Amiga this card will fit in so I thought I may as well get 11 MiB working. :-D


Thanks!
cbmeeks is offline  
Old 28 June 2020, 15:52   #2
Vypr
Registered User

Vypr's Avatar
 
Join Date: Dec 2016
Location: East Kilbride, Scotland
Posts: 341
I had issues with the same card, you can have a look at my findings in this thread:

https://eab.abime.net/showthread.php?t=97854
Vypr is offline  
Old 28 June 2020, 17:54   #3
Matt_H
Registered User
Matt_H's Avatar
 
Join Date: Jul 2008
Location: Boston, MA
Posts: 391
You actually can’t get 11MB working - the 16bit Zorro bus maxes out at 8MB (plus 1MB of Chip RAM on the motherboard). To get more RAM you’ll need an accelerator that adds memory on the 32bit bus.

So you don’t “need” to get the 25000 working for the sake of your system. Although you should try to get it working for the sake of bragging rights in repairing old hardware.
Matt_H is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead A25000 memory card Vypr support.Hardware 5 29 June 2020 18:38
A500 rev 6A, motherboard 1MB chip ram, question about slow ram expansion. x56h34 support.Hardware 6 25 April 2019 17:27
ram expansion for the A1200 done by commodore clauddio support.Hardware 1 19 May 2012 06:17
FS: Commodore A1200 With Ram Expansion and HDD scrappysphinx MarketPlace 3 01 March 2009 22:41

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:18.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06099 seconds with 15 queries