English Amiga Board


Go Back   English Amiga Board > Main > Amiga scene

 
 
Thread Tools
Old 18 September 2017, 17:54   #161
Sinphaltimus
Registered User

Sinphaltimus's Avatar
 
Join Date: Aug 2016
Location: Cresco, PA, USA
Age: 47
Posts: 654
AROS 68k

I understand that the goal is to run on 68k whether that is:
An Original Amiga.
An Original Amiga with upgrades (Any accelerator you want - including Vampire)
Emulation (pick any host PC)

Is that a correct assumption to make?

The same version of AROS 68k should run on everything mentioned.
Sure, you will need to develop drivers of course.
Sounds like it works fine with emulated drivers.
Does that mean it runs fine on original hardware also?
As for Vampire, I suppose it's a matter of writing all the SAGA drivers and such?

Am I understanding this correctly?
Sinphaltimus is offline  
AdSense AdSense  
Old 18 September 2017, 18:02   #162
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 383
Quote:
Originally Posted by Sinphaltimus View Post
Does that mean it runs fine on original hardware also?
Not as well as it should. "Slower than molasses on a winter day" was a description I heard.
Quote:
As for Vampire, I suppose it's a matter of writing all the SAGA drivers and such?
The accelerated SAGA-driver has had a great impact on usability of AROS on the Vampire. It went from unbearably slow to pretty much usable. The AROS IDE-driver needs fixing. It used to only work on A1200 and has been fixed to also run on the A600 and A4000. However, it is still very slow and currently reaches only 1.1 MB/s as compared to the at least 3.5 MB/s on the same hardware running AOS. So there is still much room for improvement. The slow IDE speed is probably the most important single remaining factor that makes AROS perceivably slower than AOS on the Vampire. Of course, on WinUAE things are totally different as it just uses the underlying OS infrastructure and thus needs no real driver but only wrappers. This is also why a thread "Aros68k viability on real Amiga hardware" was created in the first place...
grond is offline  
Old 18 September 2017, 18:38   #163
Sinphaltimus
Registered User

Sinphaltimus's Avatar
 
Join Date: Aug 2016
Location: Cresco, PA, USA
Age: 47
Posts: 654
Thanks for that. Perfectly clear now.
Sinphaltimus is offline  
Old 18 September 2017, 18:44   #164
Marlon_
Amiga Programmer

Marlon_'s Avatar
 
Join Date: Mar 2016
Location: Sundsvall, Sweden
Age: 29
Posts: 184
Send a message via Skype™ to Marlon_
Quote:
Originally Posted by grond View Post
Not as well as it should. "Slower than molasses on a winter day" was a description I heard. The accelerated SAGA-driver has had a great impact on usability of AROS on the Vampire. It went from unbearably slow to pretty much usable. The AROS IDE-driver needs fixing. It used to only work on A1200 and has been fixed to also run on the A600 and A4000. However, it is still very slow and currently reaches only 1.1 MB/s as compared to the at least 3.5 MB/s on the same hardware running AOS. So there is still much room for improvement. The slow IDE speed is probably the most important single remaining factor that makes AROS perceivably slower than AOS on the Vampire. Of course, on WinUAE things are totally different as it just uses the underlying OS infrastructure and thus needs no real driver but only wrappers. This is also why a thread "Aros68k viability on real Amiga hardware" was created in the first place...
From apollo-team irc channel last night:
Code:
[23:14:38] ( wawa) on internal ide of an a4000/060/50 i have 2528k/s.
[00:16:34] ( wawa) 000 unfortunatelly result of the very same cf on a 1200 is worse: 1309kb/s
And today:
Code:
[14:05:12] ( wawa) interestingly rscp gives me 1416kb/s on the same cf on the same amiga 1200 under os3
[14:05:22] ( wawa) never thought it was that slow
[14:05:40] ( wawa) so aros is oly like 10% slower in comparison
So, they're working on it!
Marlon_ is offline  
Old 18 September 2017, 22:36   #165
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 892
no, i simply checked on it with the same tool the vampire team is using and it occures that aros ide (ata) driver speed is about to be on pair with the original os3 counterpart.
the penalty might be in a range of 10%..
wawa is offline  
Old 18 September 2017, 23:20   #166
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 383
Quote:
Originally Posted by wawa View Post
aros ide (ata) driver speed is about to be on pair with the original os3 counterpart.
the penalty might be in a range of 10%..
Perhaps this is the case on relatively slow hardware. With a Vampire the speed comparison is something like 3.5 MB/s with AOS vs. 1.1 MB/s with AROS. Or that's at least how I understood it. ShK should know the detailed numbers.
grond is offline  
Old 18 September 2017, 23:33   #167
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 892
i cant review or confirm it. on irc gunnar suspected that the apollo ide fix may have influenced this.
wawa is offline  
Old 19 September 2017, 11:47   #168
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 383
Quote:
Originally Posted by wawa View Post
i cant review or confirm it. on irc gunnar suspected that the apollo ide fix may have influenced this.
Yes, this is very well possible. It seems that the fix is just curing some symptoms. It works well when running the core at 78 MHz (x11) but not so well at 85 MHz (x12). Thus, it looks like it is timing sensitive which is not a good sign.

Simo did a testrun with RSCP (128KB blocksize) which showed 0.984 MB/s with AROS's ata.device as opposed to 2.9 MB/s with AOS's scsi.device running on the same hardware, an A600 equipped with a v600.
grond is offline  
Old 19 September 2017, 12:10   #169
ShK
Apollo Team
ShK's Avatar
 
Join Date: Mar 2013
Location: Lahti / Finland
Age: 46
Posts: 258
Here's vid of that quick test: http://apollo-accelerators.com/files/shk/AROS_RSCP.mp4

Aros ROM is aros-amiga-m68k-ext + aros-amiga-m68k-rom joined to the 1MB rom. It contains IDE fix by Mike Ness. Nightly build ROM works about 1 times of 10 (or less) with the A600 IDE. The faster the core, the worse IDE works.
ShK is online now  
Old 19 September 2017, 13:01   #170
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 892
we have tested with the default 512kb instead of 128 but perhaps it doesnt matter. on amigas i have (a1200, a4000) aros provides similar results as the original scsi.device.
wawa is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
HAM Video Variants - FS-UAE vs Real Amiga Hardware movec Amiga scene 44 20 August 2017 05:51
Help us test our new game on real hardware alpine9000 Retrogaming General Discussion 26 08 June 2016 10:21
AROS68k: what is needed to run on real hardware? Akira support.Apps 9 11 December 2015 03:57
ALWAYS test your code on real hardware!! h0ffman Coders. General 32 16 July 2015 22:02
Netplay on real Amiga hardware? lesta_smsc support.Hardware 0 03 June 2013 01:40

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:27.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.16724 seconds with 14 queries