English Amiga Board


Go Back   English Amiga Board > Support > support.Demos

 
 
Thread Tools
Old 03 March 2018, 23:04   #1
Foebane
Registered User
 
Join Date: Sep 2011
Location: Cardiff, UK
Posts: 1,038
[SOLVED] Mental by Push Entertainment - trueaga.library DOS I/O error

https://www.pouet.net/prod.php?which=10727

I was able to run this one fine a short while ago, but I wrote a new configuration for the A4000 that I thought was the same, and now it no longer runs for me, I just get the error message "DOS I/O ERROR" instead.

Can anyone help me find the cause? I don't see any info online.
Attached Files
File Type: uae Amiga 4000.uae (12.1 KB, 15 views)
Foebane is offline  
AdSense AdSense  
Old 04 March 2018, 00:06   #2
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
mental_rtg.exe does crash here all the time using p96. HALT3, crash dump, killing the emulator itself, no idea :/
so i did test the aga version, mental.exe only.
extract the demo archive in your ram disk, and start it from that location.
maybe a mask/max transfer value (?!) problem of your hdd.

Last edited by emufan; 04 March 2018 at 00:15.
emufan is offline  
Old 04 March 2018, 05:09   #3
Foebane
Registered User
 
Join Date: Sep 2011
Location: Cardiff, UK
Posts: 1,038
Quote:
Originally Posted by emufan View Post
extract the demo archive in your ram disk, and start it from that location.
maybe a mask/max transfer value (?!) problem of your hdd.
It worked when I did that. What is a mask/max transfer value hdd problem? I'm using a Dynamic HDD with full RDB mode, 1.6Gb.
Foebane is offline  
Old 04 March 2018, 06:13   #4
Foebane
Registered User
 
Join Date: Sep 2011
Location: Cardiff, UK
Posts: 1,038
SOLVED!

The old .vhd I was using had been pushed to its limits, in terms of having been filled up, and so I simply created a brand new .vhd, exactly the same size and file system, re-copied all the demos from backup, and ran this one again, and it ran fine.
Foebane is offline  
Old 04 March 2018, 10:19   #5
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by Foebane View Post
It worked when I did that. What is a mask/max transfer value hdd problem? I'm using a Dynamic HDD with full RDB mode, 1.6Gb.
here you can read about those values - CF / SD and large drives FAQ --> Max transfer and mask
using a different or the default value, may result in read-errors with large files and such things.
Quote:
Originally Posted by Foebane View Post
SOLVED!
good news.
just to spread the news, we now have a collection of ready to use hdd/hdf images.

Last edited by emufan; 04 March 2018 at 10:24.
emufan is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Open-source dos.library Don_Adan Coders. System 271 28 October 2015 19:28
PCMCIA fault: DOS error code 225 - Not a valid DOS disk 4am support.Hardware 2 07 April 2012 10:20
Dos.library question. Thorham Coders. General 2 11 January 2011 21:03
(ERROR) Shadow Warriors - DOS Error #219 Retro-Nerd project.Killergorilla's WHD packs 5 04 January 2009 16:26
Push Push Penguin for Amiga tomcat666 Amiga scene 16 09 October 2004 19:37

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:44.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06215 seconds with 16 queries