English Amiga Board


Go Back   English Amiga Board > Other Projects > project.WHDLoad

 
 
Thread Tools
Old 08 January 2021, 17:37   #1
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
Installer 44.10 error help

I've updated my WHDLOAD to the latest release and when I tried to load Banshee I got a message saying a newer slave was available. I've downloaded it and unpacked it and when I run the installer it tells me that my installer is outdated, I have 43.3 but I need 44.10.

I've downloaded quite a few offline but none seem to give me the version I need. I also downloaded one off this site from another thread but still get the same message.

How can I get the Installer 44.10 I need to be able to install the WHDLOAD slave file updates?

None of the ones on Aminet work either. At a loss now how to sort this out. My config in WinUAE is Amiga 1200 with 68882 FPU and all the info online says it sorts the version of the Installer based on the CPU, I think I'm covered for Banshee just can't get the installer working. It'll be the same for Jimmy Whites Snooker as I read it uses the same installer version. Damn nightmare but I'm sure someone knows the solution

By the way I'm using AmigaInABox r10.6 if that makes any difference. It's the best looking alternative I found that was quick and easy to get running.
Bazzietuk is offline  
Old 08 January 2021, 18:26   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,184
Quote:
Originally Posted by Bazzietuk View Post
when I run the installer it tells me that my installer is outdated, I have 43.3 but I need 44.10.
That's bad coding style. Tell the author to read the style guide and let him correct his script.

Installer 44.10 is included in the OS 3.9 NDK: http://www.haage-partner.de/download/AmigaOS/NDK39.lha
thomas is offline  
Old 08 January 2021, 23:23   #3
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
Thank you Thomas, I'll give it a try later when I get on my PC, from the readme it looks like a higher version that what is needed which would is great.

Unfortunately it seems quite a lot of WHDLoad games need it now since the last update from different authors as well.
Bazzietuk is offline  
Old 09 January 2021, 20:35   #4
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
Okay, I've unpacked that and copied it into the C folder of workbench on my drive and directory Opus gives the info on the file as version 44.10 but I still get the error on WHDLoad about it being a lower version. Not sure if I have to copy it to the directory of the game I'm trying to update or to a different location on the workbench drive? Any ideas please? I'm using WinUAE with Amiga in a box installed if that's any help solving the problem.
Bazzietuk is offline  
Old 09 January 2021, 20:48   #5
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 6,184
It belongs to Utilities, not C.
Or just replace the old version by the new version, wherever it is.
thomas is offline  
Old 09 January 2021, 21:38   #6
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
Only location that it's in is the C folder in Workbench. I've replaced that one but still doesn't seem to be recognizing it when opening the WHDLoad installer for Banshee. I don't know if I need to put an entry into the startup sequence file or not or associate it somehow to get programs to recognize it.
Bazzietuk is offline  
Old 10 January 2021, 16:34   #7
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,757
What is the output of "which installer" in a shell?
daxb is offline  
Old 10 January 2021, 17:01   #8
zipper
Registered User
 
Join Date: Mar 2004
Location: finland
Posts: 1,644
which installer all - shows if there are several.
zipper is offline  
Old 10 January 2021, 18:13   #9
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
What is "which installer"? Is it on Aminet?
Bazzietuk is offline  
Old 10 January 2021, 20:44   #10
ma693541
Computer Wizard

ma693541's Avatar
 
Join Date: Aug 2007
Location: Ramberg/Norway
Posts: 832
Which Installer all shows what kind of installers you have got and will also show the version and revision number, just write in Shell; Which Installer all and press Enter-key.

Last edited by ma693541; 10 January 2021 at 20:45. Reason: Typo
ma693541 is offline  
Old 10 January 2021, 21:23   #11
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
All it says (twice) is:

system:c\installer

That's all I get listed typing that into a shell. It doesn't say a version number or anything after it.
Bazzietuk is offline  
Old 10 January 2021, 22:13   #12
ma693541
Computer Wizard

ma693541's Avatar
 
Join Date: Aug 2007
Location: Ramberg/Norway
Posts: 832
Then try in Shell; Version C:Installer
ma693541 is offline  
Old 11 January 2021, 01:07   #13
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
It says:

installer 44.10

But for some reason though it still tells me that I have an older version installed when I try to run the WHDLoad installer for Banshee AGA.
Bazzietuk is offline  
Old 11 January 2021, 01:54   #14
Bazzietuk
Registered User
 
Join Date: Jun 2020
Location: England
Posts: 13
Thanks for everyone's help it's sorted now. Found out with the Which installer all command I had 3 versions (obviously my laptop install of WINUAE is different to my main PC version as I only had 2 on my laptop but 3 on my main PC). Found out in the end I have one in the system folder as well as the S and C folders. Copied the newer one there and it solved the issue.
Bazzietuk is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WHDLoad - I get an installer error methodman support.Apps 2 07 April 2018 00:52
WHDLoad error: error during 'resload_LoadKick' on monkey island & others jamespstevenson project.MAGE 14 20 February 2014 06:33
ERROR: Metal Masters (Illegal Instruction / Address Error / Black Screen) killergorilla project.Killergorilla's WHD packs 7 25 March 2012 16:32
ERROR: Leisure Suit Larry Enhanced (Address Error) batwinky project.Killergorilla's WHD packs 23 30 January 2011 14:00
(ERROR) Shadow Warriors - DOS Error #219 Retro-Nerd project.Killergorilla's WHD packs 5 04 January 2009 17:26

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:44.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.13808 seconds with 15 queries