English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Language > Coders. C/C++

 
 
Thread Tools
Old 08 December 2017, 23:31   #21
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546


here in emulation the game runs very well, editor is working too.
from the list in main window, if you choose one, each has alot of sub-level, can select those with
the <-- and --> buttons when in game mode.

#1) we had some issue with LinApple and a black screen. i'll have a look these days,
maybe the new sdl lib can fix that issue too. maybe
emufan is offline  
Old 08 December 2017, 23:38   #22
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 287
-eyes turn into heart shapes- I am in love with you!!
xboxown is offline  
Old 09 December 2017, 01:33   #23
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,335
Quote:
Originally Posted by xboxown View Post
-eyes turn into heart shapes- I am in love with you!!
I am just fond of you emufan.
grelbfarlk is offline  
Old 09 December 2017, 05:06   #24
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 287
Emufan I am going to do reporting.

Xye...mmmmmmmmmmaaah! Perfect! Don't change or change anything on it. It is perfect!!

For the other one it starts very fast on my vampire x11 which is perfect but instantly it keeps slowing down and down and down and down until it crawls almost to a halt. There is a bug in there that makes the game slow down to a stop. Is it possible you could look into it?

Thanks
xboxown is offline  
Old 09 December 2017, 08:58   #25
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
it's not me, it is the new sdl lib. so some flowers to arti aswell

I have the impression too, Xye works very well. while tworld is a bit messy. I have the same here. slow downs :/
I build a version with the new sdl, but this gave gfx corruption. maybe I have to replace the include files first.
emufan is offline  
Old 09 December 2017, 09:06   #26
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 287
Thank you arti!!
xboxown is offline  
Old 09 December 2017, 10:47   #27
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
I build a new version of latest sdl 1.2.15 and voilà, we have a working and fast Tile World aka tworld
no gfx corruption, sound working, keyboard input looking good aswell

zone: tworld-68k-WIP_SDL_1.2.15.lha (maybe final version)

Last edited by emufan; 09 December 2017 at 19:16.
emufan is offline  
Old 09 December 2017, 19:46   #28
xboxown
Registered User
 
Join Date: Dec 2012
Location: Vancouver/Canada
Posts: 287
Quote:
Originally Posted by emufan View Post
I build a new version of latest sdl 1.2.15 and voilà, we have a working and fast Tile World aka tworld
no gfx corruption, sound working, keyboard input looking good aswell

zone: tworld-68k-WIP_SDL_1.2.15.lha (maybe final version)

Thank you arti for sdl 1.2.15 and thank you emufan for taking your time and porting it and making it work!!!!!!!!!!!!

Can you please release them to aminet? Please!
xboxown is offline  
Old 09 December 2017, 19:57   #29
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by xboxown View Post
Can you please release them to aminet? Please!
will do so. I also build NAGI with new sdl and it is much faster, very impressive

zoned: NAGI-68k-WIP-SDL_1.2.15.lha

added two games, the Voodoo girl game now has some crackling sound,
which was not there with older sdl version - dunno whats wrong now (F2 sound off).
btw. just test the fastest speed settings

#1) with this fast sdl 1.2.15 lib, all those releases using the old sdl version, must be rebuild

Last edited by emufan; 09 December 2017 at 20:18.
emufan is offline  
Old 10 December 2017, 11:59   #30
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by emufan View Post
will do so.
I put them on aminet: tworld-68k.lha, xye-68k.lha and NAGI-68k.lha
all build with new libSDL 1.2.15

with NAGI the speed setting "fastest" make the game unplayable, since it's simply too fast now.
one issue here is the crackling sound in Voodoo Girl game, which didnt happen with old libSDL.
maybe just this game, dunno yet, not much more tested.

Last edited by emufan; 10 December 2017 at 12:11.
emufan is offline  
Old 10 December 2017, 17:04   #31
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
I get a weird error I dont understand:
Code:
fearray.h:56: error: non-template `fearray' used as template
fearray.h:56: error: (use `fearray<type>::template fearray' to indicate that it is a template)
Code:
template <class type> struct fearray
{
  typedef unsigned sizetype;
  fearray() : Data(0), Size(0) { }
  fearray(const fearray&);
  fearray(const type*, sizetype);
  ~fearray();
  fearray& operator=(const fearray&);
  type& operator[](sizetype I) { return Data[I]; }
  const type& operator[](sizetype I) const { return Data[I]; }
  void Allocate(sizetype);
  void Add(const type&);
  void Clear();
  const type& GetRandomElement() const { return Data[RAND_N(Size)]; }
  type* Data;
  sizetype Size;
};
.....
56: template <class type> inline fearray<type>::~fearray<type>()
there is one #include in the header file, which has this line:
Code:
template <class type> struct fearray;
how can i fix this?

#1) I've comment out the template definition started in line 56. now it does build something.

#2) seems working, there was another template with such a class constructor (!?) "~...",
also comment out and it does build the thing.
one type conversation error, tmp fixed with -fpermissive -
it #define LINUX, which was used for those posix/directory stuff. "fixed" with renaming to LINUX2 in src code
now let's see what will be the result :Spin

#3) hmm, those template are needed when linking - exactly the comment-out templates are missing:
Code:
undefined reference to `fearray<contentscript<item> >::~fearray()'
undefined reference to `contentmap<glterrain, contentscript<glterrain>>::~contentmap()'
so what is worng with the non-template thing? anyone can help here?

I wrote a PM to alkis
Attached Files
File Type: txt fearray.h.txt (3.3 KB, 25 views)

Last edited by emufan; 10 December 2017 at 20:11.
emufan is offline  
Old 12 December 2017, 20:26   #32
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 47
Posts: 431
Well, never actually used templates. And this goes over my head. Two questions though:

With what version of gcc does that compile?
Which version of gcc are you using to compile?
alkis is offline  
Old 12 December 2017, 20:30   #33
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by alkis View Post
With what version of gcc does that compile?
Which version of gcc are you using to compile?
*bummer* at the moment I cannot even remember, which source code it is.
But i'll have a look

#1) it's IVAN - error occures with gcc 3.4.0 (AmiDevCPP).
I try with another gcc

#2) gcc 6.3.1 is even worse, has problems with it's own include files:
Code:
/opt/m68k-amigaos/lib/gcc/m68k-amigaos/6.3.1b/include/c++/cstdio:176:11: error: ‘::vfscanf’ has not been declared
   using ::vfscanf;
           ^~~~~~~
/opt/m68k-amigaos/lib/gcc/m68k-amigaos/6.3.1b/include/c++/bits/basic_string.h:5472:20: error: no matching function for call to ‘__to_xstring(int (*)(char*, size_t, const char*, char*), long unsigned int, const char [3], int&)’
         "%d", __val); }
dozens lines below it says:
Code:
../../FeLib/Include/fearray.h: At global scope:
../../FeLib/Include/fearray.h:37:8: error: ‘fearray<type>::fearray’ names the constructor, not the type
 inline fearray<type>::fearray<type>(const fearray<type>& A)
        ^~~~~~~~~~~~~
../../FeLib/Include/fearray.h:37:8: error: and ‘fearray<type>’ has no template constructors
../../FeLib/Include/fearray.h:45:8: error: ‘fearray<type>::fearray’ names the constructor, not the type
 inline fearray<type>::fearray<type>(const type* Array, sizetype Size)
        ^~~~~~~~~~~~~
../../FeLib/Include/fearray.h:45:8: error: and ‘fearray<type>’ has no template constructors

Last edited by emufan; 12 December 2017 at 21:09.
emufan is offline  
Old 12 December 2017, 21:12   #34
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 47
Posts: 431
Linux's g++ (7.2.0) compiles the fearray.h without problems.
bebbo's cross-compiler g++ (6.3.1b) compiles the fearray.h without problems.
alkis is offline  
Old 12 December 2017, 21:17   #35
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 47
Posts: 431
Umm, top CMakeLists.txt specifies:

set(CMAKE_CXX_FLAGS "-std=c++11 ${CMAKE_CXX_FLAGS}")


so it needs c++11 standard. Maybe gcc3.4.0 is too old for this.
alkis is offline  
Old 12 December 2017, 21:29   #36
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by alkis View Post
Linux's g++ (7.2.0) compiles the fearray.h without problems.
bebbo's cross-compiler g++ (6.3.1b) compiles the fearray.h without problems.
hmmm, I've just completely remade bebbo's compiler, cannot believ it is broken again here :/
Quote:
Originally Posted by alkis View Post
Umm, top CMakeLists.txt specifies:

set(CMAKE_CXX_FLAGS "-std=c++11 ${CMAKE_CXX_FLAGS}")

so it needs c++11 standard. Maybe gcc3.4.0 is too old for this.
cannot find Cmake stuff in ivan src code, this thing is from 2004, only configure is here.
emufan is offline  
Old 12 December 2017, 21:51   #37
jotd
Cat freak
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 46
Posts: 2,476
This "SDL faster" stuff is beginning to interest me. I had built my port of "Bagman" SDL and it was ok on Winuae but very slow on a real 060, no sound, etc..

I didn't follow everything. So it was slow, and you ported a new version and it was way faster? That'd be great.

I'm tempted to rebuild it again with the new lib. BTW AmiDevCPP is the best IDE ever for cross compiling Windows => Amiga & gcc stuff. 3.4 is okay, even if old (and yes, C++11 is from ... 2011, gcc 3 is way older than that, so no luck, but maybe the usage of C++11 is limited to some constructs like "for (auto x : collection)" which can be replaced by "old-style" code.

Another possibility would be to translate code to C first: https://stackoverflow.com/questions/...rt-c-code-to-c

Maybe I can help with some unfinished ports BTW. I've got a good experience of C & C++ as you can witness here https://stackoverflow.com/search?q=u...B]+is%3Aanswer

Last edited by jotd; 12 December 2017 at 21:58.
jotd is offline  
Old 12 December 2017, 22:03   #38
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by jotd View Post
I didn't follow everything. So it was slow, and you ported a new version and it was way faster? That'd be great.
I only build it from the source code , provided by arti and buggs - others were involved too.
but indeed, it does fix some of the stuff, that did not work with the older libsdl.

dgen sega emulator had no sound, stalled when enabled with old version.
linked with new 1.2.15 and this thing works perfect.
NAGI got some big gfx improvement, game gfx in "fastest" mode is now unplayable
in winuea/jit, simply too fast - but got some new sound issue - maybe just bad sdl_audio prefs in src

I like AmiDevCPP alot too. cannot say exactly, but i guess in 80% of those old source, it did a good job.

with great help by alkis, we already translated some c++ plugins for lightwave.
class to struct for example. but those class-template stuff combined with struct is horrible

Quote:
Originally Posted by jotd View Post
... as you can witness here
cool

Last edited by emufan; 12 December 2017 at 22:18.
emufan is offline  
Old 13 December 2017, 16:51   #39
alkis
Registered User

 
Join Date: Dec 2010
Location: Athens/Greece
Age: 47
Posts: 431
Quote:
Originally Posted by emufan View Post
hmmm, I've just completely remade bebbo's compiler, cannot believ it is broken again here :/

cannot find Cmake stuff in ivan src code, this thing is from 2004, only configure is here.

I think I found a continuation on github

https://github.com/Attnam/ivan
alkis is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Port of IK from the ST meynaf Amiga scene 169 28 September 2016 06:42
Using PotGo on Mouse Port (Port 0)? Daedalus Coders. System 14 02 March 2016 20:44
Serial port, parallel port, and pipe device mount errors Samurai_Crow support.FS-UAE 4 13 March 2014 00:04
Port to Linux Enverex support.WinUAE 22 26 April 2006 15:35
AExplorer and com port Ebster support.Hardware 12 05 October 2005 09:02

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:52.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.10390 seconds with 16 queries