English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 15 October 2018, 12:55   #341
Minuous
Coder/webmaster/gamer
Minuous's Avatar
 
Join Date: Oct 2001
Location: Canberra/Australia
Posts: 1,828
@kolla:

OK, thanks.
Minuous is offline  
Old 15 October 2018, 17:38   #342
alenppc
Registered User
 
Join Date: Apr 2012
Location: Canada
Age: 38
Posts: 803
I installed 3.1.4 on my A500 with TF534 yesterday, including burning the rom chip. Two questions:

1) CPU Fastrom option is no longer supported. This option is kind of essential for this type of system, since it makes you gain a big speedup. Why was it removed? Is there an alternative for copying the ROM into RAM with accelerators that don’t have a dedicated feature for doing so?

For the moment I reverted to using the old 3.1 CPU command.

2) what is the purpose of the modules disk? How are these modules intended to be used?

To update intuition.library, I had to add “LoadModule intuition.library” to the startup-sequence since LoadModule ROMUPDATE (as per FAQ) gives an error message since I use a 3.1.4 ROM chip.
alenppc is offline  
Old 15 October 2018, 18:14   #343
QkiZ
Registered User

QkiZ's Avatar
 
Join Date: Oct 2016
Location: Poland
Posts: 23
It's for making your own kickstart. But there's one question: why they didn't share all contents of new kickstart? I enlisted above all missing modules and residents that are in kickstart but not on Modules floppy. We are lack of ROMplit that will be able to extract missing modules. Of course we can take modules from 3.1 ROM but I don't how it will be working.

Sent from Moto G (5S) Plus via Tapatalk
QkiZ is offline  
Old 15 October 2018, 20:58   #344
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,541
They are intended for use with LoadModule on a kick 3.1 system, but can also be used to build custom kickstarts.
kolla is offline  
Old 15 October 2018, 21:20   #345
nogginthenog
Amigan

 
Join Date: Feb 2012
Location: London
Posts: 671
Quote:
Originally Posted by kolla View Post
They are intended for use with LoadModule on a kick 3.1 system, but can also be used to build custom kickstarts.
Not all the updated modules are included.

Quote:
Originally Posted by QkiZ View Post
I'm interesting about making custom 3.1.4 kickstart. How do you extract modules from 3.1.4 kickstart?
It needs someone with some skills to make a patch file. ROM modules in a Kickstart are located at a fixed address and any absolute addresses need to be patched.

Mostly these seem to be minor modules (potgo etc) but I agree it would be nice to have them!
nogginthenog is offline  
Old 15 October 2018, 22:29   #346
DanyPPC
Registered User

 
Join Date: Dec 2016
Location: Italy
Posts: 122
t would be easier if Hyperion included in the AmigaOS3.1.4 archive also the maprom version with Intuition.library v45.
DanyPPC is offline  
Old 15 October 2018, 22:46   #347
desiv
Registered User
 
Join Date: Oct 2009
Location: Salem, OR
Posts: 1,392
Quote:
Originally Posted by DanyPPC View Post
t would be easier if Hyperion included in the AmigaOS3.1.4 archive also the maprom version with Intuition.library v45.
Personally, I would vote for that as an option. ;-)
desiv is offline  
Old 15 October 2018, 23:01   #348
asymetrix
Registered User

 
Join Date: Jul 2009
Location: UK
Posts: 90
What would be next ? No disks ?

Direct ROM stream Install from Hyperion servers ? LOL.
asymetrix is offline  
Old 16 October 2018, 00:09   #349
oscillik
Registered User
 
Join Date: Aug 2018
Location: UK
Posts: 24
I'm definitely very interested in getting hold of physical ROM chips and floppies of this
oscillik is offline  
Old 16 October 2018, 09:45   #350
Nightfox
Registered User

Nightfox's Avatar
 
Join Date: Apr 2016
Location: Perth, Australia
Posts: 224
Is anyone able to create a ROM image that includes the new intuition.library? That would make the LoadModule step unnecessary
Nightfox is offline  
Old 16 October 2018, 10:25   #351
AC/DC HACKER!
Registered User

 
Join Date: Aug 2016
Location: DigitalCorruption/iNT
Posts: 218
Understand that not all games are compatible with the new update. If you make a ROM of the current new update you're also going to make of ROM later updates, of fixes to be released later also.

They aren't done. I think several are missing this point. For now, I for one, am glad I do not have a burned ROM. I expect fixes, and I expect my [real] and emulated Amigas to reset for some time to make the new Kickstart active.

Let's point to bugs fixing for a bit. Let's help them notice them. Let's...explore them. We JUST got an Update..let's not loose sight of that. How do we help? EH?? EH?? Right.
AC/DC HACKER! is offline  
Old 16 October 2018, 15:31   #352
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,541
Quote:
Originally Posted by AC/DC HACKER! View Post
How do we help? EH?? EH?? Right.
Indeed, how do one help - I have several bugs to report, where is the bug-tracker?
kolla is offline  
Old 16 October 2018, 16:04   #353
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 3,775
Quote:
Originally Posted by AC/DC HACKER! View Post
Understand that not all games are compatible with the new update.
Compared to OS 3.1, which games (OCS/ECS/AGA) in particular they could find incompatibility ?
AMIGASYSTEM is online now  
Old 16 October 2018, 17:48   #354
desiv
Registered User
 
Join Date: Oct 2009
Location: Salem, OR
Posts: 1,392
Quote:
Originally Posted by AC/DC HACKER! View Post
If you make a ROM of the current new update you're also going to make of ROM later updates, of fixes to be released later also.t.
While I agree with burned ROMs (except for those people who can burn their own), I wouldn't mind a kickstart/maprom file with the new intuition library built in.
Those running WinUAE and/or accelerators with maprom functionality could use it. ;-)

Last edited by desiv; 16 October 2018 at 19:52.
desiv is offline  
Old 16 October 2018, 18:47   #355
number6
Registered User

 
Join Date: Sep 2017
Location: USA
Posts: 29
Quote:
Originally Posted by kolla View Post
Indeed, how do one help - I have several bugs to report, where is the bug-tracker?
The only support I am currently aware of is:

Hyperion classic forum

I'd suggest checking info there for any info on a bug tracker.

#6
number6 is offline  
Old 16 October 2018, 20:04   #356
Rixa
Registered User
 
Join Date: Sep 2007
Location: Tampere / Finland
Posts: 121
Quote:
Originally Posted by QkiZ View Post
Of course we can take modules from 3.1 ROM but I don't how it will be working.

If you boot with an older ROM, isn't it designed to LoadModule the provided components on top of it? Obviously it can't load the missing ones, so one would think they weren't necessary to replace.



That said I am a bit sad about them missing.
Rixa is offline  
Old 17 October 2018, 00:33   #357
asymetrix
Registered User

 
Join Date: Jul 2009
Location: UK
Posts: 90
@thread

can the AmigaOS ROM be extended ?

EG ROM holds jump data, activates a memory type RAD: and store libraries in there, like a memory based RAD device which can load up on restart.

Hell if one has enough memory load all disks into multiple RADs and install WB and do repairs from there.

If we had wget built in we could have acces to cloud based user environments with all files and settings downloaded eg RTG, icons, apps installed to common approved paths that dont interfere with AmigaOS systems.

If a users version or install path intereferes, just auto remove and auto download another compatible install config for that app.

The user would not have to type any script or look for where files are - just select and install like an apps store.
asymetrix is offline  
Old 17 October 2018, 01:54   #358
wiser3
Registered User

 
Join Date: Sep 2018
Location: Canada
Posts: 8
Has anyone noticed any compatibility issues with 3.1.4?
wiser3 is offline  
Old 17 October 2018, 05:24   #359
sean_skroht
Gimmemore Commodore

 
Join Date: Apr 2016
Location: Australia
Posts: 132
Quote:
Originally Posted by wiser3 View Post
Has anyone noticed any compatibility issues with 3.1.4?

Yeah! PenPal doesn't work for me anymore.

Last edited by sean_skroht; 19 October 2018 at 11:44.
sean_skroht is offline  
Old 17 October 2018, 20:48   #360
Ami
Registered User

 
Join Date: Sep 2014
Location: Poland
Posts: 27
Hooooo

Can I post an issue here? I have two scripts:

edit_startups:
Code:
S:edw S:Startup-Sequence -AREXX S:bat/ss1.epxx
S:edw is:
Code:
.KEY FILE,PARAMS/F
.BRA {
.KET }
Run >NIL: C:EdWordPro {FILE} {PARAMS}
If I run "edit_startups" script, EdWordPro says that it cannot open file named: S:Startup-Sequence "-AREXX S:bat/ss1.epxx

The problem is with " (single quotation mark) character just before -AREXX S:bat/ss1.epxx string. In OS3.1 everything is OK.
Ami is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Would AmigaOS 3.9 be ok for me? stu232 support.Hardware 12 02 October 2013 19:20
AmigaOS 3.9 PoLoMoTo support.WinUAE 8 27 August 2011 19:06
AmigaOS 3.5 or 3.9 maddoc666 support.Apps 12 22 February 2010 09:02
AmigaOS koncool request.Apps 6 04 June 2003 18:45
AmigaOS XL sturme New to Emulation or Amiga scene 4 15 January 2002 03:13

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:49.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.11883 seconds with 16 queries