English Amiga Board


Go Back   English Amiga Board > Requests > request.Apps

 
 
Thread Tools
Old 30 October 2017, 23:06   #1
rzookol
Registered User
 
Join Date: Mar 2007
Location: Poland
Posts: 24
OktaPussy Rom for AT-2008

Hi,

Does anybody have such rom for AT-2008 card?

Regards,
rzookol
rzookol is offline  
Old 30 October 2017, 23:58   #2
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
I only found a guide by georg braun, describes how to make such oktapussy rom on your own.
yandex translated english version.

but i bet someone already made the hack, so with some patience, you get some more convenient reply, i hope

#1) I'm not sure, I undestand the guide, but it looks simple enough.
you need the expansion/AT file from oktapussy aminet download,
and the oktagon 6.12 rom from resource.cx.

i did what the guide says, result attached, but not sure, i did it the right way
Attached Files
File Type: lha OktaPussy-AT-WIP.lha (13.9 KB, 80 views)

Last edited by emufan; 31 October 2017 at 00:54.
emufan is offline  
Old 01 November 2017, 22:51   #3
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
*bump* does it work, could anyone test it?
emufan is offline  
Old 01 November 2017, 23:18   #4
MartinW
Registered User

 
Join Date: Mar 2017
Location: United Kingdom
Posts: 211
I might be wrong but aren't those instructions for patching the ROM so it works with the 68060 accelerator of the GBA machine? Possibly any 68060 CPU?

Given that, wouldn't the 6.10 file linked to in the article just work without modification?

Admittedly it would help if the OP said if he has an original Octagon card, a GBA with that version of Oktagon and which CPU. As a GBA owner I have patched files that work with my system, but I've no idea if they work only with my system (which is also 060) or if they would work on the original Okatagon boards.
MartinW is offline  
Old 01 November 2017, 23:31   #5
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
well, some feeback by rzookol would be of some help

I think it is not related to 060 functionality.
since you only use the original roms and cut/copy/paste some parts to eachother,
there is no link to a specific cpu type.

i guess the OP want the OktaPussy functionality, but does not want to use the RDB method,
which is an option from the aminet oktapussy release.
emufan is offline  
Old 01 November 2017, 23:34   #6
MartinW
Registered User

 
Join Date: Mar 2017
Location: United Kingdom
Posts: 211
The document you linked to talks about different movep assembler commands for the 060 CPU and I know that I had to use a version of the ROM that had been patched by Georg Braun so that it would work with the 060 accelerator that was produced for the GBA.

But yeah, there's probably other stuff in the patching as well...
MartinW is offline  
Old 01 November 2017, 23:38   #7
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by MartinW View Post
... talks about different movep assembler commands for the 060 CPU ...
ah, ok, now I see that section.
I just started at "You can also have an EPROM with the Oktapussy AT Device make?" - from the yandex translated version.
here you only cut/copy/paste parts of the 6.12 rom and oktapussy-AT file.
emufan is offline  
Old 01 November 2017, 23:42   #8
MartinW
Registered User

 
Join Date: Mar 2017
Location: United Kingdom
Posts: 211
Regardless, either the patched ROM you did should work or the 6.10 version (mentioned in the document) should work. either way rzookol should be sorted, just need to know more about what they need
MartinW is offline  
Old 01 November 2017, 23:49   #9
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
Quote:
Originally Posted by MartinW View Post
Regardless, either the patched ROM you did should work or the 6.10 version (mentioned in the document) should work. either way rzookol should be sorted, just need to know more about what they need
hmm, but the 6.10 rom does not have the OktaPussy features.
with the 6.10 rom you need the OktaPussy "AT" device in the RDB.

rzookol: what do you want to achieve? with what hardware?
emufan is offline  
Old 17 April 2018, 00:09   #10
rzookol
Registered User
 
Join Date: Mar 2007
Location: Poland
Posts: 24
Hi,
My Willem stopped working so i had to buy another programmer and finally can program the eprom. Thanks for the oktapussy rom. It seems to work (boot from hd works, scsi.device is shown instead of oktagon.device). It's for original AT2008 device in A2000/010 Rom 3.1.
rzookol is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alfapower A500 oktapussy IDE patch - CF not visible in WINUAE oissery77 support.WinUAE 22 19 September 2015 15:10
Oktagon 2008 no-ROM option mark_k support.WinUAE 1 02 April 2015 20:26
ROM scanner always reports Action Cartridge Super IV Professional ROM found mark_k support.WinUAE 1 26 January 2015 19:52
Sundown Demoparty (UK) 2008 12-14th September 2008 rc55 Amiga scene 15 01 September 2008 13:19
Amiga Forever 2008 Released 31.05.2008 ma693541 News 18 08 July 2008 09:17

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:37.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07112 seconds with 14 queries