English Amiga Board Amiga Lore


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 14 March 2017, 22:19   #1
Crazy C
Registered User

Crazy C's Avatar
 
Join Date: Mar 2017
Location: Hannover / Germany
Age: 41
Posts: 16
Question UAE4ALL2/UAE4ARM Test/comparison/questions

Hello forum!

Since a while I'm testing UAE4ALL2 and UAE4ARM Amiga emulators for Android.
Lots of questions came up using and comparing them in several months and I hope to find some answers to them in this forum.
Also it seems there are still some bugs and things that need to be improved or at least I want to know if other users have similar problems with their emulators.

The versions I tested are UAE4ALL2 2.3.7.5 and UAE4ARM 1.0.0.16.
I mostly played GODS and SUPER CARS II which turned out to be best for use with the emulators.

Here's some 'report' of testing them...


UAE4ALL2

Has no stereo separation and collision detection setting

Autofire only available through control presets, not definable for custom control buttons

Autofire buttons and normal fire buttons exist separately (shortly tapping autofire buttons doesn't trigger fire)

Autofire 'medium' is in fact 'heavy' and 'heavy' doesn't do anything

Adding 0,5 MB slow ram causes Speedball 2 to crash when 'loading game'

What exactly is 'vsync'?


UAE4ARM

Lower performance in lots of parts of many demos

Slightly lower performance with lots of games especially when games are accessing Amiga disks

No additional button size setting like in UAE4ALL2 (see both emulators, device configuration's on screen keyboard size)

Autofire 'medium' and 'fast' are both the same ('fast')

When using the dpad as mouse, mouse speed 0,25 does nothing, only from 0,5 on the mouse speeds are supported

Virtual keyboard permanently changes from visible/invisible when about to enter a name for a custom configuration file

Playing Gods 'fast copper' setting causes background colour to change to green in some frames

When port0 and port1 are both set to 'none' and there are defined
two custom buttons for each 'mouse button left' (button 'A')
and 'mouse button right' ('button B'):
If you tap button 'A', no left mouse click is triggered,
port0 is suddenly automatically set to 'nubs as mouse' and only now
tapping button 'A' again triggers a left mouse click.
The same with button 'B' and port1:
If I tap button 'B' port1 now is set to 'nubs as mouse' and tapping
button 'B' only now really triggers a right mouse click!

When running 'World of Commodore Amiga' demo from Sanity:
The first effect (zoom of logo) is accelerated with 'fast copper' on.

In menu (chosing directory/file) some unicode characters ( for example) are not supported

'JIT' slows down emulation instead of improving performance

Also, the 'adz' disks are not working (dms and zip do)


BOTH EMULATORS

No manual

Amiga disks always not write protected

Device configuration's left mouse click setting 'hold at the same spot' seems not to work sometimes or conflicts with 'tap delay' setting

Don't understand device configuration's 'relative mouse movement', 'video settings' and 'multiple touch events per video frame'

Device configuration's 'on screen keyboard/button images size' is always one level smaller than it should be (large is in fact medium)
Only if you use UAE4ALL2's button size setting, large is really large (UAE4ARM does not have this option, so 'medium' size buttons are the largest with that emulator)

When playing the game 'GODS':
If player positioned in the right part of the screen looking to the right or positioned in the left part of the screen looking to the left:
Autofire triggers fire correctly (no pauses between firing)
If player positioned in the right part of the screen looking to the left or positioned in the left part of the screen looking to the right:
Autofire triggers 3 times fire - pause - 3 times fire - pause...

Floppy drive speed x 2/8 etc. slows down emulation significantly


That's it.

Finally, some information about my Phone:

Samsung Galaxy J1 (J100H)
Device: j13g
Board: sc7727s
Hardware: sc8830
Processor: ARMv7 Processor rev 5 (v7l)
Instruction sets: armeabi-v7a, armeabi
CPU features: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt
CPU hardware: sc8830
Cores: 2
Clock speed: 768 MHz - 1200 MHz
Resolution: 480 x 800 pixel
Density: 240 dpi (hdpi)
Refresh rate: 60.001 Hz
RAM: 452,9 MB
Android: 4.4.4 KITKAT, API level 19
Kernel: Linux, armv7l, 3.10.17-1042529
Android runtime: Dalvik 1.6.0
Not rooted

Hope to get some reactions...

Last edited by Crazy C; 22 March 2017 at 23:26.
Crazy C is offline  
AdSense AdSense  
Old 19 March 2017, 14:57   #2
Genlock
BAA - Born Again Amigan

Genlock's Avatar
 
Join Date: Jul 2010
Location: UK
Posts: 84
Hello Crazy C, and Welcome..
I only just noticed that you just joined this month

Hopefully youve had a chance to have a look around by now , but if not this section shoild answer most if not all your questions on the Android Emulation for the Amiga and a bit more

http://eab.abime.net/forumdisplay.php?f=54

or just click the support.OtherUAE in the blue link at the top of this page

good luck
Genlock is offline  
Old 14 April 2017, 06:34   #3
rsn8887
Registered User
rsn8887's Avatar
 
Join Date: Oct 2006
Location: USA
Posts: 729
Quote:
Originally Posted by Crazy C View Post
Hello forum!
UAE4ALL2

Has no stereo separation and collision detection setting

Autofire only available through control presets, not definable for custom control buttons

Autofire buttons and normal fire buttons exist separately (shortly tapping autofire buttons doesn't trigger fire)

Autofire 'medium' is in fact 'heavy' and 'heavy' doesn't do anything
Note that I also noticed and fixed all the quoted problems above and many more, but I did this only in the Playstation Vita port of UAE4all2. I also added customizable multiplayer controls for Vita TV in the Vita port (up to four mappable controllers on Vita TV).

https://github.com/rsn8887/uae4all2/releases

Somebody might be able to enable these fixes also on the RPi version, maybe using "diff" to see the differences. For some of my changes it might be as easy as removing some "ifdef __PSP2__" statements, for others (multiple controller for example), it would require some more changes than that. Most of my changes are protected via "#ifdef __PSP2__" so they are only active on the PS Vita for now. But I did this mostly because I didn't have a RPi 3 to test.

But I don't have time to do any of this myself. Especially since I am more interested in UAE4Arm on the Pi, but that is a whole different beast.

Last edited by rsn8887; 14 April 2017 at 19:17.
rsn8887 is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
UAE4all2 / UAE4arm Comparison on Bare Raspbian... Panthros support.OtherUAE 8 01 March 2017 16:08
RaspberryPI uae4arm Chips support.OtherUAE 91 24 December 2016 11:17
How to run Grafx2 under Uae4Arm? lovinggames support.OtherUAE 5 22 August 2016 23:02
PocketCHIP and UAE4ARM ali-b support.OtherUAE 0 12 August 2016 10:22
UAE4ARM, actually for ARM? Enverex support.OtherUAE 3 08 June 2016 11:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:00.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.11926 seconds with 14 queries