English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General

 
 
Thread Tools
Old 21 May 2017, 15:28   #1
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
GLHexen2 Warpos.

As requested, my "rogue" port for warpos (didn't know where to put this).

Use AHI 8 or 16 bits. Possibility to grab the left button mouse in window mode ( see readme).

Still bugs and fixes to be done to the original code.

DO NOT USE the "demos" to check the game as those on the original 68k package, or you will be dissapointed (are really bad done). Use original game cd paks.

Edit: Removed beta2.

Last edited by Cowcat; 27 May 2017 at 20:10.
Cowcat is offline  
AdSense AdSense  
Old 21 May 2017, 16:49   #2
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 763
Great job it seems to work so far.

I have AHI 8 bit DMA selected so hz reported is some huge number 381924892 something like that, the original Hexen 2 68k version had this same problem.

800x480 works but the heads up display looks like it's positioned 1/4 up the screen.

Opening Options in the menu locks up the game.
grelbfarlk is offline  
Old 21 May 2017, 16:57   #3
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
grelbfarlk:

All screen options are better be changed from shell (-w , width, -f , etc). Those get "almost" saved & you can restart without calling a shell.

Don't use DMA on ahi. Hedeon says it doesn't work well. Better (paula?) 8 bit stereo (I use fast paula 8 bit stereo++).

Whatever changes on options gl parameters it's preferable to check those and then close the game & restart.

Permedia users -> GL_luminance 8 bit.
VooDoo users -> GL_RGBA.
Cowcat is offline  
Old 21 May 2017, 17:35   #4
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 763
Sound works fine with 8-bit Stereo ++ I used 27khz (or whatever nearest).
Runs well.

Joystick doesn't work, I'm using a PSX pad with Kipper's adapter in second mouse port. In_joystick and Joystick don't seem to be recognized as variables.
grelbfarlk is offline  
Old 21 May 2017, 17:42   #5
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 385
using the -nomouse option makes the options menu work (strangely enough).
Hedeon is offline  
Old 21 May 2017, 18:24   #6
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
Seems to work ok with me with no "-nomouse" option. Even can change effects options with no problem (those shadows are wrong, again old quake stuff), but I stay away from changing screen modes/resolution/apply.....

Still a lot of bugs to fix
.
Cowcat is offline  
Old 21 May 2017, 18:38   #7
BSzili
Registered User

BSzili's Avatar
 
Join Date: Nov 2011
Location: Hungary
Posts: 214
Send a message via MSN to BSzili
Quote:
Originally Posted by grelbfarlk View Post
Sound works fine with 8-bit Stereo ++ I used 27khz (or whatever nearest).
Runs well.

Joystick doesn't work, I'm using a PSX pad with Kipper's adapter in second mouse port. In_joystick and Joystick don't seem to be recognized as variables.
The joystick support was originally written for Poseidon, and doesn't work very well with the regular lowlevel.library. It assumes that the controller types can be reliably detected upon startup. You can try to use a program like JoyPortTest to make sure the type reported by lowlevel.library is joystick/gameport and then start the game. I plan to overhaul this, but haven't got to it yet.
BSzili is offline  
Old 21 May 2017, 18:39   #8
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 385
Quote:
Originally Posted by Cowcat View Post
Seems to work ok with me with no "-nomouse" option.
.
Tried it again and crash when no arguments used with glhexen2. Options work with 'glhexen2 -nomouse'. Maybe Sonnet specific.
Hedeon is offline  
Old 21 May 2017, 18:53   #9
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
My plan is to get rid of all mouse nonsense, so that implies changes to original code & to behave like my usual stuff with windowmode.
Cowcat is offline  
Old 22 May 2017, 16:00   #10
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,158
There is a version GLHexen2 68k?
AMIGASYSTEM is offline  
Old 22 May 2017, 16:03   #11
Aladin
Registered User
 
Join Date: Nov 2016
Location: France
Posts: 128
@AMIGASYSTEM:

BsZili port:
http://eab.abime.net/showthread.php?t=83804
Aladin is offline  
Old 22 May 2017, 18:48   #12
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 385
For the ones who missed it: Great job so far!

[ Show youtube player ]
Hedeon is offline  
Old 22 May 2017, 22:20   #13
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italia)
Posts: 2,158
Quote:
Originally Posted by Aladin View Post
Perfect, tested on AFA OS screenmode RTG 800x600
[ Show youtube player ]
AMIGASYSTEM is offline  
Old 27 May 2017, 02:30   #14
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
Ups... Maybe someone is wondering where the cool effects went (hitting things = kaboom) or why the spiders are kinda sedated or when the witch is going to appear in the game. Basically the gore.

Mistery? No, big mistake !! "posix library" is missing in the binary.


Wonder why all could function after all. Expect a proper next "beta".

By the way all version uploaded are done with latest vbcc
Cowcat is offline  
Old 27 May 2017, 15:18   #15
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 385
Can't wait for it! :-)
Hedeon is offline  
Old 27 May 2017, 15:38   #16
Aladin
Registered User
 
Join Date: Nov 2016
Location: France
Posts: 128
I have use your port of hexen2 in my topic: FPS on amiga (topic in french)

http://www.amigafrance.com/forums/to...ier-fps-amiga/

Have you another good WarpOs/Warp3D port?

Last edited by Aladin; 27 May 2017 at 17:18.
Aladin is offline  
Old 27 May 2017, 20:16   #17
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
Ok. Hope that it works better

Added fog, a little bit of fix for shadows (that needs much work to be decent), no annoying mouse for fullscreen, the explosions, blabla...

Do not use menu to apply changes for videomode/resolution etc. Still not a solution for this. Just do it like BlitzQuake. See readme.

Last edited by Cowcat; 13 November 2017 at 14:26.
Cowcat is offline  
Old 27 May 2017, 20:18   #18
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
Aladin: Nice work

No more ports for today.

Last edited by Cowcat; 27 May 2017 at 22:38.
Cowcat is offline  
Old 27 May 2017, 21:41   #19
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 385
Options screen now works every time.

-nomouse option still results in a mouse pointer on the screen.

timedemo demo1 crashes mostly at the end, sometimes in the middle. I think some interrupt behaves badly, but not sure. It's demo1 from the AROS archive. Same behaviour with -w and -f.

I now see more gore. -)

Thanks for the update :-)
Hedeon is offline  
Old 27 May 2017, 22:20   #20
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 293
Hedeon: Don't use -nomouse Should not be looked as half working as before. Until I find something to cleanly separate the old code from other ports, this option doesn't work well.

You don't play with mouse ?

Sometimes timedemo does something bad, but I only see the crash when closing the game (the last beta did the same). Maybe increase vertexbuffersize.

There is a bug in one of the scenes: When you see the "sheep doing the jump", the game slows down because an effect keeps doing "something" as being in a loop, probably the whole level. Happens also in my testing linux version: When I was figuring out how the messages work and printing the resoults, the effect message keeps printing on screen. Of course a nowadays PC doesn't slow down at all but the effect message, weird enough, is the same when you hit a wall....

Maybe a non patched wad/pak ??

Last edited by Cowcat; 27 May 2017 at 22:32.
Cowcat is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
UAE for WarpOS 0.8.12 grelbfarlk request.Apps 0 23 November 2016 02:14
WarpOS Programming Help? esc support.Other 8 21 October 2015 11:37
DarcNES emulator for WarpOS Leandro Jardim support.Apps 1 02 May 2015 18:41
WarpOS MiniGL blues. Cowcat Coders. General 16 22 February 2014 19:44
ppc.library and WarpOS oldpx support.Apps 5 23 August 2002 17:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 00:26.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.18896 seconds with 13 queries