English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 09 October 2018, 13:55   #2841
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
Ok...update....ive installed your icon library....along with fblit and fblit.cfg(os3.5) via winuae environment using the OS3.1.4 rom....ecs etc.

All seems to be working...Scout shows Fblit is working...I have my 1.8mb chip back...system seems faster as usual....I will try the sd card in my A600 tonight....as o know winuae always makes stuff work...lol
Mark sealey is offline  
Old 09 October 2018, 14:12   #2842
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
I'm relieved to read that FBlit still works at least with my library.

@AMIGASYSTEM
Yes, PolyNet looks nice, but as you may know already, I don't install any eye candy on my system, it's a working horse, not a neat unicorn ...
PeterK is offline  
Old 09 October 2018, 14:20   #2843
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,530
But... you make it poop rainbows!

FBlit + FText works for me too with my own blend of OS3.9 with OS 3.1.4 components.
kolla is offline  
Old 09 October 2018, 14:33   #2844
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Quote:
Originally Posted by kolla View Post
But... you make it poop rainbows!
Yes, I know ...
[ Show youtube player ]
PeterK is offline  
Old 09 October 2018, 16:04   #2845
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
Quote:
Originally Posted by kolla View Post
But... you make it poop rainbows!

FBlit + FText works for me too with my own blend of OS3.9 with OS 3.1.4 components.
Ive never got ftext to work.
Mark sealey is offline  
Old 09 October 2018, 19:04   #2846
Michael
A1260T/PPC/BV/SCSI/NET

Michael's Avatar
 
Join Date: Jan 2013
Location: Moscow / Russia
Posts: 648
The IconDemo disk seems to work fine under 3.1.4 rom, so I guess if configured correctly it should work ok. You might need WBCtrl to force push icons to fast ram eith OS supplied icon.lib, but we are talking about a much enhanced replacement here.
Michael is offline  
Old 09 October 2018, 21:11   #2847
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Hello Michael,

I guess you are referring to Mark's problem with the 3.1.4 icon.library and FBlit. He's using my library now and that seems to work. The 3.1.4 docs say that you should not use WBCtrl anymore, that 3.1.4 would detect and know when images can be loaded into FastMem.

Something I would like to know from you is what your experiences with my HAM modes are, since you and Thorham were asking for HAM6 support? So, how is it going now?
PeterK is offline  
Old 10 October 2018, 01:40   #2848
Retrofan
Ruler of the Universe

Retrofan's Avatar
 
Join Date: Mar 2010
Location: Lanzarote/Spain
Posts: 5,998
Quote:
Originally Posted by PeterK View Post
Don't know if 3.1.4 offers any substitutes, but probably some suboptimal solutions ...
LOL, IMHO a new substitute for your icon.library should be called an imposter.
Retrofan is offline  
Old 10 October 2018, 13:40   #2849
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Quote:
Originally Posted by Mark sealey View Post
... it appears that the new OS dont like Fblit...(locks up with os3.14 icon.library) thats a shave as i loved Fblit saving my chip ram.
I've checked that now. OS 3.1.4 with icon.library v45.22 installed still works together with FBlit, fblit.library and my Envarc:FBlit.cfg for WB 3.5+. There are no locks, but the 3.1.4 icon.library wastes some ChipMem like the OS 3.9 icon.library v45.1, too.

And I can't see yet, why we should not use SwazInfo or RAWBInfo anymore, because there is nothing to change the icon type in the default Icon Information window.
PeterK is offline  
Old 10 October 2018, 15:51   #2850
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
First test with os3.1.4.....(known working system)....fblit in start up sequence.....no 3.5 fblit.cfg

No remlib or loadmodule for library

SCOUT says fblit is running....and icon.library v45.6

System first boot seems ok at first but locks up with 1.8meg chip.then is hard to reboot/reset

TO DO...

install library with remlib.
Mark sealey is offline  
Old 10 October 2018, 16:09   #2851
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,530
Quote:
Originally Posted by PeterK View Post
And I can't see yet, why we should not use SwazInfo or RAWBInfo anymore, because there is nothing to change the icon type in the default Icon Information window.
"Most users" have no such needs, you know
kolla is offline  
Old 10 October 2018, 16:22   #2852
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Quote:
Originally Posted by Mark sealey View Post
os3.1.4.....(known working system)....fblit in start up sequence.....no 3.5 fblit.cfg

SCOUT says fblit is running....and icon.library v45.6
Sorry Mark, I don't understand what you are trying to do.

FBlit, needs fblit.library and an ENVARC:FBlit.cfg for OS 3.5+, because the workbench.library of 3.1.4 is v45 and not v40 as in OS 3.1

What is icon.library v45.6? Is that from 3.1.4, too? Are there different versions of icon.library in the 5 available packs? For A500/600/2000 the icon.library is v45.22 and that works with FBlit.

@kolla
And what should the users do if they want to change a tool icon into a project? Ok, there are lots of other utilities for changing the icon type, but I prefer to stay with SwazInfo AND RAWBInfo installed.
PeterK is offline  
Old 10 October 2018, 16:30   #2853
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,530
@PeterK
I know, same here. My comment was meant tongue-in-cheek, "most users" seems to be the typical answer to all such questions.
kolla is offline  
Old 10 October 2018, 18:11   #2854
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
Im try to get your library to work with fblit.

Fblit is installed apart from fblit.cfg(will do that later)

Your 020 icon library installed in libs:

Nothing in in the start up sequence yet...no loadmodule or remlib.
Mark sealey is offline  
Old 10 October 2018, 20:44   #2855
Michael
A1260T/PPC/BV/SCSI/NET

Michael's Avatar
 
Join Date: Jan 2013
Location: Moscow / Russia
Posts: 648
Regarding WBCtrl, you have to use it with 3.1.4 if you run DOpus5 and CGX with your library to push icons to fast ram. So IMT=ANY is needed. Then icons do not use chip ram.
Michael is offline  
Old 10 October 2018, 21:01   #2856
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
So I have to install p96 on a ECS machine and WBctrl ?
Mark sealey is offline  
Old 10 October 2018, 21:37   #2857
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Quote:
Originally Posted by Mark sealey View Post
Im try to get your library to work with fblit.
Strange, since you told me that you did that already successfully: http://eab.abime.net/showpost.php?p=...postcount=2841

Quote:
Fblit is installed apart from fblit.cfg(will do that later)
I don't know if it's my poor English, but this seems to make no sense, because FBlit always needs fblit.library and also ENVARC:FBlit.cfg. The internal default settings of the FBlit configuration are not optimal for WB 3.5+ or 3.1.4 WB v45.

Quote:
Your 020 icon library installed in libs:

Nothing in in the start up sequence yet...no loadmodule or remlib.
That's correct, because 3.1.4 needs no LoadModule or RemLib for icon.library. SetPatch does this job, provided that it is the new SetPatch from 3.1.4 and not the old one from 3.1.

Quote:
So I have to install p96 on a ECS machine and WBctrl ?
No, forget P96, I tried that already and it's no optimal solution, because all disk icons are appearing in 4 colors only.
PeterK is offline  
Old 10 October 2018, 21:55   #2858
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
Sorry....im not the brightest of ppl....and have been away from the Amiga scene for a long time....I'll make sure fblit.cfg is in the right place....then if I loose stability then I'll delete it....and not bother you again.

I did have it working perfectly with os3.1(2 weeks ago)

But upgraded to os 3.1.4..this week...thats why I've posted so much.

Last edited by Mark sealey; 10 October 2018 at 22:04.
Mark sealey is offline  
Old 10 October 2018, 22:09   #2859
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,383
Concerning the locks that you reported, are you sure they are not a Furia or card problem again?

So, your problems are only on the A600 with the Furia and not under WinUAE, right?
PeterK is offline  
Old 10 October 2018, 22:33   #2860
Mark sealey
Registered User

 
Join Date: Sep 2018
Location: Nottingham
Posts: 29
Quote:
Originally Posted by PeterK View Post
Concerning the locks that you reported, are you sure they are not a Furia or card problem again?

So, your problems are only on the A600 with the Furia and not under WinUAE, right?
The locks were with os3.1...3.1 roms

With os3.1.4 and 3.1.4 roms my system is super stable....had all sorts of software running with it...unlike os3.1....I was playing with vista pro this morning....on os3.1 it would lockup....perfect paint works a treat now too...all my demos and whd load game's too.

I find everything works with winuae...ive spent many hours building the os/boot partition and loading it with eye candy only for it not to work with my A600...yes the Furia is a tricky card to work with.

The icing on the cake would be your library and fblit/ftext.

Last edited by Mark sealey; 10 October 2018 at 22:38. Reason: Typos
Mark sealey is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:26.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.15565 seconds with 14 queries