English Amiga Board


Go Back   English Amiga Board > Support > support.WinUAE

 
 
Thread Tools
Old 17 March 2019, 23:21   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 3,102
Device type in ATAPI tape IDENTIFY DEVICE data

Just wondering... looking at ide_identity_buffer() in ide.cpp, the first word of ATAPI IDENTIFY DEVICE data is set to 0x85C0. Bits [4:0] of the MSB give the device type, here %00101 = 5. That's the device type for CD-ROM.

That value seems to be also used in the ATAPI tape drive case. But the correct device type there is 1 (sequential access), so the first word for ATAPI tape drive should be 0x81C0.
mark_k is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Type of CD-Device sigma63 support.WinUAE 3 10 January 2017 16:34
DivIDE Type Device for Amstrad CPC 464 manic23 request.Other 9 16 August 2014 11:55
Atapi device not found protek support.Hardware 27 29 June 2010 08:52
Free ATAPI.device? moondynejoe support.Apps 3 03 February 2009 14:19
Slim CD drive with idefix97.....atapi device appears not to be working Smiley support.Hardware 9 28 April 2007 20:03

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:46.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.05630 seconds with 13 queries