English Amiga Board


Go Back   English Amiga Board > abime.net - Hosted Projects > project.Green Amiga Alien GUIDES

 
 
Thread Tools
Old 24 September 2008, 21:25   #81
Charlie
. . Mouse . .
Charlie's Avatar
 
Join Date: Jun 2005
Location: Nowhere
Age: 49
Posts: 1,792
You're welcome.

Things to think about:
-A fair few of the files I included are 'a bit' out of date now.
-Amithlon does USB too!
-If anything doesn't work out of the box as long as the basic setup works, you've every chance of finding drivers...
...OpenPCI being one to look into.
-You can get Warp3D under Amithlon - see higher up this thread.
-Forget Amithlon's Fat32 support - it's just the normal 68k Fat95 thing & there are newer updates on aminet. There's also GiggleFS...
-Network via NetFS, SAMBA, SmbFS...
...all a bugger to set up on the miggy but with persistence you'll have network shares transparently mounted on your WB.
-Don't forget: There's no worries about lack of horsepower here! Once you've done all the usual tweaking it's time to throw all the eye-candy @ it that you can.
Charlie is offline  
AdSense AdSense  
Old 26 September 2008, 22:27   #82
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Hi BryanRodrigues,

I bet the issue was, having two partitions both with bootable checked on. You have repartitioned and the problem went away.

I couldn't get usb to work on my P4T533C motherboard. Arakattack from Aminet didn't work for me, or maybe I'm missing a point somewhere.

Charlie is so very right, Fat95 and GiggleFS are great. You can mount your AmihtlonSYS partition with Fat95 and your other NTFS partitions with GiggleFS if there are. Charlie is the guru of Amithlon by the way. I couldn't have my system installed without his guide and advices

When it comes to chipset emulation. It is rumored that with QNX you can have AGA emulation. I never got into QNX, so I am never sure if it is true. I wonder if Charlie have ever tried?

But if you're gonna use 68k UAE. I'm kind'a expert at that
Download and install this package. You will be able to run WHDLoad games on your Amithlon via E-UAE with no hassles. You will also be able to run your chipset requiring apps (like DPaint, AmosPro ect.) the same way. Read the readme very carefully.
http://aminet.net/util/batch/E-UAELoad_v1.3.lha(this is the legal version )

Have fun
Alper

Last edited by alpyre; 27 September 2008 at 00:58.
alpyre is offline  
Old 28 September 2008, 03:28   #83
BryanRodrigues
 
Posts: n/a
Hey guys,

Thanks again for the replies.

Still working on my audio.....

Can't seem to get it working...

PCI List shows 2 cards...

On Board: Intel Corporaton/82801EB/ER AC 97 Audio Controller 'Don't want this one

Card: Ensoniq/5880 Audio PCI

using AHI prefs, i've selected Amithlon_1:HiFi 16 bit Sterio ++ (I've tried all amithlon entries) driver: Devs:AHI/amithlon.audio

anything that plays sound gets : unable to open ahi.device.

Any ideas here?

Going to try USB next, i think once i have the sound and USB working, i'll start trying to get E-UAE going..

Thanks for the file Alper, i'm sure i'll have some questions..

Bryan
 
Old 28 September 2008, 12:01   #84
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
You're welcome.

First of all, I bet you have installed:
PowerPCI and OpenPCI libraries. BoingBag1, BoingBag2, BB2Contributions, AmithlonUpdate and finally copied Drivers0.90 (from Gary Collive) to the apropriate drawers.

Secondly you surely should refer back to Charlies guide on driver issues. But for a quick reference.

There are two types of drivers you can use on Amithlon.
-Native Drivers (68k OS3.9 drivers) (mostly recommended if there is)
-Linux Side Kernel Drivers (Kernel Drivers) (better than nothing)

There is no written Native Drivers for your sound hardware yet. (sorry)
But maybe there are Kernel Drivers for them.

Kernel modules (drivers) work just the same as they work in Linux. You specify the apporpriate module for your hardware, and you insert the module into the kernel with insmod command. (INSert MODule - PCIinsmod on Amithlon)
You reach the inserted module via amithlon.device from OS3.9 side.

If you already have an pciinsmode command (without arguments) in your startup-sequence, it detects the hardware you have at startup and inserts the right modules automatically to your kernel. But if there are two hardware of the same type, modules will be inserted for both, and they will conflict. So you have to choose which one to use, and let insmod command to insert only the right one. (once a module is inserted, you have to HardReset your Computer to remove them)

Now go to your S: drawer and read the file "pcimodules". Have a detailed look at the lists. Search for your hardware. If you can find the module for Ensoniq/5880 (well I don't think you will) and make sure it is inserted. And make sure your other hardware snd-intel8x0.o is not inserted. (you can query the inserted modules with xcat command. (You will have to search and read all the readme files carefully to learn how all these are done.)

To be realistic, you don't have much choice. It is best to use the hardware that works. By this I mean, if your o/b AC97 works, use it. Or buy a secondhand Vibra128 or SBLive!. They have native drivers.
alpyre is offline  
Old 30 September 2008, 02:19   #85
lost_loven
Registered User
 
Join Date: May 2007
Location: winnipeg
Posts: 358
hey there all, running a amithlon system too on a old compaq 667 mhz system with 256 megs of ram.. running pretty sweet but a couple of problems .... anybody get a ide 100 meg zip drive to work? that and i only have dlink dfe-530tx, dfe-538tx and a smc 1660t pci network cards.. have also a cnet network card with bulit in modem (diamond media) which am having no luck with.. any suggestions to where to get drivers or something to get networking going?? HELP! using a cd-rw is a pain going back from one to another to transfer software etc..
lost_loven is offline  
Old 30 September 2008, 12:45   #86
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Hi Lost Loven,

Zip Drive
Make sure your Amithlon is patched with latest patches. Contrib2 (by Bernd Meyer) includes an experimental patch for Zip drives. Obtain it, read the readmes and learn installing/using it.

Network
Same issues apply with the previous posts. Learn the way Kernel drivers work. Examine the files S:Pci_modules and Devs:PciDrivers/... Look for modules that will be able to support your hardware. Once inserted succesfully, your network cards will be accessible via amithlon1_net.device.
If you cannot find any appropriate modules, try obtaining a supported NIC card (eg. Realtek RTL8139). They are not so expensive and not so hard to find.

Transfer files
After having a working network card, Samba will be your cure.

Alper
alpyre is offline  
Old 01 October 2008, 05:17   #87
lost_loven
Registered User
 
Join Date: May 2007
Location: winnipeg
Posts: 358
whooo i have a zip drive! next is network.. no time tonight for that but tomorrow is another day.. I be back! with goo d or bad news! thanks a million alpyre!
lost_loven is offline  
Old 02 October 2008, 01:19   #88
milanca
Registered User
 
Join Date: Oct 2008
Location: Serbia and Montenegro
Posts: 69
Hello guys,
first of all its nice to meet all of you here and thanks a bunch to Charlie for making this great GUIDE. Thank you man! I am 34 yrs old , haha pretty old computer user, started with C64 back in '84. Well, i missed amiga, it was out of my budget back then. I started with one of first 386 machine until now, i run one amd x2 5600 and one intel box q6600 for my work, mainly 3d work etc. Thats about mysefl!

Well, when i found about amithlon (i have to admin it was just recently)i was so impressed and i cant express how happy i was. It is installed and i think i'm almost there. I used my wife's old computer, P3 667mhz with 256mhz sdram 133, apollo via 133 board. Well, what to say, a real beast of a machine ;-) Graphic card it had was S3 Savage with 16mb of ram, which i replaced many years ago with Geforce2 Mx400 just because we couldnt play any divx movies with old S3 one when we go to her hometown (my wife's). I kept that machine alive all these years, replacing memory, hdd, after el. shocks during storm. Now when i know about amithlon i had an idea of installing it on this machine, i never had an Amiga before and guys i am so happy with it. (I used to install WinUAE and running EUAE on Mac also, playing a bit in workbench, installing from scratch and stuff).

Amithlon is booting just fine. I installed everything with no problem at all. I am also a bit of linux user. Following Charlie's guide i think there should be no problem making it work. Internal image copied to amiga's virtual hard partition, i can boot into Installed hdd. But now my problems begin.
-I had immediate crashes (comp. restarts) when i wanted to install os3.9 from amithlon cd. There is no particalar rule when it might occur, on right click sometimes when i want to window->show all. I can change resolutions via ScreenModes, but first i have to start Picasso96 from prefs, then pick somethng like 1024x768, reboot, etc.. After this i could start OS3.9 installation but no matter if i pick (when asked about unpacking to ram or just proceed) after unpacking computer would just restart all by itself. Right now i dont know how i managed to install 3.9, probably by changing graphics modes; i have plenty of resolution options, builtin: up to 1280x1024 in ScreenMode.
-New problem appeared. I cant install BB3.9-1. Instant crash and restart just by launching the installer. When i boot using internal image i can launch the installer and install stuff, but later when i switch to HDD system, i am always on 'stand-by' for the system not to crash. It might happen when launching unarchiver, or just on a single click, completely unpredictable.

I guessed it was graphic card issue, Gf2 mx400. I switched it with old S3 Savage (also AGP) and none of the problems above happened. But i cant change any resolution, stucked with 640x460.. I also updated amithlon with all the patches (everything done properly), resolutions are changeable, but when i increase it, go 16bit or 32 bit problem with instant crashes reappeared. So if i dont change the res with s3 savage system would work just fine. Maybe it would work with GF2 but i cant install anything. I saw somewhere that GF2 is supported but how to tweak it. I tried almost everything (hehe its leading to the divorce cause wife was so pissed off because of me trying to make it work during entire weekend). I tried adding video=dovesa, messing with start-up sequence. Everytime with the same result, everything works fine just cant be sure when its gonna crash&restart.

I also disabled everything i could in BIOS, serial, parallel, audio (which is working though) just to see whats causing the problem. Amithlon Updates and patches done, not to forget to mention. Also i saw somewhere something about P3, i guess all the patches are on proper places. I am pretty sure its all because the graphic card but as i am amiga newbie i am really out of options what to do. I remember when installing everything in UAE, especially Picasso96 i had to skip some options (picasso96 modes or so) cause it wouldcause problems. Maybe its Picasso also here, maybe issomething totally different, or both of these video cards are unsupported.

What do you guys suggest me to do? Sorry for writing a lost post, i wanted to completely illustrate everything so you, the experts, might get a picture of what to do.
Thanks guys a million and sorry if there are any mistakes in language cause its not my native.
-Milan.
milanca is offline  
Old 02 October 2008, 13:39   #89
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Hi there Milanca,
Wellcome to eab.abime.net forums.

I'm not an expert but I have some ideas that maybe would be your cure.
First:
There is a patch for Intel Pentium CPU's in one of the BoingBags. I hope you have chosen the right one as installing it.
Second:
The suspect is mostly the graphic card. Because you say it crashes when you double click OS3.9 or BoingBag installers. The first thing these installers do is to open their own Public Screens with the highest resolutions available. And you also say it works fine with another graphic card without higher resolutions.
a) Did you update Picasso? If you did, you should be only updating the drivers, not the Picasso executables. Please refer Charlie's guide on this.
b) Did you copy the new rtg.library from one of the latest WinUAE packages. (which is v40.3994) It helps a lot at opening higher resolutions and increases speed too. It resides in "Amiga Programs" folder in WinUAE archives and should be copied to your "SYS:Libs" drawer.
Third:
If the above two is not your cure:
You mention that it works flawlessly with the internal HD image (which as I know is fine tuned by Charlie). So why don't you copy whole the files of that system to your harddrive partition and begin making your customizations from there?

I hope these be helpfull
Alper
alpyre is offline  
Old 06 October 2008, 02:11   #90
bombuzal
 
Posts: n/a
Wink

Hey

I appear to have forgotten my original username or e-mail, so I've re-registered.

Just noticed the tutorial in this thread no longer appears to exist - so here's one I wrote a few years ago: http://www.cgx.org.uk/?id=9

It's not great, but should be good-enough for beginners. There may be a couple of dead links (I transferred it a while ago from my old site) - but I'll get round to restoring them one of these days ;p

Bombuzal.
 
Old 06 October 2008, 13:09   #91
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Wellcome back bombuzal

If you mean the tutorial "Charlie's Amithlon Guide", the link is still valid.
http://www.box.net/shared/hisnu6o4lc

You have written a very smart alternative guide there. But I have to say that it is a little outdated. It has to be updated to include the use of Kernel 3.10 and other very important issues with the modern hardware. If you'd like to update and maintain your tutorial, Charlie's guide would be a great referral to you (which also requires some additions).

Thanks for your efforts
Alper
alpyre is offline  
Old 06 October 2008, 13:12   #92
milanca
Registered User
 
Join Date: Oct 2008
Location: Serbia and Montenegro
Posts: 69
@Alpyre: Thanks a lot for replying and helping me out.

Actually everything i did was just the same as you suggested. First after making amiga's partitions i copied everything from amithlon_hd to my system partition, and then i started upgrading from that point. I copied it with "copy amithlon_hd: system: all". This weekend i tried installing everything again, from scratch, all over again (hehe i am not giving up, until i make this working).

1) With Geforce2 mx/mx400-64MB I can't do anything. As when i installed it before, for the first time i tried, it crashes when i start to install OS3.9-Install (BB3.9-1). ScreenMode doesnt offer me to change modes. My workaround was to install AmithlonUpdates first (from patches folder) then i can change mode with new powerfb monitors, i change mode to 1024x768x8bit. After this, i installed OS3.9-1, then BB3.9-2, everything that should be installed. I also installed System updates again (which i installed first in the process) to make sure it wasnt overwritten by some of later installations, just in case.
After everything, i can use geforce2 card, i applied settings to nvidia-1. I can test and use many of the resolutions but the only stable one is 1024x768x8bit. When i test from picasso96 for example, 16bit color mode, its displayed instantly and properly, but when i switch to it, after some time i have mouse freeze or just system crash.
I also updated rtg.library. I didint installed new picasso96 cause honestly i dont know what exactly to select from the options not to ruin system. So i just copied rtg.library to picasso lib and i copied picasso96fix to my C:. I added it to my startup-sequence before loadwb, C:Picasso96Fix (not sure if its all right, thats why i am explaining my steps).
Its all the same, i can't switch to 16bit mode. Monitor is Sony trinitron17" multiscan 200sx. 1024x768 is fine resolution for it, just i am stucked with color modes.

2) I also installed everything from the beginning with other card S3 Savege 4, 16MB. I can installed os3.9-1, bb3.9-2, all the updates without doing anything else. everything works fine (everything done in small resolution, default 640x480. After all the updates, i tried this card in VESA mode. I can apply settings in picasso96 to board vesa-1. But i think this video card has weak vesa support. I can use only 8bit mode, when trying to go to 16bit mode it becomes unstable, crashes and restarts.

3) Not quitting yet. I took my laptop with me to have internet connection. Cause i couldnt achieve all i wanted on P3, I installed everything on my laptop. Intel CoreDuo, 80gb sata, via chipset and video is (it sucks but it is what it is) Via Chrome9 HC IGP /128mb. Everything going fine, all, the installations and updates. I tried to run it in VESA mode, it works. And its completely stable in 16bit mode, 1024x768. 32bit mode i think doesnt work, cant tell for sure(cant remember, lots of testing for entire weekend). Its a wide screen 15.4" TFT laptop display, so this resolution looks a bit stratched on the screen. All the other modes dont work. I wanted to increase resolution but its out of my hands, and knowledge:-) Not sure if its even possible to achieve 1440x900 whats native for this display.
Graphics is killing me ;-)

offtopic:
Alpyre, from your signature you're from Turkey. Man, i have been there for 3 times and what i can tell i like it really a lot. Last two years, in a row, i went there by car. I drove all the way through Bulgaria, then Turkey, Edirne to Canakale, then to Ayvalik and Izmir. It was beautiful but a bit exhausting for me to drive (my wife doesnt drive) and i did it like that for 2 times. Maybe next year will take a plane and fly to Antalia directly.
milanca is offline  
Old 07 October 2008, 01:25   #93
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Hello again milanca

1) You have installed Amithlon according to Charlie's guide so you should be using Kernel 3.10. Kernel 3.10 supports Geforce MX series. It even supports its graphic acceleration. But to be upright it is listed in the supported GFX cards. But not in the tested GFX Cards.

At first screenmode prefs didnot offer me any screen modes. But after the updates (only BB1, BB2 & AmithlonUpdate that Charlie has supplied) I directly switched to 1280x1024 32bits. If you aim this resolution or lower, you don't need to install Picasso96Fix and any other updates other than the mentioned above. (just read on)

Note: I've also updated Picasso96 drivers(only). I did this update manually so I remember which files really have been updated. From my memory the drivers that were updated were not obligatory for our GFX cards.

2) Yes some cards has limited vesa support.

3) Your laptop looks to be a much better system for Amithlon. If it is supporting SATA, its chipset should be "VIA K8T800 Pro". Lucky for you.

I don't know how much memory you have on your laptop but, in one of the previous post Charlie has mentioned a memory allocation trouble:
Quote:
Originally Posted by Charlie View Post
... If you can it's worth removing (extra memory above 512mb) with IGP systems as the kernel could get very confused with regard to memory allocation...
But because you are always having trouble with video, I have a hunch that you are doing something wrong as you are doing updates

Of course you can have 1440x900. (as far as I know) This is why Picasso96Fix is for.

Note: Charlie, please correct me if I'm wrong at anything.

off topic:
Yes I am from Turkey/Samsun. It is in the north coast (a.k.a the BlackSea) of Turkey. I was in Antalya (this is the right spelling) this summer. Antalya was very humid and hot. I recommend you to see Aydin/Didim(Didyma) too. It is only 2 hours to Izmir. I'll be there next summer hopefully. Maybe we can meet in there too.

Regards
Alper
alpyre is offline  
Old 12 October 2008, 18:02   #94
Charlie
. . Mouse . .
Charlie's Avatar
 
Join Date: Jun 2005
Location: Nowhere
Age: 49
Posts: 1,792
D*mn me! There's been a lot of activity on this thread.

Sorry I've not looked in a bit...
...is everything sorted out now? Can I help?


On another subject has anyone heard of VMWare ESX Server..?

Basically it's a virtualisation layer you can install to a computer, you then install your OS on top of it...

Why?
Lots of benefits:
-You can have multiple OS's running on the same box @ the same time.
-Each OS is independent so one crashing won't bring down the others.
-Regardless of hardware your 'ESX System' looks much the same, so you can move your install around without worrying about what hardware you've got.

Usually this is used in server-OS situations where this allows much easier administration, greater reliability, less down-time, and less hardware required in the first place...

...See where this is going yet..?

It's becoming increasingly difficult to get Amithlon running on modern hardware...
Fine if you run a dedicated Amithlon box - A 2.5ghz AthlonXP with a GF4/5 card is never going to be overloaded by AmigaOS. But it's not fun for peeps wanting to multi-boot their main PC...

...See where this is going yet..?

If I can get Amithlon to work on ESX Server all our compatibility problems go away! AND you'll get a more reliable PC + the ability to concurrently run your OS's for 'free'.

Oh, and there's ESXi - the free version (for legality's sake). Fully functional, but with a 32mb partition limit.
Charlie is offline  
Old 13 October 2008, 09:26   #95
amiga
Registered User
 
Join Date: Aug 2004
Location: Amiga_land
Posts: 443
@Charlie:

Yes, Charlie, I too think ESX Server is the way to go.
Amithlon on it would be a dream. Please keep us informed on how you're progressing!
amiga is offline  
Old 13 October 2008, 19:59   #96
Charlie
. . Mouse . .
Charlie's Avatar
 
Join Date: Jun 2005
Location: Nowhere
Age: 49
Posts: 1,792
Fingers crossed.

Holls comming up so it may be a week or three before I test this one out.

Last edited by Charlie; 15 October 2008 at 09:34.
Charlie is offline  
Old 10 December 2008, 17:23   #97
milanca
Registered User
 
Join Date: Oct 2008
Location: Serbia and Montenegro
Posts: 69
Hi alpire, Charlie, Hi Guys!

It's been a couple of months since i started messing with amithlon. I used to work on making it work during weekends and when time allows it, and when i get enough pissed off, hehe, i used to give up. I had to accept the fact that my desktop box is hopeless so i burried that damn machine, until last week. It's revived now and working better than ever!!

I wrote about my laptop. I made amithlon working on it.
http://www.everex.com/products/va2001t/va2001t.htm

I gave up with it at the end. Intel dualcore, 1.7gh, sata drive, chipsets including audio all VIA. Everything was working fine, if i can remember well even built-in touchpad. But it was no fun running amithlon as it has very very poor VESA support. No fun at all.

Desktop box, totally different story. As i had random craashes all the time in spite of my persistence, i had to say goodbye to amithlon. It had no other OS other than amithlon. I installed XP and system used to freeze on right mouse clicks on desktop, and things like that. I thought it was faulty hardware. I didn't know that as before trying to run amithlon it had no other OS. When i took out the mobo, bad caps all around. I ordered all the capacitors for this board, took my soldering tools and replaced them all. Its working like a charm now. Geforce2 mx400, nv11, working great now. I couldn't install os3.9 with bb3.9-1 nor bb3.9-2 update. it used to crash just when initializing installation. No more ;-) When i least expect it all started to work.

Processor is pentium III, 667Mhz, 256MB sdram, 40gb ide drive. Motherboard is DFI CA64 T, sound viaac97.
http://www.motherboardpro.com/DFI-CA...ard-p-250.html

I installed everything and its all running fine (someone should shoot me if i didnt install it right, it was like 1001st time installing it :-). Graphics working great with GF2, NV11. P96 set to nvidia, 1024x768x32 on my TFT, updated rtg.lib. Also sound is working fine with viaac97 with my initial install, os3.9 with bb3.9-1 then updated to 3.9-2. A little problem i have is with Amithlon Updates from the installer. I dont select to update network or sound, and its not P4 processor, and after the update when playing mp3 (from amithlon cd/multimedia just for testing) first there is some strange noise, then playing normally. When changing songs in the playlist, also first some buzzing noise then song plays normally. It used to go all smooth without any strange noise when reproducing sound with initial install without updates.
So, i am very happy at the end to be running amithlon after months of trying it. Ethernet RTL8139, i'll be dealing with it later. My amithlon knowledge doesn't go beyond charlie's guide (thanks man for this). If you guys can suggest and advise me how to improve my system, what can i do next to fully enjoy my amithlon it'll be greatly appreciated. Thanks guys!
milanca is offline  
Old 12 December 2008, 22:35   #98
Charlie
. . Mouse . .
Charlie's Avatar
 
Join Date: Jun 2005
Location: Nowhere
Age: 49
Posts: 1,792
Hi milanca,
Welcome to the wonderful world of Amithlon!

It sounds like you've had a long & rocky road to a functional system - My hat's off to you for sticking with it, my patience may have run out...

Thoughts:
-Sound: It's odd you've got issues after installing BB2, this clicky-buzzy thing is a known issue with Amithlon & some driver/card combinations rather than AmigaOS itself.
Still, it may be worth looking for alternate driver versions for your sound chipset & see if that helps...
...v. broadly 68k AmigaOS AHI drivers work best, followed by 'Amithlon drivers', then the 'Linux-side' drivers that tend to be the cause of this issue - Linux is not a real time OS while AmigaOS is. (kind-of) If this doesn't get you anywhere it may also be a linux-side network driver b*ggering the Amiga sound - if this isn't avoidable try playing mp3's with your network stack unloaded.

Thoughts to make your system nicer now you have it..?
-Eye-candy! You now have enough grunt to run as many patches as you like:
MCP
PowerwindowsNG - I think it will run with the modified .ird's I included...
Birdie
AfaOS... the list goes on...

AmiKit, AmigaSYS & others are worth a look for ideas & stuff.

You CAN run Warp3D very well under Amithlon (see further up this thread) without engaging in the fruitless search for unreleased Amithlon drivers for the old Voodoo2.

USB support works well under Amithlon - The driver is ArakAttack - free. You'll need a copy of Poseidon - sadly 3.8 was the last version to support Amithlon & you won't get a licence from the developer these days...

Chipset Games?
Why not? 68k e-uae (& earlier / faster versions) work well on Amithlon though I suppose you should regard Amithlon as more of a 'high-end' system.
Two routes:
Install a full emulation within Amithlon (possibly pointing back @ your own Sys: partition )
Take a look on Aminet for alpire's very clever WHDLoad solution.

Food for thought?
More?

Hardware:
You already have something far faster than any traditional mega-bucks build could ever be...
The ideal Amithlon system (without a lot of messing about):
CPU: Athlon XP-M overclocked to 2.5gig +
GPU: nVidia GF 5xxxx (A full GF 4 is great too)
Mobo: DFI Ultra-B. (Abit KV7 is a great / suitable VIA-based mobo)
Basically you want a NF2-400 or KT-600 based mobo, turn OFF the sata in the bios & compare the other board specs (USB & sound) with GC's supported list.
Sound: SB 128 or !Live - old but gold (and better than any Amiga sound card)
Memory: Buy some DDR400+ ram & overclock it!!! Seriously, this kind of emulation NEEDS fast memory. (Again you don't need more than 512mb - Amithlon won't support it without much faffing & how much does an Amiga need?)

That should do for starters.


Oh, and I haven't forgotten about trying to get Amithlon to work on VMWare ESX Server - If I can get this to work that will be the 'Holy Grail' for Amithlon: Modern hardware issues gone + many other benefits...

Last edited by Charlie; 12 December 2008 at 22:43.
Charlie is offline  
Old 13 December 2008, 05:21   #99
milanca
Registered User
 
Join Date: Oct 2008
Location: Serbia and Montenegro
Posts: 69
Yo Charlie,
Thanks for helping me out dude, i really do appreciate it.

Just a little after posting my previous post, i managed making it all work. Sound and network are fully and properly working (had to hit the head off the wall for a couple of times to figure how it is to be done, drivers loaded, etc ;-) Amithon is on the internet! ;-)

i could try with Amikit, or AmigaSYS. Also 68k uae could be great if i make it work, to play some amiga demos, or Turricane ;-) I have two more machines, my workstations (used for everyday work, for a living) but the are far from amithlion capable. One is amd x2 5600+, gigabyte mobo 790x chipset with gigabyte 8800GTS modded to quadro 4600FX which i use for 3D work. Second is Intel Q6600 on Gigabyte P35-DS3 with 9600GT running Mac OSX 10.5.5 ;-) used for various graphic design, web design, etc. I also have a PowerMac G4 on 500mhz loaded with Tiger. I just cant sell this old Mac dude, i could try to load it with amithlon maybe .. once, if possible :-)
If i even try to build one more machine especially for amithlon, start chasing components for it, that will definitely lead me to my divorce hahahahah

But, when that old P3 board died for the first time i got (have it still) an Asus tuscl-2 board with tualatin 1,2ghz PIII and Geforce4. I could have built an amithlon box with it, but the only IDE drive i have is ata133,40gb and the asus board won't boot off it, only supports booting off ata100 drive. That would be nice and final upgrade to amithlon, 1.2ghz and GF 4 (have to check if its supported).
milanca is offline  
Old 15 December 2008, 11:36   #100
alpyre
Registered User
 
Join Date: Jul 2008
Location: Samsun / Turkey
Posts: 52
Hi there Milanca... Hi there Charile... great man

@Milanca
At last you made it to work, Congrats... You are a real diehard Amithlon user...

Yes... use as much eyecandy as you can. Here you take a look at my Amithlon screenshots:

* First thing you should install MUI and update its libraries...
* You can replace some of your OS tools with MUI versions . For ex. MagicASL...
* Donot forget MagicMenu
* OS4 Theme and dual PNG icons are done by AFA_OS,
* DualPNG icon set is KEN's ICONS v3 (v4 is much better) (don't forget to donate Ken )
* PowerWindowsNG lets you drag windows off the screen, like in MSWindows.
* For totally customizable requesters don't forget to install ReqAttack
PS: Note the programs, FroggerNG, ScummVM... And don't forget that you can play Doom and Quake with very good frame rates... Most of these software can be downloaded from Aminet, for others just click links
PS2: You can page a maximum of 1GB ram in ATI gfx cards. If you have NVidia it is maximum 768MB.

With a little work you can get your Amithlon OS3.9 to a level of replacing Windows in daily use.

------------

68k Uae is great on Amithlon... With my script package E-UAELoad you can run WHDLoad games with one mouse click (just like the animation below). Even more, you can get chipset app's like DPaint and AmosPro working on Amithlon too...
It is very easy to install. I have written user friendly installer scripts and documentation. If you have any problems installing, just PM me
E-UAELoad


------------

I wonder if you could install AmigaOS4 on your G4 Power Mac. It would be much smarter than trying to install Amithlon on that machine (which definitely wont work). OS4 is PowerPC native, and a really good OS.

------------

@Charlie : I am waiting with eyes wide open for your ESX Server results. Don't get discouraged but one of my friends in our forum have tried it without success...
alpyre is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
My first guide - Drakkhen leveling guide Fragger Nostalgia & memories 2 08 April 2010 21:35
Amithlon / AHI Sound Configuration Guide? dframeli New to Emulation or Amiga scene 10 11 September 2009 22:51
Amithlon-Guide / PDF-version Paul News 0 10 March 2006 15:43
Amithlon Peter Leyland Amiga scene 1 11 February 2003 02:43
Amithlon eldiablo10 support.WinUAE 6 20 September 2001 19:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.12087 seconds with 14 queries