English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 08 March 2016, 23:38   #1
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Minimal config for multiview

Hi,

I'd like to display a .guide file on a bare system.

multiview needs DEVS:datatypes/amigaguide

I use adddatatypes refresh

but that's not enough. There's a "Classes" folder too.

Any assigns?

I get a "multiview failed errorcode 20" without further explanation.
jotd is offline  
Old 09 March 2016, 00:13   #2
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,966
LIBS:datatypes.library?
SYS:Classes/DataTypes/amigaguide.datatype
amigaguide.datatype has "iffparse.library" string in it, not sure whether it requires iffparse (as opposed to it being optional).
SYS:Classes is one of the paths for LIBS:
And I assume MultiView needs at least Kickstart 3.0?
mark_k is offline  
Old 09 March 2016, 06:42   #3
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
thanks, got a little further but I get a cryptic message

packet request type unknown
jotd is offline  
Old 09 March 2016, 10:45   #4
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 3,491
Are you sure you have compatible versions of everything? Trying to use a 3.5 datatype on a 3.0 installation for example? Kickstart and Workbench agreeing? It should all "just work" with a clean installation - the datatype is part of the standard setup.

Have you got SnoopDOS handy? Does it give you any hints?
Daedalus is offline  
Old 09 March 2016, 11:49   #5
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 60
Posts: 3,868
Here's an adf I made for nittamituaki that loads Multiview with minimum files.

Last edited by Arnie; 13 March 2016 at 23:27.
Arnie is offline  
Old 09 March 2016, 12:04   #6
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Daedalus you may be right about 3.0 & 3.5. Snoopdos is not helping.
Arnie thanks exactly what I needed (using zetr0 principle to launch CD32Load games from Multiview because all other launchers are too cumbersome or just don't work)
jotd is offline  
Old 09 March 2016, 22:49   #7
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Thanks with your adf I could open the document... but it is an amigaguide document and it opens as text: no buttons, no links... Snoopdos tells me it doesn't even load amigaguide.datatype, only ascii & text datatype. Any ideas?
(I have zoned my mini-startup)
jotd is offline  
Old 10 March 2016, 10:12   #8
Arnie
R.I.P Smudge 18-08-16

Arnie's Avatar
 
Join Date: Aug 2005
Location: Leicester/UK
Age: 60
Posts: 3,868
Updated archive post #5
Arnie is offline  
Old 10 March 2016, 13:41   #9
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
you're a lifesaver (I did not mean a buoy) thanks. I'll test that tonight.
jotd is offline  
Old 10 March 2016, 20:42   #10
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,966
Have you considered using the (Kickstart 1.3-compatible) version of AmigaGuide instead of MultiView? That might need fewer libs & datatype files.

http://aminet.net/package/text/hyper/aguide34
mark_k is offline  
Old 10 March 2016, 21:26   #11
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Yeah mark, as long as I can display my guide, I don't care, you're right.
Aren't you the guy who wrote a big list of patches/cracks for games?
jotd is offline  
Old 11 March 2016, 20:53   #12
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,966
Yes
mark_k is offline  
Old 11 March 2016, 21:57   #13
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Amigaguide expert + your initials gave you away. I remember we talked by mail a couple of decades ago
jotd is offline  
Old 13 March 2016, 23:18   #14
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Thanks Mark Amiga guide V34 from Aminet displays the guide file without further annoyance. However I have a problem. The following works fine:

@{"Aaargh!" SYSTEM "cd32load CD0:GAMES/Aaargh!/aaargh!.slave JOYPAD=2 DATA=data"}

however, if a path has spaces in it, I don't know how to escape the quote chars. I have tried \ but it did not work.
jotd is offline  
Old 14 March 2016, 11:23   #15
Daedalus
Registered User

Daedalus's Avatar
 
Join Date: Jun 2009
Location: Dublin, then Glasgow
Posts: 3,491
According to the developer docs, using the backslash character to escape characters isn't implemented in V35, so I would guess it's not implemented in V34 either. Looks like you're out of luck there. Is there any reason you're not using a standard 2.x or 3.x install so you can use a newer version without the messing?
Daedalus is offline  
Old 14 March 2016, 11:55   #16
idrougge
Registered User
 
Join Date: Sep 2007
Location: Stockholm
Posts: 3,679
Isn't there a V37 or V38 version of Amigaguide?
idrougge is offline  
Old 14 March 2016, 13:22   #17
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,112
There is also Guideance and PowerGuide V1.23 (that one from Aminet CDs with update). Maybe its worth a try.
http://www.aminet.net/search.php?query=powerguide
daxb is offline  
Old 14 March 2016, 23:38   #18
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 47
Posts: 2,687
Mark_k: wasn't able to put quotes in my .guide.
daxb: guideance worked, but no way to escape quotes either.
Arnie, I got your new WHDboot, it worked, but same thing: cannot seem to escape the quotes. I have tried \ and * and no luck.

I'm thinking of redirecting the command to a script with execute. It will work, but will create more files.

Edit: did that, works very well. I'm sticking to it. Thanks all!

Last edited by jotd; 15 March 2016 at 00:19.
jotd is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
68000 minimal list of opcodes to know kamelito Coders. Asm / Hardware 8 28 January 2014 22:43
MultiView problem with pictures Bamiga2002 support.Apps 12 05 January 2013 12:17
WinUAE crashes with Multiview vroom6sri support.WinUAE 7 23 April 2007 23:46
A minimal request jobro Amiga scene 3 29 December 2005 04:24
Multiview sw2001 request.Apps 5 07 October 2004 00:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.08352 seconds with 13 queries