English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 30 August 2019, 20:09   #21
jPV
Registered User
jPV's Avatar
 
Join Date: Feb 2008
Location: RNO
Posts: 709
Quote:
Originally Posted by honx View Post
there is only ONE pdf set within deficons, set to rnopdf, so what is badly associated? it is associated to rnopdf, so what is bad about it? i don't see anything wrong. and still some pdfs are recognized, some are not, see screenshot, window below.
Maybe there's some "ascii" deficon definition which overrides the pdf deficon?

Quote:
i get the same crash/guru if i try rnopdf_os3 (no fpu), so it's NOT fpu related.
How much free memory you have? Maybe it could be there on the limit and cause issues? Although weird that it would coincidence with these deficon recognizing issues..

And check if you have those polybios files in LIBS:Hollywood/, just in case. If you have them there, are they same version or some older ones?
jPV is offline  
Old 30 August 2019, 20:15   #22
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by honx View Post
there is only ONE pdf set within deficons, set to rnopdf, so what is badly associated? it is associated to rnopdf, so what is bad about it? i don't see anything wrong. and still some pdfs are recognized, some are not, see screenshot, window below.
If he wants you to open it with EdiPAD, there are two reasons:
- Existing tools icon badly associated
- Wrong file name

If you send me the files I can be more precise
Quote:
codesets.library is v6.20 (04. august 2016), so which version is needed? polybios.hwp and polibios.exp are the ones which came with rnopdf itsself, they are in the same folder with rnopdf. so these two CAN'T be wrong, as they come from developer of rnopdf himself!
- codesets.library is also found in MUI/Libs deletes the older one
- polybios.hwp and polibios.exp are also used by other applications, check that there are no older versions in LIBS/Hollywood

To avoid duplication, it is preferable to have all Hollywood bookstores in LIBS/Hollywood

Quote:
i get the same crash/guru if i try rnopdf_os3 (no fpu), so it's NOT fpu related.
polybios.hwp and polibios.exp are supplied in two versions FPU noFPU, install the one related to the executable
AMIGASYSTEM is offline  
Old 30 August 2019, 20:16   #23
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by jPV View Post
Although you have interesting total pages number I wonder where that comes...
The translation does not allow you to understand well
AMIGASYSTEM is offline  
Old 30 August 2019, 20:20   #24
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,287
in deficons pdf is set within ascii tree. see screenshot 1
if i drag pdf out of that tree, working pdf files don't have an icon anymore. see screenshot 2.
the weird ones keep their text file icon although their fileending is .pdf, like the working ones.
and still crash+guru with these weird .pdfs 3 and 4, no matter where pdf deficon is located.
Attached Thumbnails
Click image for larger version

Name:	pdf_position.PNG
Views:	16
Size:	89.9 KB
ID:	64289   Click image for larger version

Name:	pdf_iconchange.PNG
Views:	14
Size:	86.1 KB
ID:	64290  

Last edited by honx; 30 August 2019 at 20:27.
honx is offline  
Old 30 August 2019, 20:34   #25
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by honx View Post
in deficons pdf is set within ascii tree. see screenshot 1
if i drag pdf out of that tree, working pdf files don't have an icon anymore. see screenshot 2.
the weird ones keep their text file icon although their fileending is .pdf, like the working ones.
and still crash+guru with these weird .pdfs 3 and 4, no matter where pdf deficon is located.

Don't use the editor because I don't think it works well, manually edit the def_icons.

The icons that maintain the association have a "real" icon so the association does not work on these icons.
To verify the exact association delete the icons and then tell the system to associate those files "show all files".

I repeat if you send me some example files I can understand the problem well
AMIGASYSTEM is offline  
Old 30 August 2019, 20:42   #26
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,287
Quote:
Originally Posted by AMIGASYSTEM View Post
If he wants you to open it with EdiPAD, there are two reasons:
- Existing tools icon badly associated
- Wrong file name
what icon exactly is badly associated? and why does it work with some .pdf and not with other .pdf? if there was anything wrong, then no .pdf file would open correctly. none at all...
and all file names end with .pdf, so no wrong filename. all the same filenames except number.
AmigaFever1.pdf - working
AmigaFever2.pdf - working
AmigaFever3.pdf - NOT working (the one i zoned)
AmigaFever4.pdf - NOT working

Quote:
Originally Posted by AMIGASYSTEM View Post
If you send me the files I can be more precise
which files should i send? all these 4 .pdf files (2 working, 2 not working)?

Quote:
Originally Posted by AMIGASYSTEM View Post
- codesets.library is also found in MUI/Libs deletes the older one
no codesets.library in mui/libs on my system. there are only:
muimaster.library, muipop.library, muipropg.library, muirexx.library, muiscreen.library, muispecial.library, muiwinborder.class, muiwinscroller.class
that's it.
Quote:
Originally Posted by AMIGASYSTEM View Post
- polybios.hwp and polibios.exp are also used by other applications, check that there are no older versions in LIBS/Hollywood
there were also no polibios files in libs/hollywood.

Quote:
Originally Posted by AMIGASYSTEM View Post
polybios.hwp and polibios.exp are supplied in two versions FPU noFPU, install the one related to the executable
i copied the ones from the rnopdf version i use to libs/hollywood and rebooted. but still crash.

Quote:
Originally Posted by AMIGASYSTEM View Post
Don't use the editor because I don't think it works well, manually edit the def_icons.
i don't know how to do that manually without that prefs program.

Quote:
Originally Posted by AMIGASYSTEM View Post
The icons that maintain the association have a "real" icon so the association does not work on these icons.
To verify the exact association delete the icons and then tell the system to associate those files "show all files".
as i said on last page on this thread: these .pdf files DON'T have any icon. there are only .pdf files, there are NO .info files.
so these .pdf files are only visible, if "show all files" is checked. otherwise this folder would be blank, as there is no .info file.

Quote:
Originally Posted by AMIGASYSTEM View Post
I repeat if you send me some example files I can understand the problem well
more examples of that .pdf which i already zoned? should i send all 4 amigafever .pdf files (2 working, 2 not working)?
honx is offline  
Old 30 August 2019, 20:59   #27
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by honx View Post
what icon exactly is badly associated? and why does it work with some .pdf and not with other .pdf? if there was anything wrong, then no .pdf file would open correctly. none at all...
and all file names end with .pdf, so no wrong filename. all the same filenames except number.
AmigaFever1.pdf - working
AmigaFever2.pdf - working
AmigaFever3.pdf - NOT working (the one i zoned)
AmigaFever4.pdf - NOT working
AmigaOS is not a Windows PC, AmigaOS does not recognize files from its extension, if you delete AmigaOS extension will still recognize the fie, amiga recognizes files "from internal Codes".

Example, if an image.JPG rename the image.MP3 the Workbench will open the file with the Viewer associated with JPG, Windows instead will open this file with an MP3 player, this was a simple technique on PCs to slice them

Amiga Associations Files, see this very old video of mine:

[ Show youtube player ]


Quote:
which files should i send? all these 4 .pdf files (2 working, 2 not working)?
Yes, I have Amiga Forever but I don't like to install it, I hate setup on PC, I only use portable or stand-alone programs

Quote:
no codesets.library in mui/libs on my system. there are only:
muimaster.library, muipop.library, muipropg.library, muirexx.library, muiscreen.library, muispecial.library, muiwinborder.class, muiwinscroller.class
that's it.

You have an old or incomplete MUI installation, see screenshot

Last edited by AMIGASYSTEM; 31 August 2019 at 10:23.
AMIGASYSTEM is offline  
Old 30 August 2019, 21:13   #28
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,287
Quote:
Originally Posted by AMIGASYSTEM View Post
Yes, I have Amiga Forever but I don't like to install it, I hate setup on PC, I only use portable or stand-alone programs
these .pdf files are not from amiga forever they are called "AmigaFever", this was a german amiga magazine back in the good old 90s.

Quote:
Originally Posted by AMIGASYSTEM View Post
You have an old or incomplete MUI installation, see screenshot
i have official mui 3.8, all "newer versions (3.9)" are not official, not from the same developer, and i have read that 3.9 is very buggy and very performance consuming, this is why i have installed the latest stable release 3.8 of mui. and mui is only for displaying/rendering windows with some special features from mui on workbench. mui has nothing to do with opening .pdf files.

Last edited by honx; 30 August 2019 at 21:22.
honx is offline  
Old 30 August 2019, 21:30   #29
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Okay, I'm waiting for your file...

Official status is not an indicator of quality or absence of bugs, i use MUI 5 and I'm happy also because the new applications acquire modernity, beauty and functionality
AMIGASYSTEM is offline  
Old 30 August 2019, 21:36   #30
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,287
that .pdf file which i zoned is already one of these 4 files, AmigaFever3.pdf which is not working here. i just renamed it. should i upload all 4 AmigaFever .pdf files (AmigaFever1-4, 2 working and 2 not working ones)? this makes ~100mb...
honx is offline  
Old 31 August 2019, 05:27   #31
tero
Registered User

tero's Avatar
 
Join Date: Jan 2009
Location: M'Gladbach
Age: 42
Posts: 547
Quote:
Originally Posted by honx View Post
i don't know how to do that manually without that prefs program.
You can't. The prefs program is to set up how to detect the fileformat. Those informations aren't available to .info files.

I may be able to help with the ascii problem at least. just download the attachment and
put the deficons.prefs into prefs/env-archive.
The default file had more than one file wrongly recognized so i edited it to fix those. It recognizes all files os4 can (there are some formats more than in 3.x) , and i added a fileformat or two.

There shouldn't be any problems but make a backup of your original file first. just to be on the safe side.

Quote:
Originally Posted by AMIGASYSTEM View Post
The icons that maintain the association have a "real" icon so the association does not work on these icons.
To verify the exact association delete the icons and then tell the system to associate those files "show all files".
That is not how it works. You just set a default tool and it'll only works if you save an .info file. That has to be done for every single file you want to open, that's not very convinient.

The 'real' icons are only used when the fileformat is found by deficons.
In the icon file you can only set what programm to use. But if the file is wrongly recognized in the first place the default tool is meaningless. If deficon sees an ascii file the def_pdf will never be used.
I can tell how the deficons prefs works but this is not the thread for that

EDIT: I get an error too on reading your pdf. (guru 8000 0027)
Attached Files
File Type: lha deficons.prefs.lha (2.7 KB, 9 views)

Last edited by tero; 31 August 2019 at 06:14.
tero is offline  
Old 31 August 2019, 08:26   #32
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by tero View Post

EDIT: I get an error too on reading your pdf. (guru 8000 0027)
Try the cure I reported above

I did not understand correctly what you wrote your "deficons.prefs" works well and I have no block.
AMIGASYSTEM is offline  
Old 31 August 2019, 08:38   #33
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by honx View Post
that .pdf file which i zoned is already one of these 4 files, AmigaFever3.pdf which is not working here. i just renamed it. should i upload all 4 AmigaFever .pdf files (AmigaFever1-4, 2 working and 2 not working ones)? this makes ~100mb...
Attach them all including the icons if present so I can understand with certainty the problem
Quote:
i don't know h.ow to do that manually without that prefs program
Easier than you think, you will find all the "Def" icons designated by the system in this path:

DH0:Prefs/Env-Archive/Sys/

Check that the def_pdf.info icon is of the project type, and as a tool it is "RNOPDF" and path
AMIGASYSTEM is offline  
Old 31 August 2019, 09:11   #34
tero
Registered User

tero's Avatar
 
Join Date: Jan 2009
Location: M'Gladbach
Age: 42
Posts: 547
Quote:
Originally Posted by AMIGASYSTEM View Post
I did not understand correctly what you wrote your "deficons.prefs" works well and I have no block.
The Guru has nothing to do with deficons that's a different cause. i assume it's a bug in the hollywood library or a wrong datatype or library or something.
The whole deficons part in this thread is only because the pdf is shown as ascii.

just to explain:
Setting the def_icon to project and set a tool also has nothing to do with deficons. Those are 2 different things. (the problem with the pdf is problem on its own and has nothing to do with the icon.)

Project + tool is to set a programm to use for a file. It is saved in a files .info. you can't even configure those in deficons. (But it offers a way to open iconinformation to make things easier.)

Deficons is only used when no .info for a file exists. And only to deliver a default icon.
To have a good setup in your workbench both (deficons + the def_ files) have to be configured correctly and separatly)

Last edited by tero; 31 August 2019 at 09:18.
tero is offline  
Old 31 August 2019, 09:19   #35
Mr-Z
Registered User

 
Join Date: Sep 2016
Location: Netherlands
Posts: 59
Quote:
Originally Posted by AMIGASYSTEM View Post
AmigaOS is not a Windows PC, AmigaOS does not recognize files from its extension, if you delete AmigaOS extension will still recognize the fie, amiga recognizes files "from internal Codes".

Not completely true, in AmigaOS 3.9 you can do both, you can let Deficons only look at extension and/or also the file headers.
Mr-Z is offline  
Old 31 August 2019, 09:27   #36
tero
Registered User

tero's Avatar
 
Join Date: Jan 2009
Location: M'Gladbach
Age: 42
Posts: 547
True, not only can deficons do that iirc it really does for some files.
btw those 'internal codes' is deficons.
tero is offline  
Old 31 August 2019, 09:28   #37
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by tero View Post
The Guru has nothing to do with deficons that's a different cause. i assume it's a bug in the hollywood library or a wrong datatype or library or something.
The whole deficons part in this thread is only because the pdf is shown as ascii.
Who has spoke of Def Icon as a cure, read well the cure that I indicated to honx


Quote:
just to explain:
Setting the def_icon to project and set a tool also has nothing to do with deficons. Those are 2 different things. (the problem with the pdf is problem on its own and has nothing to do with the icon.)

Project + tool is to set a programm to use for a file. It is saved in a files .info. you can't even configure those in deficons. (But it offers a way to open iconinformation to make things easier.)

Deficons is only used when no .info for a file exists. And only to deliver a default icon.
To have a good setup in your workbench both (deficons + the def_ files) have to be configured correctly and separatly)
Whoever has ever said the contrary, you have encountered the problem Guru, I on all my systems I have no GURU with PDF or other extensions, you can see here many of my associations files on both Workbench and Dopus4


https://drive.google.com/file/d/1LHn...Bwy_h-gAd/view
AMIGASYSTEM is offline  
Old 31 August 2019, 09:31   #38
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by Mr-Z View Post
Not completely true, in AmigaOS 3.9 you can do both, you can let Deficons only look at extension and/or also the file headers.
This only happens if there is a real icon or if a file has an extension, a file without an icon and without an extension will be examined internally, see also Dopus4
AMIGASYSTEM is offline  
Old 31 August 2019, 09:32   #39
honx
Registered User

honx's Avatar
 
Join Date: Oct 2014
Location: Klagenfurt / Austria
Posts: 1,287
Quote:
Originally Posted by tero View Post
I may be able to help with the ascii problem at least. just download the attachment and
put the deficons.prefs into prefs/env-archive.
The default file had more than one file wrongly recognized so i edited it to fix those. It recognizes all files os4 can (there are some formats more than in 3.x) , and i added a fileformat or two.

There shouldn't be any problems but make a backup of your original file first. just to be on the safe side.
thx, this at least solved the problem with pdf wrong recognized.

but there are some entries in your deficons.prefs i can't doubleclick to change. for example: tif, if i doubleclick it to assign it to multiview or any other picture viewer, i get an error:
Quote:
DefIcons.Prefs
tif: object not found
Okay
and on right side it says "Makroklasse". there are more entries which do this: utahrle, wbmp, xbm, yuvn, etc. (i don't know these ).
but no worry, .tif never worked on my system. now with your deficons.prefs at least it has an icon (tiff) which it didn't have before.
i guess, it will take some weeks checking if everything still works as it used to (opens how it's supposed to be opened), i'll have to check wordworth, turbocalc, amigawriter, etc. - not gonna do this today...

Quote:
Originally Posted by tero View Post
EDIT: I get an error too on reading your pdf. (guru 8000 0027)
at least i'm not alone with this!

Last edited by honx; 31 August 2019 at 09:40.
honx is offline  
Old 31 August 2019, 09:44   #40
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,130
Quote:
Originally Posted by honx View Post
but there are some entries in your deficons.prefs i can't doubleclick to change. for example: tif, if i doubleclick it to assign it to multiview or any other picture viewer, i get an error:
Edit the def_tiff file by hand, done this you'll also have it modified in DefIcons.Prefs
AMIGASYSTEM is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Polybios PDF plugin for Hollywood released softwarefailure News 1 24 June 2019 09:31
PDF versions? Akira AMR contributions 0 12 May 2015 21:10
Pagestream 4 PDF? chocolate_boy support.Apps 7 12 March 2014 01:28
Amiga Future Magazine Archive Released on DVD (PDF format) AndreasM News 0 11 August 2009 02:11
PDF reader mtb support.Apps 4 19 September 2002 22:17

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:22.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.08642 seconds with 14 queries