English Amiga Board


Go Back   English Amiga Board > Off Topic > OT - General

 
 
Thread Tools
Old 19 January 2018, 01:38   #1
Nosferax
Registered User

 
Join Date: Apr 2015
Location: Beauharnois,Qc,Canada
Posts: 178
My amiga rant...

I'm really unlucky when it comes to my Amiga experience...

Let me explain why I need to vent a bit.

I had an A1000 and was a bit limited memory and expansion wise so I decided to get rid of it so I could afford my dream machine an A2000. And I did find one that seemed to be in beautiful condition, well at least on photo.... I even planned to take a post Christmas vacation since I've cumulated a week worth of time in my "time bank" at work to play with it.

When the machine got to me it was in less than stellar conditions. Crooked back pannel, missing or not matching screws and with the leaking battery still there. I had words with the seller about these defects... Ok the acid damage didn't seem too bad so I cleaned it up. I put back the machine toghetter and boot it up. Ok so far so good, but it was a KS 1.3 machine and I've already passed an order for an IDE->CF zorro interface which need at least 2.4 but work better on 3.1. Also, at that moment I realized that when I shipped my A1000 I've sent my new Amiga mouse with it instead of the original A1000 mouse with its angled plug which doesn't fit with the A2000.

So, I search a bit and found a guy on AtariAge that had both a mouse and the 3.1 KS rom. It finaly got here, so I went and opened the A2000, removed the drives and PSU tray, removed the rom and plug in the new one. Created a CF HDD on WinUAE and installed the card in the first Zorro slot. So far so good!
So back went the drives and PSU. Now to plug the floppy cable back then I'll finally enjoy my new baby... Oh wait... I don't remember the floppy connector missing a pin?!?

Yep, when removing the floppy cable, carefully I might add, one of its pin came with the cable. In all my years of upgrading computers I've never even bent a single connector pin let alone pull one out! So, now I need to replace that pin somehow and find a new floppy cable since the pin is stuck in it and I got no way to pull it out without breaking connector (I really tried, believe me) since its to far inside to use even my most pointed needle nose pliers.

Now, I do own another Amiga, a 500 PAL model. And here's where my curse continue... I'm Canadian, the machine came with an european PSU. I bought it as a spare so I wasn't in a hurry to get a PSU for it. So I've just ordered a Ray Carlsen PSU because even though I have all the parts to hook up an ATX PSU to it, I just don't want to jinx it... It'll probably take a week or more to get here. Funny thing I've found out recently is that US postage to Canada takes about twice the time that it take to ship the other way. I've finaly found a postal service worst than Canada Post!

So, next time I wan't to take time off to play with my toys, I'll make sure that they're working first else it's bloody demoralizing...

But I feel better now that I've written this...
Nosferax is offline  
AdSense AdSense  
Old 19 January 2018, 10:06   #2
jmmijo
Junior Member
jmmijo's Avatar
 
Join Date: Jan 2002
Location: PDX
Age: 55
Posts: 2,356
Man here's to wishing you some better luck
jmmijo is offline  
Old 19 January 2018, 15:18   #3
Anubis
Maj. Voodoo

Anubis's Avatar
 
Join Date: Jan 2005
Location: #Confefe
Age: 45
Posts: 2,291
All that trouble because you didn't get Raspberry Pi with RetroPie? Well deserved!
On serious note, don't play lotto.
Anubis is offline  
Old 19 January 2018, 22:10   #4
gimbal
cheeky scoundrel
gimbal's Avatar
 
Join Date: Nov 2004
Location: Spijkenisse/Netherlands
Age: 36
Posts: 2,955
What a horror story. Attributing it to the Amiga is not fair though, that was only what you were in the market for when you ran into the nightmares of shipping and third party reselling.
gimbal is offline  
Old 19 January 2018, 23:38   #5
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 41
Posts: 10,297
You can see mine in various threads over the past hour or so
DamienD is online now  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hardware Rant! BinoX support.Hardware 11 10 June 2007 18:15
Barry Walkers Amiga Rant Zola Amiga scene 51 22 May 2007 14:52
My Amiga Rant !!! synchro Amiga scene 25 22 November 2004 23:17
WinUAE Rant #1 Exodus Amiga scene 68 16 September 2004 00:51
Rant page Twistin'Ghost Retrogaming General Discussion 15 09 August 2002 08:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:38.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.13516 seconds with 14 queries