English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 11 January 2020, 02:48   #1
lost_lemming
Registered User
lost_lemming's Avatar
 
Join Date: Aug 2009
Location: Birmingham
Age: 34
Posts: 379
Can't boot into HDD workbench now! (ENV?)

I get a system request message saying "Please insert volume ENV in any drive"
Retry just asks the question again and Cancel just takes me into AmigaDOS saying "can't open file"

I can load workbench from floppy and everything is still there. but I don't want to have to have a floppy in the whole time, plus it some how took away my toosdeamon menu's so I can't have that!

for a bit of a backstory this is actually a newly installed harddrive (from a foreveramiga 6 disk set)... I accidentally formatted my entire HDD this week which was devastating.
Anyway as soon as I had all the workbench disks installed (you know, the extras, storage, fonts etc) I began just installing all my fave apps on there... mostly music stuff.
I think the last thing I put on was EasyADF. some programs I installed by hand so I was moving files (sort of half guessing) from its S's and C's and DEVs to the S's C's DEV's on the system which I remember I had to do to actually get programs to fire up. maybe I did somthing silly there. I know I replaced a "startup" file but I thought that would be ok. I don't really know what I'm doing half the time.

What is this ENV thing though? I even renamed a floppy disk to ENV to just try and trick it as revenge but it then said it couldn't find a file or something so that didn't work.
lost_lemming is offline  
Old 11 January 2020, 10:47   #2
thomas
Registered User
thomas's Avatar
 
Join Date: Jan 2002
Location: Germany
Posts: 5,924
ENV is a virtual drive which holds environment variables and various temporary settings. It is normally assigned to a directory in Ram Disk early in the boot process.

There are two statup scripts in the S directory which are essential for starting the Amiga:
startup-sequence
user-startup

Startup-sequence is a system file, it should not be touched by average users. Editing it is for experienced users only. You should replace it only if you really know what you are doing.

User-startup, as the name suggests, is for user additions. Entries there are usually added automatically by the installation of apps. But you can add your own entries there, too, if you know what you do.

If user-startup failed, the symptoms would be different, so it's probably startup-sequence you replaced. I think the original one is on the Workbench disk, so boot with the Workbench floppy (not the Install floppy) and copy S/Startup-Sequence from the floppy to your hdd.
thomas is offline  
Old 11 January 2020, 11:03   #3
malko
Ex nihilo nihil

malko's Avatar
 
Join Date: Oct 2017
Location: CH
Posts: 2,608
Make sure you haven't renamed the ' Prefs ' folder.
malko is online now  
Old 11 January 2020, 11:16   #4
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,384
I don't think he has the startup-sequence assignment.

Assign >NIL: ENV: RAM:ENV
AMIGASYSTEM is offline  
Old 11 January 2020, 19:14   #5
lost_lemming
Registered User
lost_lemming's Avatar
 
Join Date: Aug 2009
Location: Birmingham
Age: 34
Posts: 379
you legends! thanks a lot guys, back to normal now!
lost_lemming is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Amiga 3000 hdd boot problems Borgy support.Hardware 19 20 October 2017 22:30
When workbench starts with fs-uae i cannot found (asks two times) ENV why? JPQ support.FS-UAE 16 07 March 2014 10:13
Getting WinUAE to boot from HDD with Kickstart 1.2 8bitbubsy support.WinUAE 12 17 April 2013 19:19
A1200 HDD Boot Issue! PowerPie5000 support.Hardware 11 10 March 2010 00:39
No boot from HDD with blizzard 1230 Voz79 support.Hardware 27 06 January 2010 18:34

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06743 seconds with 13 queries