English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 03 February 2020, 13:24   #81
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by Viceroy View Post
Is it still possible to download this? I thought I already had it!
After the behavior of some Vampire users Here I've decided to suspend distribution.
AMIGASYSTEM is offline  
Old 03 February 2020, 14:13   #82
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 613
:-(
Viceroy is offline  
Old 03 February 2020, 14:26   #83
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 733
What behaviour in particular? A valid point was made: you only _claim_ that your stuff could run on real Amigas (and at the same time you claim it doesn't run on the Vampire). All we have as a proof is that you are running this in WinUAE which can circumvent a lot of hardware problems. You have done no tests with real hardware.
grond is offline  
Old 03 February 2020, 15:00   #84
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
AROS 68k will start from a Real Amiga if you use AROS 68k ROMs, if you do it with WinUAE you must do it with Real Amiga too.

About the Vampire AROS 68k Standard cannot start because you need to edit startup-sequence add Drive et..
Try booting from a Real Amiga This "nightly" AROS 68k for Vampire

I have not tested the real hardware but I trust what the developers write, on the review you Nightly Build you can say it here and reported:

The native version for m68k Amigas, or WinUAE. This version is binary compatible with AmigaOS. The archive contains a bootable floppy image which will kick the AROS rom

Last edited by AMIGASYSTEM; 03 February 2020 at 15:09.
AMIGASYSTEM is offline  
Old 03 February 2020, 16:45   #85
grond
Registered User

 
Join Date: Jun 2015
Location: Germany
Posts: 733
Despite of what may be claimed about AROS, it does _not_ boot on A600 or A4000 (or was it the A1200?) because of timing-related IDE-incompatibilities while there are no such problems when using WinUAE. This is precisely what I am talking about. You _assume_ that WinUAE really is accurate enough to make the conclusion that, if it runs on WinUAE, it will run on real hardware. But it is not.
grond is offline  
Old 03 February 2020, 17:29   #86
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
I don't know if there is an IDE problem, certainly an Italian user wrote my Hardfile on a CF and booted on a real Amiga, getting the error message "stdc.library" not found.

This I think shows that there are no problems on IDE, on WinUAE I simulated the same error emulating an A4000, then solved it by mapping the ROM of AROS


AROS One 68k on A4000/040 JIT (error simulated)

Last edited by AMIGASYSTEM; 03 February 2020 at 17:44.
AMIGASYSTEM is offline  
Old 03 February 2020, 17:59   #87
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by grond View Post
A valid point was made: you only _claim_ that your stuff could run on real Amigas
i have not had that impression, but i havent red the posts on the subject on apollo forum in particular, so others may have won a different one.

to me it was rather clear that the distribution in question is meant for emulation, at least for the time being.
wawa is offline  
Old 03 February 2020, 18:04   #88
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by AMIGASYSTEM View Post
I have not tested the real hardware but I trust what the developers write:
The native version for m68k Amigas, or WinUAE. This version is binary compatible with AmigaOS. The archive contains a bootable floppy image which will kick the AROS rom
its one thing that it can boot on a genuine amiga, but another if it works satisfactory there. advertising it as working out of the box under such circumstances, without having tested it in reality isnt a good move. i appreciate your work in putting that stuff together and making it look good, but ensuring that it works on an amiga is a whole different matter, which i have been concerned with for quite a while, and demands a different kind of work.
wawa is offline  
Old 03 February 2020, 18:09   #89
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by grond View Post
Despite of what may be claimed about AROS, it does _not_ boot on A600 or A4000 (or was it the A1200?)
actually if my latest tests are still valid aros boots (bootstraps and maps itself upon the genuine amiga roms) on all these amigas (at least to early startup and further with no s-s, as long as they are equipped with at least 2mb of ram).
the problem appears when the machines are equipped with a vamp accel.

currently the test machine, you lent me arrived at michals and we may expect some results soon, i hope. in the meantime ill try to review the situation on other a4000 and a1200 configs.
wawa is offline  
Old 03 February 2020, 18:17   #90
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by AMIGASYSTEM View Post
I don't know if there is an IDE problem, certainly an Italian user wrote my Hardfile on a CF and booted on a real Amiga, getting the error message "stdc.library" not found.
that exactly shows that aros has _not_ booted (bootstrapped). it shows that aros attempted to be run upon genuine amiga roms, which it cant, obviously. pretty cetrainly arosbootstrap line has not been added to the startup-sequence.
Quote:
This I think shows that there are no problems on IDE, on WinUAE I simulated the same error emulating an A4000, then solved it by mapping the ROM of AROS


AROS One 68k on A4000/040 JIT (error simulated)
no. you cannot emulate exactly many of these issues, especially not the vampire, since such an exact setup is unavailable for winuae. but it also demands some expertise to be able to setup winuae such a way that certain real hardware can be actually replicated, such as particular version of ide. i have been working with toni on such issues. thats exactly, what grond is talking about.
wawa is offline  
Old 03 February 2020, 18:24   #91
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by wawa View Post
its one thing that it can boot on a genuine amiga, but another if it works satisfactory there. advertising it as working out of the box under such circumstances.
Being compatible does not mean it works well, surely on a genuine Amiga it will go very slow, I have never advertised the use of a genuine Amiga I just said that it can start., then maybe in the future it can do so thanks to some new accelerator card
AMIGASYSTEM is offline  
Old 03 February 2020, 18:27   #92
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
@AMIGASYSTEM

fyi: if it isnt present, you need to add something like that at the beginning of your s-s to boot aros on an amiga:
Code:
  boot/amiga/AROSBootstrap ROM boot/amiga/aros.hunk.gz
we actually are even using the block below in attempt to support ACA accelerators as well:

Code:
IF EXISTS c/acatune 
  If NOT EXISTS boot/amiga/aros-1mb.bin 
    JOIN boot/amiga/aros-ext.bin boot/amiga/aros-rom.bin AS boot/amiga/aros-1mb.bin 
  Endif 
  c/acatune maprom boot/amiga/aros-1mb.bin maxmem >NIL: 
ELSE 
  boot/amiga/AROSBootstrap ROM boot/amiga/aros.hunk.gz 
ENDIF
wawa is offline  
Old 03 February 2020, 18:28   #93
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by wawa View Post

no. you cannot emulate exactly many of these issues, especially not the vampire, since such an exact setup is unavailable for winuae..
Yes it's true but I don't care that it works well on Vampire, my AROS One 68k I created it mainly for WinUAE users, same thing for my AfA One, OS in my opinion suitable only for emulation.
AMIGASYSTEM is offline  
Old 03 February 2020, 18:28   #94
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by AMIGASYSTEM View Post
Being compatible does not mean it works well, surely on a genuine Amiga it will go very slow, I have never advertised the use of a genuine Amiga I just said that it can start., then maybe in the future it can do so thanks to some new accelerator card
i think the whole flack is unnecessary. the situation just need to be clarified and all is fine.
wawa is offline  
Old 03 February 2020, 18:33   #95
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by wawa View Post
boot/amiga/AROSBootstrap ROM boot/amiga/aros.hunk.gz
c/acatune maprom boot/amiga/aros-1mb.bin maxmem >NIL:

Yeah, I noticed in these distro, but are they official? I've noticed old files and old library!

Last edited by AMIGASYSTEM; 03 February 2020 at 18:40.
AMIGASYSTEM is offline  
Old 03 February 2020, 19:56   #96
wawa
Registered User
 
Join Date: Aug 2007
Location: berlin/germany
Posts: 1,054
Quote:
Originally Posted by AMIGASYSTEM View Post
Yeah, I noticed in these distro, but are they official? I've noticed old files and old library!
its structured pretty straightforwardly. simply navigate up and then to the most recent build, which is currently:
https://dl.amigadev.com/nightly/aros/2020/02/03/

as you see the directories layout reflects the date of the build.
wawa is offline  
Old 03 February 2020, 20:14   #97
Solskogen
Registered User
 
Join Date: Nov 2016
Location: Skien / Norway
Posts: 38
Please continue with your distribution @AMIGASYSTEM.
Despite a few bugs, it runs very well on Amiberry on the Pi4!
Solskogen is offline  
Old 03 February 2020, 20:45   #98
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by wawa View Post
its structured pretty straightforwardly. simply navigate up and then to the most recent build, which is currently:
https://dl.amigadev.com/nightly/aros/2020/02/03/

as you see the directories layout reflects the date of the build.
Yes I know, it's the vampire version that's not always up to date.
AMIGASYSTEM is offline  
Old 03 February 2020, 20:48   #99
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,403
Quote:
Originally Posted by Solskogen View Post
Please continue with your distribution @AMIGASYSTEM.
Despite a few bugs, it runs very well on Amiberry on the Pi4!
Given the many requests from good users soon AROS One 68k will be available again !
AMIGASYSTEM is offline  
Old 03 February 2020, 21:11   #100
Viceroy
Registered User
 
Join Date: Jul 2006
Location: Sunderland
Posts: 613
Thank you!
Viceroy is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Integrated 68K in AROS bloodline Coders. Nextgen 16 28 February 2019 16:22
WinUAE And AROS 68k AMIGASYSTEM support.WinUAE 0 29 July 2017 11:56
AROS 68k Emulation AMIGASYSTEM support.WinUAE 4 24 December 2016 11:08
New Video of my Aros 68k distribution "Aros Vision" OlafSch Amiga scene 26 16 February 2016 11:16
News about AROS 68k development? Leandro Jardim Coders. C/C++ 80 29 November 2014 18:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:13.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09001 seconds with 14 queries