English Amiga Board


Go Back   English Amiga Board > News

 
 
Thread Tools
Old 15 February 2020, 01:08   #401
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 42
Posts: 5,644
Send a message via ICQ to Predseda
So... in my case it is the same with Hippoplayer. Once the playing of the module is finished, it starts from the beginning again.

Additionally, it gives me a message:

_execute_command(), could not find any of the Arexx ports.
Predseda is offline  
Old 15 February 2020, 09:37   #402
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,381
Strange I don't have these problems, check the Arexx HippoPlayer port installation (HIP copy in C: and scripts in S: and Arexx: Directory)

Here's how it works AmiModRadio on my system:

https://drive.google.com/open?id=1GH...0sG5zO4DhQZety
AMIGASYSTEM is offline  
Old 18 February 2020, 05:42   #403
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 672
Hi Predseda and AmigaSystem!

Quote:
Originally Posted by Predseda View Post
So... in my case it is the same with Hippoplayer. Once the playing of the module is finished, it starts from the beginning again.

Additionally, it gives me a message:

_execute_command(), could not find any of the Arexx ports.
Sorry to read about your problem, Predseda, and thanks for helping, AmigaSystem

I never had this problem myself either; I would think that it could come from HiP: HiP should not start playing the same module after it ends, HiP should just stop (and nothing should be played if AmiModRadio cannot find HiP AREXX port).

Predseda, could you try resetting your HiP preferences please?

Let us know!
Cheers!
tygre is offline  
Old 18 February 2020, 08:39   #404
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 42
Posts: 5,644
Send a message via ICQ to Predseda
In fact I am a bit lost in Arexx and these things to I would welcome step by step instructions. For example your last advice: "Eagleplayer must be in the path (or running)" helped me, but took me a very long time to discover, that it means I need to have a line in user-startup saying "path: dh0:.../EaglePlayer"

I must find where Hippo preferences are stored.

(Now I messed it somehow - probably path / Arexx - and AmiModRadio doesnt start neither Eangle nor Hippo for me, saying something like "There is really nothing to play". I must start a player manually before AMR.)
Predseda is offline  
Old 18 February 2020, 09:27   #405
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,381
Copy the HippoPlayer data into these paths:

HiP -> SYS:C

HippoPlayer.group - > SYS:S
HippoPlayer.PS3M - > SYS:S
HippoPlayer.prefs > SYS:S

HippoPlayer.key - > SYS:L

medplayer.library - > SYS:LIBS
octamixplayer.library - > SYS:LIBS
octaplayer.library- > SYS:LIBS
PlaySID.library - > SYS:LIBS
reqtools.library - > SYS:LIBS
mline.library - > SYS:LIBS

Startup-sequence
Assign >NIL: REXX: SYS:ARexx

Directory ARexx (HippoPlayer data) -> SYS:ARexx

Last edited by AMIGASYSTEM; 19 February 2020 at 00:06.
AMIGASYSTEM is offline  
Old 18 February 2020, 09:32   #406
Predseda
Puttymoon inhabitant
Predseda's Avatar
 
Join Date: Mar 2007
Location: The City of Townsville
Age: 42
Posts: 5,644
Send a message via ICQ to Predseda
Thank you, I will look at it. SYS: = DH0: (my boot partition)?

Last edited by Predseda; 18 February 2020 at 09:38.
Predseda is offline  
Old 18 February 2020, 09:58   #407
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,381
Quote:
Originally Posted by Predseda View Post
Thank you, I will look at it. SYS: = DH0: (my boot partition)?
Yes, it is equal SYS includes any volume name

Copy in C: also LHA, LZX, UnZIP
AMIGASYSTEM is offline  
Old 18 February 2020, 13:31   #408
daxb
Registered User
 
Join Date: Oct 2009
Location: Germany
Posts: 2,469
Quote:
Originally Posted by AMIGASYSTEM View Post
Startup-sequence
Assign >NIL: REXX: SYS:ARexx
This seems to be not a good idea. I would say, don't do this. The REXX assign is usually assigned to SYS:S and the above assign would "destroy" the system assign.
Quote:
Directory ARexx (HippoPlayer data) -> SYS:ARexx
Why?
daxb is offline  
Old 18 February 2020, 18:33   #409
tygre
Returning fan!

tygre's Avatar
 
Join Date: Jan 2011
Location: Montréal, QC, Canada
Posts: 672
Hi Predseda!

Quote:
Originally Posted by Predseda View Post
In fact I am a bit lost in Arexx and these things to I would welcome step by step instructions. For example your last advice: "Eagleplayer must be in the path (or running)" helped me, but took me a very long time to discover, that it means I need to have a line in user-startup saying "path: dh0:.../EaglePlayer"

I must find where Hippo preferences are stored.

(Now I messed it somehow - probably path / Arexx - and AmiModRadio doesnt start neither Eangle nor Hippo for me, saying something like "There is really nothing to play". I must start a player manually before AMR.)
No worries! And I see that AmigaSystem beat me to helping you

You can also start HiP or EaglePlayer by hand yourself. If one of them is running, AmiModRadio should (will?) find their ARexx port...

BTW, have you started SYS:System/RexxMast? (It can also be started manually.) RexxMast is necessary for Amiga programs to use ARexx...

Cheers!

Last edited by tygre; 18 February 2020 at 18:34. Reason: More info.
tygre is offline  
Old 18 February 2020, 18:55   #410
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 5,381
Quote:
Originally Posted by daxb View Post
This seems to be not a good idea. I would say, don't do this. The REXX assign is usually assigned to SYS:S and the above assign would "destroy" the system assign.
Why?
I like to keep the system ordered, i don't like to mix everything into S.

"Assign >NIL: REXX:S" (deleted from Startup-sequence) in its place added "Assign >NIL: REXX: SYS:ARexx" (ever had any problems with Arexx)
AMIGASYSTEM is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which games are using modules? 1988 request.Modules 7 29 July 2016 21:24
A few modules Rogue request.Modules 1 31 May 2014 19:22
two modules s2325 request.Modules 4 01 May 2010 16:23
Brain Killer Aminet links changed (and a question about Aminet links) Korodny HOL data problems 0 26 November 2009 22:21
Modules.. Muerto request.Modules 2 15 December 2005 18:32

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:14.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07934 seconds with 14 queries