English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 23 December 2017, 18:20   #1
dylanmc
 
Posts: n/a
FS-UAE Launcher Linux Gentoo problem

Hi to all, I've installed from source fs-uae 2.8.3 on my Linux Genoot box but the gui frontend doesen't work, but the emulator does.

Code:
uca@snoopx ~/Scaricati/fs-uae-launcher-2.9.7dev2 $ ./fs-uae-launcher 
[LOGGING] Logging to /home/luca/FS-UAE/Cache/Logs/fs-uae-launcher.log.txt
FS-UAE Launcher 2.9.7dev2
['./fs-uae-launcher']
uname_result(system='Linux', node='snoopx', release='4.13.13-gentoo', version='#5 SMP Sun Dec 10 18:56:15 CET 2017', machine='x86_64', processor='AMD Ryzen 5 1600X Six-Core Processor')

Unhandled exception detected in thread MainThread:
  ImportError:qt.py:<module>:12

Traceback (most recent call last):
  File "./fs-uae-launcher", line 84, in <module>
    main()
  File "./fs-uae-launcher", line 81, in main
    launcher.apps.main()
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/apps/__init__.py", line 127, in main
    app_main()
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/apps/fs_uae_launcher.py", line 22, in app_main
    from launcher.launcherapp import LauncherApp
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/launcherapp.py", line 9, in <module>
    import fsui
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/__init__.py", line 5, in <module>
    from fsui.qt import *
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/qt/__init__.py", line 5, in <module>
    from fsui.qt.qt import init_qt, QDesktopWidget, QEvent, QObject, \
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/qt/qt.py", line 12, in <module>
    from PyQt5.QtCore import *
ImportError: No module named 'PyQt5'


Unhandled exception detected in thread MainThread:
  ImportError:qt.py:<module>:12

Traceback (most recent call last):
  File "./fs-uae-launcher", line 84, in <module>
    main()
  File "./fs-uae-launcher", line 81, in main
    launcher.apps.main()
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/apps/__init__.py", line 127, in main
    app_main()
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/apps/fs_uae_launcher.py", line 22, in app_main
    from launcher.launcherapp import LauncherApp
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/launcher/launcherapp.py", line 9, in <module>
    import fsui
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/__init__.py", line 5, in <module>
    from fsui.qt import *
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/qt/__init__.py", line 5, in <module>
    from fsui.qt.qt import init_qt, QDesktopWidget, QEvent, QObject, \
  File "/media/samsung/Scaricati/fs-uae-launcher-2.9.7dev2/fsui/qt/qt.py", line 12, in <module>
    from PyQt5.QtCore import *
ImportError: No module named 'PyQt5'
This is the developement version, but the stable give me the same error.
 
Old 23 December 2017, 18:58   #2
thevoice
Registered User
 
Join Date: Oct 2006
Location: germany
Posts: 104
out of the blue i would guess you have no pyqt5-dev installed.
thevoice is offline  
Old 23 December 2017, 19:11   #3
dylanmc
 
Posts: n/a
In my distro there isn't a dev package, I have to compile every item I add to my system.

The 2.6.3 release work, this doesent
 
Old 23 December 2017, 19:16   #4
nobody
Registered User

nobody's Avatar
 
Join Date: Dec 2013
Location: GR
Age: 41
Posts: 1,168
First of all this is not 2.8.3 but fs-uae-launcher 2.9.7dev2
nobody is offline  
Old 23 December 2017, 20:06   #5
dylanmc
 
Posts: n/a
I got the same error with 2.8.3 ..
 
Old 23 December 2017, 20:10   #6
nobody
Registered User

nobody's Avatar
 
Join Date: Dec 2013
Location: GR
Age: 41
Posts: 1,168
Dependencies

https://packages.debian.org/stretch/fs-uae-launcher


an older version doesn't have the same dependencies

https://packages.debian.org/wheezy-b...s-uae-launcher
nobody is offline  
Old 24 December 2017, 01:23   #7
dylanmc
 
Posts: n/a
I've gentoo.. no dependencies "-dev"
 
Old 24 December 2017, 02:22   #8
emufan
Registered User
 
Join Date: Feb 2012
Location: #DrainTheSwamp
Posts: 4,546
did you try to install PyQT5?
http://pyqt.sourceforge.net/Docs/PyQ...tallation.html
--> pip3 install pyqt5

https://packages.gentoo.org/packages/dev-python/PyQt5
not sure about the package management of gentoo, but one way or the other it should install.
emufan is offline  
Old 24 December 2017, 08:03   #9
nobody
Registered User

nobody's Avatar
 
Join Date: Dec 2013
Location: GR
Age: 41
Posts: 1,168
No dependencies? What about
ImportError: No module named 'PyQt5'
nobody is offline  
Old 24 December 2017, 09:39   #10
dylanmc
 
Posts: n/a
Quote:
Originally Posted by emufan View Post
did you try to install PyQT5?
http://pyqt.sourceforge.net/Docs/PyQ...tallation.html
--> pip3 install pyqt5

https://packages.gentoo.org/packages/dev-python/PyQt5
not sure about the package management of gentoo, but one way or the other it should install.
I've installed that module with pip, but I got no luck
I allways get the same error.
 
Old 24 December 2017, 09:41   #11
dylanmc
 
Posts: n/a
Quote:
Originally Posted by nobody View Post
No dependencies? What about
ImportError: No module named 'PyQt5'

In my distro I didn't have that -dev package,
Code:
snoopx luca # emerge -s pyqt5
  
[ Results for search key : pyqt5 ]
Searching...

*  dev-python/PyQt4
      Latest version available: 4.12.1
      Latest version installed: 4.12.1
      Size of files: 11063 KiB
      Homepage:      https://www.riverbankcomputing.com/software/pyqt/intro
      Description:   Python bindings for the Qt framework
      License:       GPL-3

*  dev-python/PyQt5
      Latest version available: 5.7.1
      Latest version installed: 5.7.1
      Size of files: 3647 KiB
      Homepage:      https://www.riverbankcomputing.com/software/pyqt/intro
      Description:   Python bindings for the Qt framework
      License:       GPL-3

*  dev-python/pyqwt
      Latest version available: 5.2.0-r2
      Latest version installed: [ Not Installed ]
      Size of files: 2609 KiB
      Homepage:      http://pyqwt.sourceforge.net/
      Description:   Python bindings for the Qwt library
      License:       GPL-2

[ Applications found : 3 ]
 
Old 25 December 2017, 13:02   #12
gryf
Registered User
 
Join Date: Jan 2013
Location: Poland
Posts: 27
Obviously, you'll need
dev-python/PyQt5
installed using
emerge
command, not pip, since there could be dependencies, which pip doesn't solve. Also, you could just try to find appropriate ebuild for fs-uae-launcher.
gryf is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Issue with fs-uae-launcher on Gentoo Linux philr5150 support.FS-UAE 1 19 September 2017 13:50
fs-uae-launcher and fs-uae-arcade (dev versions) linux problems [Solved] esc support.FS-UAE 2 18 November 2014 01:02
GLX-related compilation problem with FS-UAE on Gentoo / GCC 4.8 yoshi314 support.FS-UAE 9 17 December 2013 19:49
Bug with Launcher under Linux with dev23 - not able to start fs-uae binary laoshi support.FS-UAE 4 02 February 2013 14:50
Problem choosing folders in FS-UAE Launcher on Linux jumb0 support.FS-UAE 2 13 December 2012 01:56

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:29.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.14852 seconds with 15 queries