English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 16 July 2018, 09:27   #2301
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,074
#362 seems to fix the issues I’ve been seeing.

I did some testing on 361 - the problem with lock-ups only seems to affect warp3d stuff. Cyberpi, voxelspace etc all run with no problems but as soon as I try gears or blitzquake there’s a lockup within a few seconds. I’ll try 355 again this evening to see if that was the case with that build too.

My testing is probably not very scientific! I tend to swap the PowerPC library, reboot and then go straight for gears or blitzquake! I need to start being a little more methodical and work from the ground up.

362 appears to work fine. All WOS stuff (cyberpi, voxelspace etc) worked well, and then Blitzquake and gears ran for hours; in fact I left gears running overnight and it was still good in the morning. Will test 362 again this evening, and try Quake3 beta 5 as well.

Last edited by trixster; 16 July 2018 at 09:50.
trixster is offline  
AdSense AdSense  
Old 16 July 2018, 12:50   #2302
Marlon_
Amiga Programmer

Marlon_'s Avatar
 
Join Date: Mar 2016
Location: Sundsvall, Sweden
Age: 29
Posts: 410
Are any of you guys familiar with Slack? Many of us part of the AmigaPorts github organization hang out on a Slack and discuss things regarding GCC etc.

Feel free to join us: https://join.slack.com/t/amigaports/...TU1NWFmNTdiZDU
Marlon_ is offline  
Old 16 July 2018, 15:34   #2303
BULI
Registered User

 
Join Date: Dec 2017
Location: Rzeszów
Posts: 51
Quote:
Originally Posted by Cowcat View Post
Q3beta5 as it is now in my thread.

Great
BULI is offline  
Old 16 July 2018, 20:12   #2304
Wrangler
Registered User

 
Join Date: Sep 2015
Location: London, UK
Posts: 214
Quote:
Originally Posted by nexus View Post
^ [ Show youtube player ]
what settings are you running that at?

Crap ones, I expect, because I haven't optimised at all. Config attached.


750FX still proving very unpredictable - I'm convinced it's hardware not software because it seems to get (a bit) more reliable after it has warmed up for 5 minutes - it won't even init before that. But cooling is good, volts are good (5.02), I've cleaned the PMC and PCI connectors with alcohol. Not sure where else to go next.
Attached Files
File Type: txt q3config.txt (6.6 KB, 9 views)
Wrangler is offline  
Old 17 July 2018, 08:54   #2305
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,074
#362 seems absolutely fine to me on Rapture. Played a load of quake1 and left it runnnig overnight.

Quake3beta5 now loads successfully each time but I get random crashes which I assume are due to the zero page stuff.
trixster is offline  
Old 17 July 2018, 08:59   #2306
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 631
Quote:
Originally Posted by trixster View Post
Quake3beta5 now loads successfully each time but I get random crashes which I assume are due to the zero page stuff.
No proof = didn't happen.
Hedeon is offline  
Old 17 July 2018, 10:08   #2307
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,074
Like I said, I ‘assume’.
trixster is offline  
Old 17 July 2018, 11:22   #2308
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 631
Greg,

Could you make a tutorial for the wiki on how to debug/report stuff? I guess it is needed. Your last one was perfect (attached a few posts back)
Hedeon is offline  
Old 17 July 2018, 11:27   #2309
Marlon_
Amiga Programmer

Marlon_'s Avatar
 
Join Date: Mar 2016
Location: Sundsvall, Sweden
Age: 29
Posts: 410
Quote:
Originally Posted by Hedeon View Post
Greg,

Could you make a tutorial for the wiki on how to debug/report stuff? I guess it is needed. Your last one was perfect (attached a few posts back)


Marlon_ is offline  
Old 17 July 2018, 16:15   #2310
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,074
If my ‘feedback’ is of zero use then sorry for that, I’m not technically minded like you lot. I do not have a lot of time to spend on this hobby anymore, so I just say what I observe. A debug/testing guide would be appreciated!
No trying to p anyone off.

Last edited by trixster; 17 July 2018 at 16:47.
trixster is offline  
Old 17 July 2018, 16:48   #2311
Hedeon
Sonnet Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 631
Quote:
Originally Posted by trixster View Post
If my ‘feedback’ is of zero use then sorry for that, I’m not technically minded like you lot. I do not have a lot of time to spend on this hobby anymore, so I just say what I observe. A debug/testing guide would be appreciated.
But if all I’m doing is p’ing people off (I’m detecting a level of exasperation) then I’ll stfu.
Don't take it personal. And sorry, I guess I should be less subtle. I really meant with proof at least a screenshot of the crash window. Better would be what Greg did, but we need a guide. That's for sure.
Hedeon is offline  
Old 17 July 2018, 17:10   #2312
Cowcat
Registered User
 
Join Date: Apr 2013
Location: Mallorca
Posts: 403
Quote:
I’m not technically minded like you lot.
Me neither.
Cowcat is offline  
Old 17 July 2018, 20:32   #2313
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Quote:
Originally Posted by Hedeon View Post
Greg,

Could you make a tutorial for the wiki on how to debug/report stuff? I guess it is needed. Your last one was perfect (attached a few posts back)

Sure, I'll do that tonight.
grelbfarlk is offline  
Old 17 July 2018, 21:59   #2314
Wrangler
Registered User

 
Join Date: Sep 2015
Location: London, UK
Posts: 214
I think I have finally sorted out the instability problems I was having and it was all down to heat. The temperature here today is about 5C cooler than all the last month plus (and I think this is the important bit) I've re-ordered the PCI cards so the voodoo heatsink is not radiating heat onto the back of the logic board. My working theory is that the mediator was giving up occasionally when the cplds overheated. Anyway, along with a big case fan directed on the PCI area, this seems to have fixed it for now...
Wrangler is offline  
Old 17 July 2018, 22:04   #2315
Wrangler
Registered User

 
Join Date: Sep 2015
Location: London, UK
Posts: 214
Just to add, I'd welcome a "bug reporting form" for when that's needed. But sometimes it's also good just to ask for a bit of help/guidance from other gurus and users on here to cover issues that aren't indicating there's a bug report on the software. Would be good to have a way to distinguish between the two and I think (hope) that would make life easier for Hedeon too.
Wrangler is offline  
Old 17 July 2018, 23:54   #2316
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 1,199
Almost done:
https://github.com/Sakura-IT/SonnetA...ki/Bug-Reports
grelbfarlk is offline  
Old 17 July 2018, 23:56   #2317
Marlon_
Amiga Programmer

Marlon_'s Avatar
 
Join Date: Mar 2016
Location: Sundsvall, Sweden
Age: 29
Posts: 410
Quote:
Originally Posted by grelbfarlk View Post
Oh, so you have finally started to use Git?

EDIT:
Nevermind, you don't need to know git for the wiki part. :P
Marlon_ is offline  
Old Yesterday, 00:15   #2318
strim
NetBSD developer
 
Join Date: May 2012
Location: Warsaw, Poland
Posts: 409
Quote:
Originally Posted by grelbfarlk View Post
Good work, but I think it should include content from CONTRIBUTING.md file that is in the repo.

https://github.com/Sakura-IT/SonnetA...ONTRIBUTING.md

Then perhaps the contents of this file should be replaced with link to wiki.
strim is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
WANTED: PCI Sound Card VORTEX2 SuperQuard / SQ2500 or Turtlebeach SantaCruz pci card keropi MarketPlace 12 15 March 2017 02:48
Wanted:Sonnet Technologies QuadDoubler 50 (Doubler 4000) kronuz MarketPlace 0 16 June 2013 00:29
eBay : Sonnet Quaddoubler alexh MarketPlace 3 07 May 2013 00:50
Overlay problem on GeForce 7200 Leandro Jardim support.WinUAE 1 10 August 2010 15:50
Prometheus PCI & Voodoo 3 PCI GFX Card Slayer support.Hardware 21 05 September 2006 10:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 17:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.15041 seconds with 15 queries