English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 12 May 2019, 20:19   #1
marcd
Registered User

 
Join Date: Sep 2018
Location: Montreal, Canada
Posts: 4
CD32 not reading discs

Hi,

I have two CD32 that are unable to read discs. The first unit I bought had this symptom. I purchased an NOS laser pickup and it did not fix the issue. I recapped the main PCB and the CD-ROM pcb and it did not fix the issue either. As a last attempt to fix it, I adjusted the pots as shown on a video I found on youtube. It did not help. I tried a different power supply, still no luck

I had the opportunity to purchase a working CD32 this weekend. The unit worked at the seller's home this friday. We tried about 5 different discs and they all worked. I bought it thinking it would help me fix my first unit.

I just tried the unit and it does not work anymore. I get the same behavior I was having with my first CD32.

When I insert a disc, it keeps spinning. It detects music CDs, plays them but I hear no audio.

I am really out of options. Any idea what I could try next ? Could it be the laser pickup lens ? Not sure if it changes anything but both are NTSC version.


Thanks !

Marc

Last edited by marcd; 13 May 2019 at 17:50.
marcd is offline  
Old 12 May 2019, 21:06   #2
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 48
Posts: 3,210
welcome to the club of dual-CD32 owners.

yes, changing the laser solves issues when only audio cds work and not data. But use sony laser, not some chinese crap. I suck at anything hardware but I could do it easily following Akira tutorial: http://eab.abime.net/showthread.php?p=1115899

Adusting the pots is on the other hand complex. I saw the videos and I decided: I'm not doing it. not useful when you're using original sony lasers.

Audio not playing, that's something new. Try with normal audio & also jack audio. Try fiddling with the volume button too.

You mean you have now 2 non-working CD32s?? I myself had one non working CD32 and bought another one, that wasn't working either. Changing both lasers fixed both.

Which discs did you test at the sellers? burned discs or pressed discs? it can be different.

Now I have a perfectly working one, but the CD motor of the first one seems faulty.

Last edited by jotd; 12 May 2019 at 21:18.
jotd is offline  
Old 12 May 2019, 21:36   #3
marcd
Registered User

 
Join Date: Sep 2018
Location: Montreal, Canada
Posts: 4
Hi,

I used original game discs. Defender of the Crown II and a couple other ones. I did try with headphone jack and the RCA output ports. I hear the sound when the console boot so again I am not sure what the problem can be.

I used original Sony lens at first altough they are very difficult to source. Where did you get yours from ?

And yes, now I have 2 non-working CD32 with the same problem. Not being able to read any kind of discs. Can't believe it was working 2 days ago and the first time I plug it in at home it does not work.

Tanks for your help !
marcd is offline  
Old 12 May 2019, 21:54   #4
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 48
Posts: 3,210
difficult to source?? no way! google KSS210A. Amazon sells some (https://www.amazon.fr/Replacement-KS.../dp/B00MWR8YI4
)...
I bought mine for 20 euros from a company in italy. I don't remember now.

When you installed the lasers did you remove the blob of solder as indicated in the tutorial BTW?

Maybe now you fiddled with the potentiometers (the 3 ones or the one on the laser?). You shouldn't have done that IMHO... can you reset to their original positions?

Maybe the seller showed you a working one and swapped it, or it was on the edge of failing and carrying it killed the laser for good... who knows, I wasn't there.
jotd is offline  
Old 13 May 2019, 02:47   #5
marcd
Registered User

 
Join Date: Sep 2018
Location: Montreal, Canada
Posts: 4
On the second unit, I did not touch anything yet. I will order new pickup lens.

To fix the first unit, I ordered 2 New Old Stock pickup lens from a guy in Austria. They were brand new but at least 10 years old.

I will give it a shot and order 2 more from another retailer. The ones you suggest on Amazon, are they genuine ?

The seller was honest. I packed the console myself right after we tested it. I guess it's just a bad luck. Hopefully I will be able to fix them both.

Thanks for your help.

If someone has a good place to order the pickup lens in North America, let me know. Or if you have another suggestion that could help me fix my beloved consoles.
marcd is offline  
Old 13 May 2019, 07:31   #6
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 48
Posts: 3,210
As I said, I suck at anything hardware. I just got 2 lenses (it's easy to check if they're genuine, the PN KSS210A is written on it, unless they're countefeits of course)

We're lucky as those parts are the same since 1980 something

Don't forget to desolder the blob as in the tutorial.
jotd is offline  
Old 13 May 2019, 19:19   #7
lesta_smsc
Registered User

lesta_smsc's Avatar
 
Join Date: Feb 2012
Location: United Kingdom
Posts: 1,713
Not related directly. But on the Xbox 360 I just tweaked pot diode... it allowed it to work until such time it needed complete replacement. I had no real need for drive as set it to RGH but for some originals I had lying around I used the drive.
lesta_smsc is offline  
Old 29 May 2019, 04:05   #8
marcd
Registered User

 
Join Date: Sep 2018
Location: Montreal, Canada
Posts: 4
Well, I did some extra tests and can't get my CD32 to read discs. I tried yet another power supply, recaped the entire unit and tried to raise the lens with some washers as suggested on some other threads.

Long story short, the disc spins but the CD32 logo remains on the screen. With an audio CD, I see the tracks playing but I get no audio. What is very weird is that my two CD32 have the exact same problem !!!

Does any of you have an idea/suggestion of what I could try next ?

Thanks !

Last edited by marcd; 29 May 2019 at 04:20.
marcd is offline  
Old 29 May 2019, 19:41   #9
Rochabian
The Big White Cat
Rochabian's Avatar
 
Join Date: Jan 2005
Location: France
Age: 40
Posts: 496
Is the ribbon between CD PCB and motherboard in good condition and well inserted on the two sides ? Have you tried to clean the ribbon contacts ?

While a CD audio plays did you hear something (very low volume) or nothing at all ?

I'm from the club of the dual-CD32 owners too , i've got a tricky lens adjustment method but you should hear audio from CD audio before trying that method

Here it is with a CD audio (no CD-R or games ) :

Play a CD audio ten minutes before adjusting the pot, then the lens will have a normal temp (don't do this "at cold" because you will have reading problem after some time)

Then adjust the pot (right : increase voltage to be able to play CD-R, left : decrease voltage), don't get too high on right.....

Increase voltage a little little bit then put an audio CD

Don't do this "on the fly", power off then power on at every pot step

When the CD start to spin backwards, you're a little bit too high in voltage

Then decrease voltage until the CD spins normally with no audio skipping issue

And you should be able to play original, CD-R and audio CD fine

I've done this on 4 CD32 with original & spare lens and it worked

See my actual pot position and don't get too high...
Attached Thumbnails
Click image for larger version

Name:	CD32 lens pot.jpg
Views:	18
Size:	417.6 KB
ID:	63309  

Last edited by Rochabian; 29 May 2019 at 20:17.
Rochabian is offline  
Old 29 May 2019, 21:53   #10
jotd
This cat is no more
jotd's Avatar
 
Join Date: Dec 2004
Location: FRANCE
Age: 48
Posts: 3,210
Rochabian advice looks very good

I think I'll buy another dozen of broken CD32s just to try to fix them
jotd is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Authoring CD32 Discs mcgeezer Coders. General 8 31 May 2018 07:40
Amiga 500+ not reading discs. Zeecor support.Hardware 1 22 August 2014 15:50
CD32 Not Reading Discs darkwave support.Hardware 25 22 June 2012 16:37
CD32+SX32 problem booting CD32 discs Rochabian support.Hardware 6 28 February 2007 20:36
Reading PC discs Unregistered support.Hardware 12 01 September 2004 11:00

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 06:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.08594 seconds with 14 queries