English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Asm / Hardware

 
 
Thread Tools
Old 21 September 2018, 17:21   #1
fstarred
Registered User

fstarred's Avatar
 
Join Date: Mar 2018
Location: Rome
Posts: 98
Blitter screen copy screw up with no reason ?

I'm struggling with an odd issue about blitter copy.


Basically I was doing a typical scrolling text + a whole copy of the screen on a bottom part of it.
So each VBLANK the steps are 3:


  1. plot char beyond screen
  2. scroll text
  3. copy whole text screen area on the bottom
While the first 2 steps, work, the third step screw up the result.

But It's not finished:


If I alternate step 2 with 3 each VBLANK, it works



This is the source code:


https://github.com/fstarred/amiga_pl...emo/3/temp_4.s


I've also posted a video that show how the demo works simply by alternating step 2 with 3 each VBLANK, whereas calling both in a VBLANK step it stop working..
Attached Thumbnails
Click image for larger version

Name:	ezgif.com-video-to-gif.gif
Views:	64
Size:	696.6 KB
ID:	59912  
fstarred is online now  
Old 21 September 2018, 17:29   #2
StingRay
move.l #$c0ff33,throat

StingRay's Avatar
 
Join Date: Dec 2005
Location: Berlin/Joymoney
Posts: 6,146
Quick guess without having looked at the code: Blitter is most probably still busy copying the screen when you reach step 1 (plot char) again hence the display is screwed. Try adding a blitterwait directly after starting the blit for step 3 and see if that changes anything.
StingRay is offline  
Old 21 September 2018, 17:42   #3
fstarred
Registered User

fstarred's Avatar
 
Join Date: Mar 2018
Location: Rome
Posts: 98
Yes I thought it too, unfortunately there are all the blitterwait required (I've also tried to add even more than required )
fstarred is online now  
Old 21 September 2018, 17:47   #4
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 43
Posts: 22,017
Hint: A6
Toni Wilen is online now  
Old 21 September 2018, 17:51   #5
fstarred
Registered User

fstarred's Avatar
 
Join Date: Mar 2018
Location: Rome
Posts: 98
Quote:
Originally Posted by Toni Wilen View Post
Hint: A6

You saved my day...



I'm not kidding, it's the whole day I'm struggling..


thank you very much
fstarred is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blitter Mask shift during copy LeCaravage Coders. Asm / Hardware 6 18 March 2018 23:50
Smooth H-scrolling platform game in AMOS, screen copy vs screen offset? Damiga Coders. AMOS 30 19 March 2015 19:06
Blitter busy flag with blitter DMA off? NorthWay Coders. Asm / Hardware 9 23 February 2014 22:05
Need advice before I screw up my Amiga 1200 tech3475 support.Hardware 5 15 February 2012 21:46
All I want is a good screw... NovaCoder support.Hardware 2 15 July 2008 13:11

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06490 seconds with 16 queries