English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 17 April 2014, 17:46   #1
e5frog
The Headstrong
e5frog's Avatar
 
Join Date: May 2010
Location: Älvängen / Sweden
Age: 46
Posts: 269
Send a message via ICQ to e5frog Send a message via MSN to e5frog
[Solved] Width adjustment stopped working on 1084S-P2.

I was finally getting around to adjust the convergence on my 1084S-P2. After a bit of tinkering and adding two magnets I got the picture almost perfect - a lot better than when I started.

Adjusted picture height and positions, everything was nice so back on the shelf after attaching the rear part of the housing again. Big smile...

When turning it on again I had some picture flutter, small disturbances and picture was very wide. When trying to adjust the width, I got nothing, no change. The small disturbances stopped after a while and I assumed I had broken the pot or something.

Measured, desoldered, measured again, nothing wrong with that, soldered it back on and found the service manual for the 1084S-P1. Schematic is very hard to read... Seems there's a few resistors and then it goes to the TDA IC.
Checked the voltage on the first pin, it was -26V, according to the schematic for the "1084pal2" that voltage is -21V - for that one at least. When adjusting the pot I can change the voltage from -26V to almost 0V (-0.2 or so).

So I guess that IC could be broken.

Does anyone have any good tips or a better schematic, preferably for the 1084S-P2.

Don't know what could have happened, it's pretty annoying now that I got the picture right again.

Last edited by e5frog; 18 April 2014 at 00:16. Reason: Solved
e5frog is offline  
Old 17 April 2014, 18:23   #2
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 45
Posts: 24,646
Does image geometry still look correct? (Straight lines don't become curved near the edges etc)

EDIT: Asking because I had old monitor that had stuck full-width screen with bad edge geometry, problem was caused by shorted diode. Unfortunately I don't remember anymore what its function was.

Last edited by Toni Wilen; 17 April 2014 at 18:30.
Toni Wilen is online now  
Old 17 April 2014, 18:30   #3
e5frog
The Headstrong
e5frog's Avatar
 
Join Date: May 2010
Location: Älvängen / Sweden
Age: 46
Posts: 269
Send a message via ICQ to e5frog Send a message via MSN to e5frog
Yes, geometry is otherwise near perfect.
Guess I should discharge it, pull the PCB out and trace the signal... *sigh*

Well, yes, it could be something as simple as that.

Last edited by e5frog; 17 April 2014 at 18:50.
e5frog is offline  
Old 18 April 2014, 00:16   #4
e5frog
The Headstrong
e5frog's Avatar
 
Join Date: May 2010
Location: Älvängen / Sweden
Age: 46
Posts: 269
Send a message via ICQ to e5frog Send a message via MSN to e5frog
Discharged the tube, disconnected and desoldered enough to get the PCB out of the monitor, started looking for errors after also contacting Ray Carlsen for support and tips...

After checking most stuff such as diodes, resistors, with some help from the 1084S-P1 hardly readable schematic and resoldering some recommended components I also desoldered the cage on the bottom of the PCB - there I find a small strand of dremel metal brush, stuck to one of the pins of the large upright coil in the upper cage and touching the cage of course - so it was shorted out and no adjustment could be made - apparently.

As I had taken the time to tear it all down I proceeded to check solder joints and made sure all diodes measured OK, then reassembled and everything was working again. Screen is nice and sharp again all controls are working!

My own fault for using the dremel with a bare PCB on the table - I'll try not to do that again - or at least with a better quality brush that doesn't shed...
e5frog is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.5.1 has stopped working sege support.WinUAE 3 16 April 2013 12:40
1084s-d1 Vertical hold adjustment skforty support.Hardware 12 21 August 2009 12:51
CD32 stopped working twiggy support.Hardware 14 15 June 2009 11:44
Highway just stopped working... Smiley support.Hardware 3 04 September 2006 18:20
A2091 Stopped working Gary Harrison support.Hardware 5 19 June 2004 21:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 13:57.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.06838 seconds with 13 queries