English Amiga Board


Go Back   English Amiga Board > Coders > Coders. System

 
 
Thread Tools
Old 15 February 2019, 18:02   #3101
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,327
Quote:
Originally Posted by PeterK View Post
A similar problem and a comment from Toni:
http://eab.abime.net/showthread.php?t=96289
Yes, also with Kickstart a1200 if on WinUAE you configure ChipSet A4000 Picasso Driver do not work.
AMIGASYSTEM is offline  
Old 16 February 2019, 07:55   #3102
Michael
A1260T/PPC/BV/SCSI/NET

Michael's Avatar
 
Join Date: Jan 2013
Location: Moscow / Russia
Posts: 672
Quote:
Originally Posted by AMIGASYSTEM View Post
Yes, also with Kickstart a1200 if on WinUAE you configure ChipSet A4000 Picasso Driver do not work.

Really? PicassoIV or UAE driver or any? You may need to enable some tweaks, but you can make it work for sure.
Michael is offline  
Old 16 February 2019, 10:58   #3103
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,327
Quote:
Originally Posted by Michael View Post
Really? PicassoIV or UAE driver or any? You may need to enable some tweaks, but you can make it work for sure.
No, with KickStart 3.1.4 "A1200" PicassoIV or UAE driver does not work if you use an A4000 "RTG" configuration.

Anyway I think everything is normal, the same thing happens with KickStart 3.1 "A1200", even here you can not start an RTG A4000 system.
To run an A4000 RTG system you need the KickStart 3.1 "A4000".

This happens on WinUAE but I think it's the same thing on a real A4000, A1200 and A4000 even if they look the same, in reraltà they are not.
AMIGASYSTEM is offline  
Old Yesterday, 16:15   #3104
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,725
Quote:
Originally Posted by Retrofan View Post
Please tell how you're doing it, it's very interesting.
I have a cronjob running on a webserver. It's just a shelll+awk script that downloads the first page of this thread, searches for the attachments, downloads them, unpacks them, and makes the various icon.library files available for download from my systems.
kolla is offline  
Old Yesterday, 17:30   #3105
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,497
So, that explains now, why there were nearly 1500 downloads of my build 511 here in only 8 weeks, much more than I usually would expect. Kolla's cronjob probably downloaded my attachments every few hours. And I thought I had sooo many new followers ... (no, just kolla)
PeterK is offline  
Old Yesterday, 17:35   #3106
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,327
No PeterK, there are also me and the Italian users of amiganews.it
AMIGASYSTEM is offline  
Old Yesterday, 17:43   #3107
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,497
Yes, I know. But you and the Italian users are belonging to the 200-300 "normal" downloaders of an update, the people I can really "count" on.
PeterK is offline  
Old Yesterday, 17:47   #3108
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,725
icon.library 46.4 test versions

Quote:
Originally Posted by PeterK View Post
And I thought I had sooo many new followers ... (no, just kolla)

Oh, hehe, sorry about that

It's not possible to count unique IP addresses?
kolla is offline  
Old Yesterday, 17:53   #3109
AMIGASYSTEM
Registered User
AMIGASYSTEM's Avatar
 
Join Date: Aug 2014
Location: Brindisi (Italy)
Posts: 4,327
Peter what do you think of this, a floppy boot that only start with Icon.libry (including loadWB)
AMIGASYSTEM is offline  
Old Yesterday, 18:13   #3110
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,497
Quote:
Originally Posted by kolla View Post
Oh, hehe, sorry about that

It's not possible to count unique IP addresses?
I'm not the owner or operator of EAB, how should I get the IPs?

Try to parse the build numbers of my updates in your script to avoid downloading things again and again.


@AMIGASYSTEM
Yes, I already had a look at BootWB, because the OS 1.x icon.library code is interesting for me, although I will probably never use it.

But that icon.library was made with the intention to keep it as short as possible in order to save disk space and in addition it even contains a few instructions (LoadWB, EndCli) for executing it from the startup-sequence. So, you can not replace it with any other icon.library.
PeterK is offline  
Old Yesterday, 18:26   #3111
kolla
Registered User
kolla's Avatar
 
Join Date: Nov 2007
Location: Trondheim, Norway
Posts: 1,725
Quote:
Originally Posted by PeterK View Post
Try to parse the build numbers of my updates in your script to avoid downloading things again and again.

Good point, I will do that if you start bumping versions again. For now I have disabled the cronjob.
kolla is offline  
Old Yesterday, 18:35   #3112
PeterK
Registered User
 
Join Date: Apr 2005
Location: Hangover
Posts: 2,497
Not sure, if ever and when the next updates are coming. There's nothing planned yet.

Btw, it's not even necessary to parse the build numbers, just store the name string from the last download somewhere to compare it with the name of the latest attachment.
PeterK is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
ClassicWB Full and icon.library 46.4 Retroplay project.ClassicWB 8 05 August 2018 14:57
WB library conflict/versions Akira support.Apps 3 22 July 2010 19:47
PNG Icon to Color Icon Converter? Leandro Jardim request.Apps 1 24 May 2010 05:39
What's the latest version of icon.library for OS3.9? NovaCoder support.Apps 3 30 June 2009 16:43
Requesting icon.library v44+... nikvest request.Other 2 16 September 2007 02:58

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:20.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.16684 seconds with 15 queries