English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 29 October 2011, 23:43   #1
palaste
Registered User
 
Join Date: Oct 2011
Location: Helsinki, Finland
Posts: 70
Problems with E-UAE

Hello there!

This is my first post to the English Amiga Board. I saw that there is an UAE support forum here, so I thought I'd post my question here.

I am running Fedora 12 Linux on a 64-bit AMD system. I am using E-UAE to emulate my old Amiga 4000, with the Kickstart ROM from Amiga Forever and the Amiga hard disk copied directly from my old Amiga 4000.

The emulation works otherwise OK, but the sound has horrible latencies, which causes it to play incorrectly. I've tried setting various values for sound latency and frequency in .uaerc, but they don't help.

I am running E-UAE version 0.8.29-WIP4 which came preinstalled on Fedora 12 Linux. I also tried recompiling it from the source package, but although E-UAE compiles, when I run it, it segfaults before I even get to see the configuration window. This happens both when compiling from the sources and when using a ready-built binary. Here is what it displays:

E-UAE 0.8.29-WIP4
Build date: Oct 29 2011 16:23:07
X11GFX: Initialized.
Found 0 joystick(s)
X11GFX: Raw key-mapping disabled.
Opening cfgfile '/home/joona/.uaerc'...okay.
unknown config entry: 'sdl.map_raw_keys=false'
unknown config entry: 'cachesize=1024'
Testing the RDTSC instruction ... done.
TSC frequency: 3013.000000 MHz
Cannot open audio device: Device or resource busy.
Sound driver unavailable: Sound output disabled
Found 0 joystick(s)
X11GFX: Raw key-mapping disabled.
Segmentation fault (core dumped)

I've also tried P-UAE, but when I try to run autoconf to generate the configure file, it gives errors:

configure.in:11: error: possibly undefined macro: AM_CONFIG_HEADER
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
configure.in:13: error: possibly undefined macro: AM_INIT_AUTOMAKE
configure.in:22: error: possibly undefined macro: AS_PROG_OBJC
configure.in:23: error: possibly undefined macro: AM_PROG_AS
configure.in:71: error: possibly undefined macro: AM_PATH_GTK_2_0
configure.in:73: error: possibly undefined macro: AM_PATH_GTK
configure.in:238: error: possibly undefined macro: AC_DEFINE
configure.in:814: error: possibly undefined macro: AM_PATH_SDL
configure.in:1672: error: possibly undefined macro: AC_CHECK_FRAMEWORK
configure.in:2043: error: possibly undefined macro: AM_CONDITIONAL

The resulting configure file fails because of these errors.

Can anyone help me in getting E-UAE working properly?
palaste is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with UAE 2.5.1 Edwooger support.WinUAE 3 22 April 2013 23:13
KGB - WHDLoad UAE problems Angus support.Games 2 17 December 2010 19:39
E-UAE (MorphOS) - problems with memory Solo Kazuki support.OtherUAE 3 12 April 2007 03:49
CD32 problems with cd games and UAE ElectroBlaster support.WinUAE 3 23 March 2002 16:57
Problems with UAE under Linux... Lettmennli support.WinUAE 15 13 February 2002 23:09

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Page generated in 0.05847 seconds with 13 queries