English Amiga Board


Go Back   English Amiga Board > Support > support.FS-UAE

 
 
Thread Tools
Old 06 February 2012, 17:50   #41
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by gaula88@hotmail View Post
Is it possible to boot an HDF file in A1200 mode?
Is it possible to use a custom video mode for PAL 50HZ? Or at least ..is it possible to control internal refresh rate so we can have smooth scroll in NTSC games? (IE to force them into an exact given internal refreh rate, synced with a given monitor refresh rate)

thanks!
Support for hard disk files is not implemented yet, and it wasn't really on my TODO list, but on the other hand, it might be fairly easy to do (The code is there, I just have to make it work with fs-uae).

PAL games should sync perfectly if you have the refresh rate set to 50 (unless your on Mac, where refresh rate detection code is not done yet - I could alternatively implement some override settings). There is no (good) support for NTSC games right now, but if you will test them, I will add code for it!

Quote:
Originally Posted by sebbi View Post
Hi,

i tried to compile the 0.9.3 source on archlinux x64 and got the following error:

g++ obj/fs-main.o obj/fs-menu.o obj/fs-mouse.o obj/fs-keyboard.o obj/fs-video.o obj/fs-joystick.o obj/libamiga.a -Llibfsemu/out -lfsemu `sdl-config --libs` `pkg-config --libs glib-2.0 gthread-2.0` -lpng -lz -lGL -lGLU -o out/fs-uae
/usr/bin/ld: obj/libamiga.a(libamiga-caps.o): undefined reference to symbol 'dlsym@@GLIBC_2.2.5'
/usr/bin/ld: note: 'dlsym@@GLIBC_2.2.5' is defined in DSO /lib/libdl.so.2 so try adding it to the linker command line
/lib/libdl.so.2: could not read symbols: Invalid operation

Any hints?
It looks like I have omitted to link with libdl (http://linux.die.net/man/3/dlopen), and it just happens to work on Debian without it). Try to replace the line
libs += -lGL -lGLU
with
libs += -lGL -lGLU -ldl
in fs-uae/Makefile. Please let me know if it works and I can fix the Makefile in the source distribution.

Quote:
Originally Posted by kire_online View Post
Great work on this, I can hook into it from Plex and play my Amiga games on the big screen.
Just tried it on my macbook air, scrolling seems OK on Giana Sisters, the sound was fairly crap though.
I loved the floppy disk sounds, sounds like the real thing.
Keep up the great work.
Thank your for the encouragement! Regarding sound, could you describe the nature of the crapiness? Is the sound stuttering?

I have an OpenAL backend nearly done which might work better; it depends on the actual problem.

Updated: here are some issues which are on my short-term todo list, which aren't already fixed:
- Support hard disk files (HDF)
- Add support for NTSC games / 60Hz
- Fix refresh rate detection on Mac to let fs-uae turn on vsync @50Hz, and/or implement an override option
- CD32 CD audio support
- CD32 gamepad (emulated by keyboard)
- More Amiga models (A1000, A500+, A600)
- Configurable memory (chip, slow, fast)

Last edited by FrodeSolheim; 06 February 2012 at 18:51. Reason: added note about more amiga models
FrodeSolheim is offline  
AdSense AdSense  
Old 06 February 2012, 18:16   #42
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by gaula88@hotmail View Post
Is it possible to use a custom video mode for PAL 50HZ?
fs-uae will not change video mode on its own (explained in the README), but will use your current video mode, so switch to a 50hz mode and it should work.

fs-uae parses the output of xrandr to check the refresh rate of the current mode. Actually, that reminds me of something. nVIDIAs Linux drivers lies about the refresh rate to xrandr as default, and this can cause fs-uae to not work properly. If you disable TwinView support, the refresh rates will be reported correctly.

Last edited by FrodeSolheim; 06 February 2012 at 19:03.
FrodeSolheim is offline  
Old 06 February 2012, 19:21   #43
Jerry
Registered User
 
Join Date: Mar 2005
Location: Germany
Age: 38
Posts: 196
Really nice work. Works well on my Kubuntu system. A git repository would be neat so one could quickly get your changes without having to do the complete unpack/compile cycle.

But I really like the idea of having the gui in the framebuffer. If it's carried out nicely (ie. agnostic of the graphics lib) perhaps this version can be easily ported to the wii and similar platforms where current (e-)uae implementations lack nice guis because people want to port the application not wasting time in implementing the 100th text based gui.
Jerry is offline  
Old 06 February 2012, 20:40   #44
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Version 0.9.4

  • CD audio support for CDTV/CD32
  • Audio output is now using OpenAL
  • CDTV/CD32 now works properly when specifying kickstart files manually
  • link with libdl on Linux systems

Binaries:
http://fengestad.no/fs-uae/files/fs-....4-windows.zip
http://fengestad.no/fs-uae/files/fs-...-macosx.tar.gz
Source code:
http://fengestad.no/fs-uae/files/fs-uae-0.9.4.tar.gz

I haven't put these up on the home page yet. I would like to get some feedback on how well fs-uae works for you with OpenAL - This version requires OpenAL. On Windows, you must install it (if you haven't got it already). The installer is available here:
http://fengestad.no/fs-uae/files/oalinst.exe or here: http://connect.creativelabs.com/open...ds/oalinst.zip
On debian, you must install libopenal1 (and libopenal-dev to compile fs-uae).
Mac OS X 10.6+ already comes with OpenAL built-in.
FrodeSolheim is offline  
Old 06 February 2012, 20:55   #45
dreamkatcha
My elbow tastes of icky

dreamkatcha's Avatar
 
Join Date: Mar 2002
Location: Manchester, UK
Posts: 702
Wow, some more Miggy emulation action for the Mac! Before P-UAE came along I was starting to think the long stagnant E-UAE project was the end of the line. Thanks for all your hard work.

Unfortunately it doesn't like my Mac. I get the error message: "You can’t open the application “fs-uae” because it’s not supported on this type of Mac."

I'm running it on an Intel Core Duo Mac Mini with Snow Leopard 10.6.8 installed. Any ideas?
dreamkatcha is offline  
Old 06 February 2012, 21:37   #46
sebbi
Registered User
sebbi's Avatar
 
Join Date: Dec 2011
Location: Frankfurt/Germany
Posts: 10
It compiles and runs now on my system. Many thanks for this one!

I created an AUR-package for all Archlinux users out there:
https://aur.archlinux.org/packages.php?ID=56450

cheers

Sebbi
sebbi is offline  
Old 06 February 2012, 22:25   #47
kamelito
Zone Friend
kamelito's Avatar
 
Join Date: May 2006
Location: France
Posts: 893
why not just put the folders needed for fs-uae, like kickstart in the same folder as fs-uae? what is the point of /path/to/ why not use folder relative to fs-uae archive? (by including all the necessary ones. Kamel
kamelito is offline  
Old 06 February 2012, 23:42   #48
P-J
Grumpy veteran
P-J's Avatar
 
Join Date: Mar 2001
Location: Moorpark, California
Age: 38
Posts: 1,146
Send a message via MSN to P-J
Heya

Thought I'd throw my errors in here :P Running the 64-bit Debian version you put together. Have pointed to a working ADF file and 1.3 ROM, but I don't get any output in the emulator. It's responding ok, but I get a black screen and no Amiga

Here's the log :

Code:
load config file
loading config from /home/phil/.config/fs-uae/fs-uae.conf
initializing SDL
fs_emu_init
fs_emu_video_init
detected refresh rate: 50
current display mode is 0x0@50hz
auto display mode is enabled
already correct display mode
auto vsync enabled
frame rate (50) equals screen refresh (50)
activating video sync
calling fs_ml_init
detected refresh rate: 50
assuming refresh rate: 50 (20000 usec per frame)
init_input
calling fs_ml_video_init
creating condition
creating mutex
calling fs_ml_input_init
fs_ml_input_init
device #01 found: MICROSOFT X-BOX 360 PAD
- 11 buttons 1 hats 6 axes
read config
fs_emu_input_init
init_input_configs
WARNING: fs_get_application_exe_path not implemented
WARNING: fs_get_application_exe_path failed
checking share dir ../share/fs-emu-share-dir
checking share dir share/fs-emu-share-dir
checking share dir /usr/share/xubuntu/fs-emu-share-dir
checking share dir /usr/share/xubuntu/fs-uae/fs-emu-share-dir
checking share dir /usr/share/xubuntu/../../share/fs-emu-share-dir
checking share dir /usr/local/share/fs-emu-share-dir
checking share dir /usr/local/share/fs-uae/fs-emu-share-dir
checking share dir /usr/local/share/../../share/fs-emu-share-dir
checking share dir /usr/share/fs-emu-share-dir
checking share dir /usr/share/fs-uae/fs-emu-share-dir
reading input device configs from /usr/share/fs-uae/input
initializing devices for menu
0 MICROSOFT X-BOX 360 PAD
get system config for device: microsoft_x_box_360_pad
config file for microsoft_x_box_360_pad was not found
did not find menu config for device "microsoft_x_box_360_pad"
1 KEYBOARD
get system config for device: keyboard
read config for keyboard for menu
did not find action for "skip_left"
did not find action for "(primary)"
did not find action for "skip_right"
did not find action for "secondary"
did not find action for "(back)"
fs_emu_audio_init
using SDL for audio
trying to open audio @48000Hz
frequency: 48000.0
system buffer size (samples): 1024
system buffer size (bytes): 4096
system buffer size (ms): 21.3
fs_ml_video_create_window
*** SDL_GL_SWAP_CONTROL is enabled ***
using windowed mode
init_opengl
loading texture "/usr/share/fs-uae/glow_left.png"
loading texture "/usr/share/fs-uae/glow_top_left.png"
loading texture "/usr/share/fs-uae/glow_top.png"
loading texture "/usr/share/fs-uae/screen_gloss.png"
initializing menu
loading texture "/usr/share/fs-uae/sidebar_background.png"
loading texture "/usr/share/fs-uae/close.png"
loading texture "/usr/share/fs-uae/volume.png"
loading texture "/usr/share/fs-uae/volume_mute.png"
loading texture "/usr/share/fs-uae/aspect_stretch.png"
loading texture "/usr/share/fs-uae/aspect_correct.png"
loading texture "/usr/share/fs-uae/menu_fade_item.png"
loading texture "/usr/share/fs-uae/menu_fade_selected_item.png"
loading texture "/usr/share/fs-uae/menu_selected.png"
loading texture "/usr/share/fs-uae/menu_arrow.png"
load font title_font
loading texture "/usr/share/fs-uae/title_font.png"
font height: 32 pixels
load font menu_font
loading texture "/usr/share/fs-uae/menu_font.png"
font height: 32 pixels
create windows is done
STUB: fs_uae_init_mouse
fs_uae_configure_menu
fs_emu_set_menu 0x3d04250
fs_emu_run, main_function at 0x407090
emulation thread started
amiga_main
KB: keyboard_settrans
target_default_options p=0x2981140 type=0
configuring floppy sounds
init_joystick
FIXME: call figure_processor_speed here???CLOCKFREQ: CLOCK_REALTIME 10.00MHz (10.00MHz, DIV=1)
 -- stub -- init_kb 
STUB: target_save_options zfile=? p=0x2981140
 -- stub -- target_fixup_options 
graphics_setup
target_default_options p=0x2981140 type=0
configuring floppy sounds
init_joystick
FIXME: call figure_processor_speed here???CLOCKFREQ: CLOCK_REALTIME 10.00MHz (10.00MHz, DIV=1)
 -- stub -- init_kb 
STUB: target_save_options zfile=? p=0x2981140
load config '././/home/phil/././.uaerc':0
load failed
 -- stub -- target_fixup_options 
failed to load config '/home/phil/././.uaerc'
target_default_options p=0x2981140 type=0
configuring floppy sounds
init_joystick
FIXME: call figure_processor_speed here???CLOCKFREQ: CLOCK_REALTIME 10.00MHz (10.00MHz, DIV=1)
 -- stub -- init_kb 
STUB: target_save_options zfile=? p=0x2981140
load config '././.uaerc':0
load failed
 -- stub -- target_fixup_options 
 -- stub -- target_fixup_options 
target_default_options p=0x2981140 type=1
configuring floppy sounds
configure_rom
load_rom_files .
target_default_options p=0x2981140 type=1
configuring floppy sounds
set option "quickstart" to "A500,," (result: 1)
set option "kickstart_rom_file" to "~/Other/Emulation/Kickstarts/kick13.rom" (result: 1)
configure_floppies
value for option floppy_drive_0: ~/Other/Emulation/Floppies/digital_innovation.adf
set_default_dirs_from_file_path ~/Other/Emulation/Floppies/digital_innovation.adf
default dir = ~/Other/Emulation/Floppies
set option "floppy0" to "~/Other/Emulation/Floppies/digital_innovation.adf" (result: 1)
set option "floppy0type" to "0" (result: 1)
value for option floppy_drive_1: (null)
value for option floppy_drive_2: (null)
value for option floppy_drive_3: (null)
automatically set num_drives to 1
set option "floppy1type" to "-1" (result: 1)
set option "floppy2type" to "-1" (result: 1)
set option "floppy3type" to "-1" (result: 1)
configuring joystick ports:
configuring joystick port 0 (auto)
set option "joyport0" to "mouse" (result: 1)
configuring joystick port 1 (auto)
trying to auto-configure joystick 1 in port 1
configure joystick "joy0" for "amiga"
matched device #0
config name "microsoft_x_box_360_pad"
get system config for device: microsoft_x_box_360_pad
config file for microsoft_x_box_360_pad was not found
did not find config for device "microsoft_x_box_360_pad"
could not auto-configure joystick 1, using keyboard emulation
configure joystick "KEYBOARD" for "amiga"
did not match device #0 (MICROSOFT X-BOX 360 PAD)
matched device #1
config name "keyboard"
get system config for device: keyboard
read config for keyboard for amiga
set option "joyport1" to "joy1" (result: 1)
set option "statefile_name" to "~/Other/Emulation/Floppies/fs-uae-state.uss" (result: 1)
fs_emu_get_video_sync returned true
set option "gfx_vsync" to "true" (result: 1)
set option "sound_auto" to "false" (result: 1)
set option "sound_frequency" to "48000" (result: 1)
init_joystick
FIXME: call figure_processor_speed here???CLOCKFREQ: CLOCK_REALTIME 10.00MHz (10.00MHz, DIV=1)
 -- stub -- init_kb 
 -- stub -- gui_init 
 -- stub -- logging_init 
 -- stub -- target_fixup_options 
 -- stub -- target_run 
 -- stub -- scsidev_install 
 -------- input_get_default_mouse ----------
input_get_default_joystick num=1 port=1 af=0 mode=0
Entered action_replay_load ()
ROM loader.. (<none>)
Failed to open '~/Other/Emulation/Kickstarts/kick13.rom'
 -- stub -- notify_user msg=1
ROM loader end
memory init end
drive_insert drv=0x285b480 dnum=0 fname=~/Other/Emulation/Floppies/digital_innovation.adf fake=0
about to call gui_disk_image_change(dnum=0, fname=~/Other/Emulation/Floppies/digital_innovation.adf, wrprot=1)
gui_disk_image_change drive 0 name ~/Other/Emulation/Floppies/digital_innovation.adf write protected 1
calling disk_setwriteprotect 0
diskfile_iswriteprotect fname=~/Other/Emulation/Floppies/digital_innovation.adf
 -- stub -- gui_filename num=0 name=""
gui_disk_image_change drive 0 <no disk>
drive_insert drv=0x287da88 dnum=1 fname=df1.adf fake=0
about to call gui_disk_image_change(dnum=1, fname=df1.adf, wrprot=1)
gui_disk_image_change drive 1 name df1.adf write protected 1
calling disk_setwriteprotect 0
diskfile_iswriteprotect fname=df1.adf
 -- stub -- gui_filename num=1 name=""
gui_disk_image_change drive 1 <no disk>
drive_insert drv=0x28a0090 dnum=2 fname=df2.adf fake=0
about to call gui_disk_image_change(dnum=2, fname=df2.adf, wrprot=1)
gui_disk_image_change drive 2 name df2.adf write protected 1
calling disk_setwriteprotect 0
diskfile_iswriteprotect fname=df2.adf
 -- stub -- gui_filename num=2 name=""
gui_disk_image_change drive 2 <no disk>
drive_insert drv=0x28c2698 dnum=3 fname=df3.adf fake=0
about to call gui_disk_image_change(dnum=3, fname=df3.adf, wrprot=1)
gui_disk_image_change drive 3 name df3.adf write protected 1
calling disk_setwriteprotect 0
diskfile_iswriteprotect fname=df3.adf
 -- stub -- gui_filename num=3 name=""
gui_disk_image_change drive 3 <no disk>
No disk in drive 0.
CPU cycleunit: 256 (0.500)
Building CPU table for configuration: 68000 prefetch and cycle-exact 24-bit
1879 CPU functions
Building CPU, 44316 opcodes (0 -1 1)
CPU=68000, FPU=0, MMU=0, JIT=0.
graphics_init
calling reset_drawing
>>> init_colors
init_sound
 -------- input_get_default_mouse ----------
input_get_default_joystick num=1 port=1 af=0 mode=0
CPU cycleunit: 256 (0.500)
 -- stub -- target_reset 
 -- stub -- scsidev_reset 
 -- stub -- scsidev_start_threads 
 -- stub -- filesys_addexternals 
memory init end
Reset at 00000000
00000000    2048K/4 =     512K Chip memory
00200000    8192K/0 =    8192K <none>
00A00000    2048K/0 =    2048K CIA
00C00000     512K/1 =     512K Slow memory
00C80000    1024K/0 =    1024K Custom chipset
00D80000     256K/0 =     256K <none>
00DC0000      64K/0 =      64K Battery backed up clock (none)
00DD0000      64K/0 =      64K <none>
00DE0000     128K/0 =     128K Custom chipset
00E00000     512K/1 =     512K Extended Kickstart ROM (7000C2B4)
00E80000      64K/0 =      64K Autoconfig
00E90000     960K/0 =     960K <none>
00F80000     512K/1 =     512K Kickstart ROM (B2161EDB)
drive_insert drv=0x285b480 dnum=0 fname= fake=0
about to call gui_disk_image_change(dnum=0, fname=, wrprot=1)
gui_disk_image_change drive 0 <no disk>
 -- stub -- gui_filename num=0 name=""
gui_disk_image_change drive 0 <no disk>
drive_insert drv=0x287da88 dnum=1 fname= fake=0
about to call gui_disk_image_change(dnum=1, fname=, wrprot=1)
gui_disk_image_change drive 1 <no disk>
 -- stub -- gui_filename num=1 name=""
gui_disk_image_change drive 1 <no disk>
drive_insert drv=0x28a0090 dnum=2 fname= fake=0
about to call gui_disk_image_change(dnum=2, fname=, wrprot=1)
gui_disk_image_change drive 2 <no disk>
 -- stub -- gui_filename num=2 name=""
gui_disk_image_change drive 2 <no disk>
drive_insert drv=0x28c2698 dnum=3 fname= fake=0
about to call gui_disk_image_change(dnum=3, fname=, wrprot=1)
gui_disk_image_change drive 3 <no disk>
 -- stub -- gui_filename num=3 name=""
gui_disk_image_change drive 3 <no disk>
 -- stub -- updatedisplayarea 
PAL mode V=50.0000Hz H=15600.0000Hz (227x312+1)
 -- stub -- fpux_restore 
hardreset, memory cleared
init_sound
init_sound_thread
uae_start_tread name Sound function at 0x409540 arg (nil)
initialize drivesound
open_sound returning 1
 -- stub -- updatedisplayarea 
Display Size: 640x480 Offset: 58x36
First: 26 Last: 0 MinV: 0 MaxV: 0 Min: 26
fs-uae:render_screen dt 519.85
>  58  36 640 480
 -- stub -- updatedisplayarea 
PAL mode V=50.0000Hz H=15600.0000Hz (227x312+1)
Display Size: 640x480 Offset: 58x36
First: 26 Last: 0 MinV: 0 MaxV: 0 Min: 26
fs-uae:render_screen dt 35.87
fs-uae:render_screen dt 36.69
fs-uae:render_screen dt 36.77
Illegal instruction: 4e7a at 00F8042C -> 00F804BC
fs_emu_toggle_menu
update_main_menu
floppy in 0: 
fs-uae:render_screen dt 35.85
fs-uae:render_screen dt 39.58
fs-uae:render_screen dt 36.06
fs-uae:render_screen dt 39.95
fs-uae:render_screen dt 36.95
fs-uae:render_screen dt 36.53
fs-uae:render_screen dt 36.93
fs-uae:render_screen dt 38.17
fs-uae:render_screen dt 36.98
fs-uae:render_screen dt 37.67
fs-uae:render_screen dt 36.90
fs-uae:render_screen dt 40.16
fs-uae:render_screen dt 36.37
fs-uae:render_screen dt 40.46
fs-uae:render_screen dt 37.63
fs_emu_toggle_menu
fs-uae:render_screen dt 36.46
fs-uae:render_screen dt 37.10
fs-uae:render_screen dt 36.81
fs-uae:render_screen dt 36.58
fs-uae:render_screen dt 36.77
fs-uae:render_screen dt 36.91
fs-uae:render_screen dt 39.96
fs-uae:render_screen dt 36.76
fs-uae:render_screen dt 36.42
fs-uae:render_screen dt 36.53
fs-uae:render_screen dt 36.84
fs-uae:render_screen dt 36.78
fs-uae:render_screen dt 36.80
fs_emu_toggle_menu
update_main_menu
floppy in 0: 
fs-uae:render_screen dt 36.49
fs-uae:render_screen dt 36.85
fs-uae:render_screen dt 36.63
fs-uae:render_screen dt 36.51
fs-uae:render_screen dt 36.68
fs-uae:render_screen dt 36.59
fs-uae:render_screen dt 39.61
fs-uae:render_screen dt 36.20
on_quit selected from menu
fs_emu_quit called
fs-uae:render_screen dt 39.88
calling amiga_quit
 -- stub -- target_quit 
 -- stub -- close_kb 
 -- stub -- gui_exit 
 -- stub -- machdep_free 
amiga_main returned
calling fs_ml_stop_video
fs_emu_run: main loop is done
fs_emu_run: waiting for emulation thread to stop
fs_emu_run: emulation thread stopped
fs_emu_run: calling SDL_CloseAudio
fs_emu_run: returning
fs-uae shutting down
Cheers
P-J is offline  
Old 06 February 2012, 23:59   #49
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by Jerry View Post
Really nice work. Works well on my Kubuntu system. A git repository would be neat so one could quickly get your changes without having to do the complete unpack/compile cycle.
I use git internally for this project (git is fantastic). For now, I prefer to create source tarballs, but hosting the git on a public git repository would make sense later.

Quote:
Originally Posted by Jerry View Post
But I really like the idea of having the gui in the framebuffer. If it's carried out nicely (ie. agnostic of the graphics lib) perhaps this version can be easily ported to the wii and similar platforms where current (e-)uae implementations lack nice guis because people want to port the application not wasting time in implementing the 100th text based gui.
The actual input, audio and video code is separated from the rest of fs-uae, and it would probably not be that much work to implement input/audio/video for another system, such as Wii. But some other parts would perhaps have to be re-coded, for instance if glib is not available for Wii. I do not develop for Wii, so I cannot comment much, but I am open to patching fs-uae/libfsemu to better support Wii if someone decides to port it.

Quote:
Originally Posted by dreamkatcha View Post
Wow, some more Miggy emulation action for the Mac! Before P-UAE came along I was starting to think the long stagnant E-UAE project was the end of the line. Thanks for all your hard work.

Unfortunately it doesn't like my Mac. I get the error message: "You can’t open the application “fs-uae” because it’s not supported on this type of Mac."

I'm running it on an Intel Core Duo Mac Mini with Snow Leopard 10.6.8 installed. Any ideas?
Glad you're excited -Unfortunately I do not know what the problem is here. I built the app bundle on a Intel Core Duo with 10.6.8 myself...

Quote:
Originally Posted by sebbi View Post
It compiles and runs now on my system. Many thanks for this one!

I created an AUR-package for all Archlinux users out there:
https://aur.archlinux.org/packages.php?ID=56450
Great

Quote:
Originally Posted by kamelito View Post
why not just put the folders needed for fs-uae, like kickstart in the same folder as fs-uae? what is the point of /path/to/ why not use folder relative to fs-uae archive? (by including all the necessary ones. Kamel
The paths do not need to be absolute! Perhaps I should put a clarification on this in example.conf. Relative paths will be interpreted as relative to the
working directory.

What the working directory is depends on the OS and how the program was launched. In a terminal, the working directory is the directory "you're in". If it is launched from a graphical shell, the working directory may be the directory containing the executable. fs-uae does not change the working directory itself.

Last edited by FrodeSolheim; 07 February 2012 at 00:24.
FrodeSolheim is offline  
Old 07 February 2012, 00:04   #50
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by P-J View Post
Heya
Thought I'd throw my errors in here :P Running the 64-bit Debian version you put together. Have pointed to a working ADF file and 1.3 ROM, but I don't get any output in the emulator. It's responding ok, but I get a black screen and no Amiga
Good you posted the log! The problem is that fs-uae does not replace ~ with your home directory, so it does not find the files (It actually tries to look in a folder named ~ for them). It will probably work if you use full paths.

However, I can be quite useful to refer to files specific to the home dir, so I'll put on my TODO list to perform a shell-like expansion of paths from the configuration file
FrodeSolheim is offline  
Old 07 February 2012, 00:19   #51
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by P-J View Post
Code:
device #01 found: MICROSOFT X-BOX 360 PAD
- 11 buttons 1 hats 6 axes
...
0 MICROSOFT X-BOX 360 PAD
get system config for device: microsoft_x_box_360_pad
config file for microsoft_x_box_360_pad was not found
did not find menu config for device "microsoft_x_box_360_pad"
...
configure joystick "joy0" for "amiga"
matched device #0
config name "microsoft_x_box_360_pad"
get system config for device: microsoft_x_box_360_pad
config file for microsoft_x_box_360_pad was not found
did not find config for device "microsoft_x_box_360_pad"
could not auto-configure joystick 1, using keyboard emulation
Another interesting thing which can be seen from the log: you have a gamepad which is not currently recognized. Is this a cabled Xbox 360 controller? Would you help me fix this? See the README for more information.
FrodeSolheim is offline  
Old 07 February 2012, 00:23   #52
P-J
Grumpy veteran
P-J's Avatar
 
Join Date: Mar 2001
Location: Moorpark, California
Age: 38
Posts: 1,146
Send a message via MSN to P-J
Quote:
Originally Posted by FrodeSolheim View Post
Another interesting thing which can be seen from the log: you have a gamepad which is not currently recognized. Is this a cabled Xbox 360 controller? Would you help me fix this? See the README for more information.
It certainly is a cabled 360 controller What would you like me to do?
P-J is offline  
Old 07 February 2012, 00:27   #53
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by P-J View Post
It certainly is a cabled 360 controller What would you like me to do?
Either create a configuration file for it (explained in the README) and send me, or run jstest /dev/js0 and tell me the axis/hat/button number for each axis/hat/button on the gamepad. (For instance: Y is button 0, ...) and I'll create a configuration based on the description. I would appreciate it!
FrodeSolheim is offline  
Old 07 February 2012, 00:29   #54
P-J
Grumpy veteran
P-J's Avatar
 
Join Date: Mar 2001
Location: Moorpark, California
Age: 38
Posts: 1,146
Send a message via MSN to P-J
Quote:
Originally Posted by FrodeSolheim View Post
Either create a configuration file for it (explained in the README) and send me, or run jstest /dev/js0 and tell me the axis/hat/button number for each axis/hat/button on the gamepad. (For instance: Y is button 0, ...) and I'll create a configuration based on the description. I would appreciate it!
Ok, bear with me while I finish watching Top Gear and I'll sort it for you
P-J is offline  
Old 07 February 2012, 00:36   #55
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by P-J View Post
Ok, bear with me while I finish watching Top Gear and I'll sort it for you
Great -but no rush; I'm going to bed ;-)
FrodeSolheim is offline  
Old 07 February 2012, 01:00   #56
P-J
Grumpy veteran
P-J's Avatar
 
Join Date: Mar 2001
Location: Moorpark, California
Age: 38
Posts: 1,146
Send a message via MSN to P-J
Quote:
Originally Posted by FrodeSolheim View Post
Good you posted the log! The problem is that fs-uae does not replace ~ with your home directory, so it does not find the files (It actually tries to look in a folder named ~ for them). It will probably work if you use full paths.
I got it working now, but it it is extraordinarily slow. Is that a known issue?

Runs A500 at about 10fps(ish).

//edit : Using official nVidia binaries on Linux w/Twinview enabled. Could that cause an issue?

Last edited by P-J; 07 February 2012 at 12:01.
P-J is offline  
Old 07 February 2012, 10:48   #57
kire_online
Registered User
kire_online's Avatar
 
Join Date: Oct 2011
Location: Sydney
Posts: 119
Tried 0.9.4 on Mac OS X 10.7.3, sound is not as crappy as 0.9.2, but it only works for about 10 seconds, then complete silence. Sound won't work even after I hit F12, insert another floppy and select reset, no sound at all, even the nice floppy sound, it's completely silent. I quit out, then restart, and again the same thing, I can only play Giana Sisters for about 10 seconds before it goes silent.

Just tired leaving it on the Kickstart screen for several minutes, and floppy clicking sound continues, so it's a problem while playing the game that kills the sound.

Also tried leaving music playing at the start of Hybris for several minutes, no problem at all.

Gave you a plug on the following website too;
http://www.emucr.com/2012/02/fs-uae-v093.html

Keep up the great work.

Last edited by kire_online; 07 February 2012 at 11:08.
kire_online is offline  
Old 07 February 2012, 18:52   #58
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by P-J View Post
I got it working now, but it it is extraordinarily slow. Is that a known issue?

Runs A500 at about 10fps(ish).

//edit : Using official nVidia binaries on Linux w/Twinview enabled. Could that cause an issue?
TwinView should not cause this (but it can cause 50Hz detection to fail). -The nVIDIA drivers _could_ be a problem. I have two linux computers, both with nVIDIA drivers. The laptop, running Debian stable (with older nVIDIA drivers, I suppose) works perfectly, but in 60Hz, and 50Hz with perfect scrolling when connected to a 50hz TV. Then I have a (more powerful) computer running the latest Ubuntu release, and vsync does not work properly - and scrolling is rubbish. Here I have the newest nVIDIA drivers and there is possibly a driver problem with vsync. Anyway, it is nowhere near as bad as what you describe.

* First, of course, double-check that you have working 3D acceleration
* Secondly, try turning off Compiz / compositing if you have something like this enabled
* Try running it in full-screen if you have not already
(the last two points are related to getting direct rendering instead of indirect rendering)

(I also now assume you actually have enough horsepower to run the emulation)

If nothing seems to help, try pressing CTRL+F10 - this enables a debug overlay. A screenshot of this could help me see where the problem lies.

I have just created a google code project where I can maintain a list of outstanding issues. Could you create an issue there with such a screenshot and also with the complete log from fs-uae?
Here is the link: http://code.google.com/p/fs-uae/issues/list

Regarding vsync: There is two levels of "vsync" in fs-uae:
(1) sync to monitors vblank interval - this is used to get no tearing, and is always enabled
(2) the emulation is synced to the display's refresh (also implies (1)) - this is need to get perfect scrolling, and needs a 50Hz display for PAL games. (1) is always enabled, and (2) is enabled if the display is detected as 50Hz.

I think I will add an option to allow you to override this behavior, with the following values: "off" (no vsync at all), "vblank" (sync to display's vblank interval only to prevent tearing), "full" (force full synchronization with emulation) and "auto" (current behavior). (However, this will only help you if vsync is the culprit somehow). Also, if you have a 60hz display and run 50Hz games, syncing to vblank isn't that important anyway.
FrodeSolheim is offline  
Old 07 February 2012, 19:56   #59
FrodeSolheim
FS-UAE Developer

FrodeSolheim's Avatar
 
Join Date: Dec 2011
Location: Førde, Norway
Age: 37
Posts: 3,418
Quote:
Originally Posted by kire_online View Post
Tried 0.9.4 on Mac OS X 10.7.3, sound is not as crappy as 0.9.2, but it only works for about 10 seconds, then complete silence. Sound won't work even after I hit F12, insert another floppy and select reset, no sound at all, even the nice floppy sound, it's completely silent. I quit out, then restart, and again the same thing, I can only play Giana Sisters for about 10 seconds before it goes silent.

Just tired leaving it on the Kickstart screen for several minutes, and floppy clicking sound continues, so it's a problem while playing the game that kills the sound.

Also tried leaving music playing at the start of Hybris for several minutes, no problem at all.
I haven't been able to reproduce the problem exactly, but I just got a similar problem after running a CD32 game for a while. Could you report the problem here http://code.google.com/p/fs-uae/issues/list, and most importantly, upload the log? there may be openal error codes in the log!

Updated: The problem is likely found (http://code.google.com/p/fs-uae/issu...ail?id=1&can=1). Verifying the fix now.

Quote:
Originally Posted by kire_online View Post
Gave you a plug on the following website too;
http://www.emucr.com/2012/02/fs-uae-v093.html

Keep up the great work.
Excellent

Last edited by FrodeSolheim; 07 February 2012 at 20:42.
FrodeSolheim is offline  
Old 07 February 2012, 22:57   #60
P-J
Grumpy veteran
P-J's Avatar
 
Join Date: Mar 2001
Location: Moorpark, California
Age: 38
Posts: 1,146
Send a message via MSN to P-J
Quote:
Originally Posted by FrodeSolheim View Post
I have just created a google code project where I can maintain a list of outstanding issues. Could you create an issue there with such a screenshot and also with the complete log from fs-uae?
None of the remedies you suggested worked, so I've logged an issue on the tracker there with a link to a Youtube video with the debug info enabled. Hope this is of some use.
P-J is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible platform for Amiga Emulator? smiffy92 Amiga scene 1 18 February 2011 12:43
SPS Multi Platform Effort Is Go! CodyJarrett News 4 04 July 2010 21:13
Floppy Drive Emulation (Multi-Platform) Claw22000 Amiga scene 23 12 March 2009 07:01
poll for the multi platform tournament turrican3 EAB's competition 16 21 January 2009 21:24
Multi-platform Distributive Operating System (MPDOS) for Amiga JackTheKnife support.Hardware 2 10 December 2008 16:39

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 10:46.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.43153 seconds with 13 queries