English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 10 April 2011, 21:08   #1
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,591
Unstable horizontal picture position on 1084S monitor

Bought an A1084S monitor a while back. I tested it on the A500 I bought it with and didn't notice any problems then. (Admittedly, it was a quick test, but it looked fine.)

Basically it's been standing unused in my room for some months since then. I connected it to my A600, and apart from the horizontal position jittering about 1px left and right all the time, the picture is perfect.

The A600 works fine with a Philips CM 8833, no jittering.

As you may know, my A600 portable has a Joytech LCD connected to the RGB (via R,G,B,sync,ground only). But I unplug its power when connecting the monitor(s).

I use the A1084S with the RGB cable that came with it. Could it be that the cable needs to have some pins disconnected to not interfere with the connected (but going to powerless LCD) R,G,B,sync,GND pins?

Or is it simply a ground problem with the A1084S (23-pin to 6-pin DIN) cables that is known already? When I attached the cable (with no power to either LCD or monitor), I only had to touch the connector (not insert it) to get a reset of the Amiga.


Explaining all this, it seems that I need to know more about how the R,G,B,sync,GND pins connected to the dormant LCD affect connecting a 1084S to the same port. Do they?

Is a safe cable possible, or is the internals of the 1084S different from other monitors that work?
Photon is offline  
Old 10 April 2011, 23:17   #2
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,591
Disconnected the shield GND from Amiga->monitor, didn't help. Cable looked... old. Removed the conductive(!) connector housing on the cable.

I'm sure it's a ground problem in the monitor. Basically whenever the Amiga isn't idle, CPU work or sound plays or I click the mouse, the screen moves horizontally. There's also kind of a floating feeling to the screen height, and at big contrast-changes on screen, the width of the picture changes markedly.

It could be electronics interference, but I doubt that. It could be the PSU in 1084S not liking my microswitched PSU for the Amiga, but I doubt that. (Both because the CM-8833 monitor seems to not mind.)

It could also be a pure bad cable, but the monitor end is moulded, so I'd be better off getting a new DIN connector. I'll start by making a new cable. Are these DINs special or easily obtainable?

For now I'll use the CM-8833 so I can give the 1084S some luvvin'... by which I mean poke it with a hot iron...
Photon is offline  
Old 11 April 2011, 00:42   #3
jaycee
Registered User
 
Join Date: Sep 2006
Location: Norwich, UK
Posts: 57
The width change you're seeing is a sign of poor control of the horizontal flyback. This is often a case with old monitors - a capacitor refresh will probably help. Also check for any dry joints in the monitor. Naturally, beware - 31kV isn't friendly!
jaycee is offline  
Old 11 April 2011, 07:37   #4
modrobert
old bearded fool

modrobert's Avatar
 
Join Date: Jan 2010
Location: Bangkok
Age: 51
Posts: 503
I would try disconnecting the RGB ground pin connected to the Joytech LCD, don't think powering it off will be enough.
modrobert is offline  
Old 15 April 2011, 00:42   #5
Photon
Moderator
Photon's Avatar
 
Join Date: Nov 2004
Location: Hult / Sweden
Posts: 4,591
OK, opened the 1084S today and looked for something not up to scratch. Didn't find anything of note. Back in the case. Connected composite, no horizontal jittering (same bulge effect as before mentioned when abruptly toggling the color of a big rectangle in Dpaint).

Decided to get a second opinion with the same cable on a different Amiga, puzzled together an A500 from parts and Rock'n'Roll cracktro was solid as a rock.

So the screen is all right!

This leaves a few possibilities:
1. (Most likely) 1084S doesn't like the powerless LCD connected to r/g/b/sync/gnd. CM-8833 is fine with it though. Riddle me that if you will!
2. Cable is bad but A500's mobo wiring to RGB port pins are different from A600 (sounds like superstition)
3. Cable shielding is bad and picks up interference from all the junk in the A600, but A500 interference is lower strength and it still has its shielding. (Yeah, right, perfect picture and only hsync is affected)
4. A600 PSU is overloaded (no) or connected with not thick enough GND wire (maybe) to keep the signal levels kosher. (Again, works on CM-8833).

Which leaves only point 1, specifically it smells like some cap in the HSYNC circuit in the LCD interfering with same circuit in 1084S, which is different from the circuit in the CM-8833. Oh well, theories are worthless without backup. But I'll listen to yours if you get any from hearing this testdata.



Using the CM-8833 monitor for the time being.
Photon is offline  
Old 15 April 2011, 04:25   #6
Hewitson
Registered User
Hewitson's Avatar
 
Join Date: Feb 2007
Location: Melbourne, Australia
Age: 36
Posts: 2,624
By having the RGBS connected to two monitors, you are doubling the resistance which causes the signals to be half the strength they should be. The sync is too weak for the 1084S.

You really should use an amplifier or switcher if you want to have two monitors connected.
Hewitson is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
C= 1084S monitor cable carls support.Hardware 3 20 May 2013 17:54
1080 Monitor Vertical Position Adjust? Tempest 2084 support.Hardware 15 11 January 2013 16:14
C=1084S picture rolls orange support.Hardware 7 04 January 2012 14:39
M1438S Horizontal Position ancalimon support.Hardware 11 16 December 2009 19:19
1084S monitor problem Jan support.Hardware 17 13 May 2003 10:48

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:54.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.06667 seconds with 15 queries