English Amiga Board


Go Back   English Amiga Board > Support > support.Hardware

 
 
Thread Tools
Old 23 February 2011, 20:21   #1
Geon106
Registered User
 
Join Date: Jan 2011
Location: Chatham, Kent
Age: 31
Posts: 38
Send a message via MSN to Geon106 Send a message via Yahoo to Geon106
Floppy disk A500 Floppy Drive error?

Hey

I know this has been asked and i've searched the forums for an answer but nothing seems to help

My A500 recently arrived and it worked fine for a day, well, mostly, occasionaly it refused to read discs but it was only about 1 out of 10 times

Now though it struggles to read any disks, it would say "unreadable disk" then if I remove the disk it would say "please reinsert <disk name> into DF0" or words to that effect.

It recognises when a disk is inserted as it spins up and starts to read but seems to struggle. The kickstart 1.3 screen flickers for a few moments before proceeding to try and load the floppy

I opened the drive up and tried and blow out as much of the dust as possible and watch it load the disk and all seems okay, the disk gets spun and the header moves in and out of the disk(before stopping when the area appears)

I'm not sure how to fix this. Any ideas?
Geon106 is offline  
Old 24 February 2011, 00:07   #2
prowler
Global Moderator

prowler's Avatar
 
Join Date: Aug 2008
Location: Sidcup, England
Posts: 10,300
http://eab.abime.net/showpost.php?p=738732&postcount=6
prowler is offline  
Old 24 February 2011, 01:02   #3
pandy71
Registered User
 
Join Date: Jun 2010
Location: PL
Posts: 1,690
check - IC pins, sockets, cable etc, next - open FDD (remove top shield) with finger try to rotate screw (shaft) http://computer.howstuffworks.com/fl...isk-drive2.htm - move head from TRACK00 position to middle, without cover, connect power to FDD and verify that head will return to TRACK00 position - if not probably friction is to high ad whole drive need to be cleaned and lubricated.
pandy71 is offline  
Old 24 February 2011, 13:42   #4
Geon106
Registered User
 
Join Date: Jan 2011
Location: Chatham, Kent
Age: 31
Posts: 38
Send a message via MSN to Geon106 Send a message via Yahoo to Geon106
Quote:
Originally Posted by pandy71 View Post
check - IC pins, sockets, cable etc, next - open FDD (remove top shield) with finger try to rotate screw (shaft) http://computer.howstuffworks.com/fl...isk-drive2.htm - move head from TRACK00 position to middle, without cover, connect power to FDD and verify that head will return to TRACK00 position - if not probably friction is to high ad whole drive need to be cleaned and lubricated.
Thanks i'll try that. I've ordered a floppy drive cleaning disk from amiga kit as well as for £5 may be worth having anyway
Geon106 is offline  
Old 24 February 2011, 16:50   #5
pandy71
Registered User
 
Join Date: Jun 2010
Location: PL
Posts: 1,690
OK, however from my experience lighter gasoline, silicone lube with PTFE, few drops of silicone oil are sufficient to revive FDD
pandy71 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
A500 Floppy Drive problem elspero support.Hardware 18 07 January 2016 11:36
A500 floppy read/write error Hoopz support.Hardware 7 07 April 2013 17:18
A500+ Floppy Drive Failure ShadowWraith support.Hardware 12 23 February 2011 10:36
Adjusting A500 floppy drive... 8bitbubsy support.Hardware 3 25 September 2009 19:20
A500: Floppy Drive . read/write error for every single disk!! iggydix support.Hardware 11 23 August 2008 15:19

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.06543 seconds with 13 queries