English Amiga Board


Go Back   English Amiga Board > Support > support.Apps

 
 
Thread Tools
Old 24 December 2016, 19:23   #1
LuigiThirty
Registered User

 
Join Date: Dec 2016
Location: USA
Posts: 101
ixemul 63.1 Guru 8000000B?

I'm trying to use the latest ported GNU coreutils on my 030-equipped A2000. I downloaded ixemul 63.1 and installed it to my LIBS: folder. When I run anything out of the coreutils package, all I get is a Guru 8000000B coprocessor exception. I've got a 68882 FPU so I don't know what it's complaining about.

I got the ixemul from here and the coreutils from here. Any suggestions?
LuigiThirty is offline  
Old 24 December 2016, 19:48   #2
matthey
Banned
 
Join Date: Jan 2010
Location: Kansas
Posts: 1,284
The 6888x does *not* have the FSxxx and FDxxx instructions like the 68040 and 68060. Most versions of GCC generate these instructions when compiling for the 68040 or 68060 specifically (unlike vbcc and SAS/C compilers). Make sure you are using an executable compiled for the 6888x or 68020-68060 with FPU and *not* for the 68040 or 68060 with FPU. There are other reasons this error could occur but this is a good place to start.
matthey is offline  
Old 24 December 2016, 21:38   #3
LuigiThirty
Registered User

 
Join Date: Dec 2016
Location: USA
Posts: 101
It looks like the only binaries in the package were compiled for the 68060 which would explain that. I'll need to download the sources and compile it for 68020.
LuigiThirty is offline  
Old 24 December 2016, 22:04   #4
matthey
Banned
 
Join Date: Jan 2010
Location: Kansas
Posts: 1,284
Quote:
Originally Posted by LuigiThirty View Post
It looks like the only binaries in the package were compiled for the 68060 which would explain that. I'll need to download the sources and compile it for 68020.
Integer only code compiled for the 68060 should run on the 68020-68060. It is only FPU using code compiled for the 68060 and 68040 which is a problem on the 6888x.

I don't see the newer version of ixemul on aminet. Maybe a 68020FPU compiled version is available somewhere else? Perhaps all the 6888x Amiga users are using the old version of ixemul?
matthey is offline  
Old 24 December 2016, 22:08   #5
Locutus
Registered User

 
Join Date: Jul 2014
Location: Finland
Posts: 988
That archive are a bit of a mess, in the root is a textfile of how ./configure was invoked, claiming 68020+68881 but the actual .libraries are for 68060.

I guess only the .o that go in GG:lib/ are for 68020
Locutus is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
XPKGuide causing error #8000000B carloratm support.Apps 7 05 June 2016 10:48
Amiga 500 Kickstart 3.1 error #8000000B grommodore support.Hardware 16 31 October 2015 18:22
iGame error #8000000B paywjlk support.WinUAE 7 18 August 2015 22:16
HivelyTracker 1.6 on WB3.1 error #8000000b Lakanman support.Apps 0 03 January 2013 18:55
Program failed (error #8000000B) Fieldday support.Hardware 14 07 November 2009 21:57

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:28.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.07357 seconds with 13 queries