English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 20 August 2008, 23:44   #1
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 776
Canīt load datatypes.library

needed:
Today, when I started my A1200 a message appears when WB loaded:
ERROR: Couldnīt open datataypes.library V39
Next I copied the datatypes.libraray from my OS3.9 CD in to my Sys:Libs
but same error appears
Someone knows what could cause this error?
Thanks for replies
AlfaRomeo is offline  
AdSense AdSense  
Old 20 August 2008, 23:48   #2
davideo
Amiga Tomcat

davideo's Avatar
 
Join Date: Sep 2007
Location: Boston Lincs
Posts: 1,175
Have you checked that you've actually got the right version of the library?

The command you need to type into a shell window is

version libs:datatypes.library

Dave G
davideo is offline  
Old 21 August 2008, 00:00   #3
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 776
thanks for reply Dave my datatype.lib is v44.47 and I suppose that as is a later version should not give problems
AlfaRomeo is offline  
Old 21 August 2008, 00:09   #4
davideo
Amiga Tomcat

davideo's Avatar
 
Join Date: Sep 2007
Location: Boston Lincs
Posts: 1,175
That's the same version as mine. So yes it's a newer version.

Are you sure you haven't upset your Miggy and got a stray library kicking about? Could be worth a look.

Dave G
davideo is offline  
Old 21 August 2008, 00:33   #5
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 776
are you referring you to a virus?
AlfaRomeo is offline  
Old 21 August 2008, 00:36   #6
davideo
Amiga Tomcat

davideo's Avatar
 
Join Date: Sep 2007
Location: Boston Lincs
Posts: 1,175
No I wasn't. I meant you could have more than one version of that library on your Miggy. And what ever is trying to open the latest version is finding an old stray version on your hardrive.

Did you install any software yesterday?

Dave G
davideo is offline  
Old 21 August 2008, 01:06   #7
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 776
I was installing poseidon USB but I have worked with Amiga after that and it was all normal. How it is possible have more than one version of same lib installed? in different directory?
AlfaRomeo is offline  
Old 21 August 2008, 01:26   #8
davideo
Amiga Tomcat

davideo's Avatar
 
Join Date: Sep 2007
Location: Boston Lincs
Posts: 1,175
Yes it could be. It's happened to me in the past with a different library.

Try version datatype.library without the libs: path.

When I do the above my Amiga says library not found - which is what should happen.

Dave G
davideo is offline  
Old 21 August 2008, 01:39   #9
AlfaRomeo
A1200 040 SAM440EP 667
AlfaRomeo's Avatar
 
Join Date: Jan 2008
Location: Lisbon / Portugal
Posts: 776
I just find the problem
By mistake I had added a ";" at the beginning of the line C:AddDataTypes in my startup-sequence
Anyway thanks for the replies
AlfaRomeo is offline  
Old 21 August 2008, 01:42   #10
davideo
Amiga Tomcat

davideo's Avatar
 
Join Date: Sep 2007
Location: Boston Lincs
Posts: 1,175
Well at least you've found the problem

Dave G
davideo is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Native (UAE) DataTypes Roland007 request.UAE Wishlist 5 11 February 2013 06:44
datatypes.library error acspo support.Apps 7 07 April 2012 16:00
AFA OS and datatypes Rod_cl support.Apps 0 16 September 2006 02:39
Datatypes to replace fc.studio support.Apps 0 02 February 2006 15:37
Good Datatypes for PPC Giana support.Apps 1 27 March 2003 18:31

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 22:45.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Page generated in 0.26445 seconds with 12 queries