English Amiga Board


Go Back   English Amiga Board > Coders > Coders. General > Coders. Releases

 
 
Thread Tools
Old 06 January 2019, 23:08   #21
trixster
Guru Meditating

 
Join Date: Jun 2014
Location: England
Posts: 1,685
Quote:
Originally Posted by jurassicman View Post
I created a folder called saves on my ScummVM directory and I put all my savegames there.

I've played a few times BS1 and Monkey2 and I was able to load the savegames I previously made without any issues.
If i make a directory and point scummvm to it in the gui it states "The chosen directory cannot be written to. Please select another one"

/edit ok, scratch that, I had to edit the game options, not the global options.

Last edited by trixster; 06 January 2019 at 23:16.
trixster is offline  
Old 06 January 2019, 23:42   #22
jurassicman
Registered User

jurassicman's Avatar
 
Join Date: Dec 2017
Location: Bologna/Italy
Posts: 303
I was able to start COMI (I've copied the COMI uncompressed files from my PC to my Amiga) but the game seems quite slow.

I couldn't play more than a few minutes because holding pressed the left mouse button on an item (the cannon rope) the game crashed with the same message I received the other time.

It's difficult to understand what causes the error, I'll see if I can reproduce it.

Unfortunately, contrary to what I previously said, the program still crashes if I start it with "fullscreen=true" on the scummvm.ini file even without any themes.

I'l do more tests tomorrow...
jurassicman is offline  
Old 11 January 2019, 01:39   #23
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
This version also works with MT-32 support for me, sounds good, a tiny amount of skipping when first starting but that's it. Tested with SQ5, Elvira, a couple others.
grelbfarlk is offline  
Old 21 January 2019, 12:30   #24
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,244
Finally got around at testing it on my CSPPC. It works on full screen, no freezes in the start menu. That is CSPPC @ 200MHz with a V4, SB128 and RTL8139. My workbench is heavily modified (it is a tuned Amikit workbench).

The debugger comes up, though, in COMI. As all the ports are compiled to WarpOS with the original WarpOS includes and docs and not to the sonnet library, where it works on mulitple different PowerPC CPUs (with/without L2, Altivec etc etc) I am pointing to the PowerPC.library itself.

Other games seem to work.

Edit:

One of the following made the debugger go away:

Setting memprot to 0
Starting from CLI
Setting stack to 2000000

My money is on the stack as it is a known problem with WarpOS.

And yes, don't play with uncompressed files.....

Last edited by Hedeon; 21 January 2019 at 13:07.
Hedeon is offline  
Old 21 January 2019, 19:24   #25
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,244
Quote:
Originally Posted by jurassicman View Post
Thanks to you Hedeon!
The fullscreen problem doesn't happen if I don't use the themes.

Without the themes the program is quite fast and, so far, I can play Monkey2, Broken Sword 1 and Broken Sword 2 without any issues.

I've just tried COMI, though, the version with compressed audio but unfortunately just after the choice between the "full" and the "easy" versions the game crashes.

Attached the picture of the error. As soon as I type "exit" I get back to WorkBench.
Increase stack in the icon to 2000000. Maybe less is enough, but this number works for me.
Hedeon is offline  
Old 21 January 2019, 20:15   #26
pipper
Registered User

 
Join Date: Jul 2017
Location: San Jose
Posts: 205
That seems excessive. Maybe the large stack space is just hiding a an OOB bug?!
pipper is offline  
Old 21 January 2019, 22:18   #27
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,244
Quote:
Originally Posted by pipper View Post
That seems excessive. Maybe the large stack space is just hiding a an OOB bug?!
I just picked a number. If you read the OS4 threads about scummvm then 600000 (the standard) is not always enough and that some people use 1000000. I haven't tried 1000000.
Hedeon is offline  
Old 22 January 2019, 00:09   #28
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
Quote:
Originally Posted by pipper View Post
That seems excessive. Maybe the large stack space is just hiding a an OOB bug?!

It's kind of a known feature of WarpOS on CSPPC/BPPC, you can see this in WinUAE and MorphOS too. Some programs require a very large stack. Cowcat's and maybe even Hyperion's Quake 2 needed something like 8000000.



The only exception is Hedeon's powerpc.library on his supported cards, since he fixed it I haven't had to adjust stack manually for a long time now.
grelbfarlk is offline  
Old 22 January 2019, 03:56   #29
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
I noticed when compressing the COMI sound files the default VBR quality is 3, this produces some tinny/hissy sound. VBR quality of 7 is better but still has quite a bit of noise in it.
grelbfarlk is offline  
Old 20 May 2019, 01:15   #30
slaapliedje
Registered User
slaapliedje's Avatar
 
Join Date: Jul 2010
Location: Utah, USA
Posts: 341
Any chance of this being uploaded to aminet? Link is giving a 404 now.
slaapliedje is offline  
Old 21 May 2019, 00:40   #31
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
Quote:
Originally Posted by slaapliedje View Post
Any chance of this being uploaded to aminet? Link is giving a 404 now.

I'll see if it's ok to upload (since it's not mine) and put it up.
grelbfarlk is offline  
Old 22 May 2019, 01:03   #32
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
It's actually still up in the Zone.
TheZone/files/ScummVM2_WOS [ScummVM V2.1 (git) for WarpOS.].lha

I put up the extra special version Hedeon built that has all engines and 44100hz mixing rate set in my upload directory too.
*EDIT* which I should say is in /~Uploads/grelbfarlk/ScummVM2.1WOS_huge.zip

Last edited by grelbfarlk; 24 May 2019 at 03:08.
grelbfarlk is offline  
Old 11 August 2019, 13:47   #33
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 59
I need help with this. When I start scummvm 2.1 wos it works until I use the mouse. Then it freeze. Have tried other ver. Same thing.

Tried true and false but it just open the wb window. No fullscreen. Tried remove the thems.

So whats the next thing to try?

Tanks!

Last edited by anotherlife; 11 August 2019 at 13:53.
anotherlife is offline  
Old 11 August 2019, 22:14   #34
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
Quote:
Originally Posted by anotherlife View Post
I need help with this. When I start scummvm 2.1 wos it works until I use the mouse. Then it freeze. Have tried other ver. Same thing.

Tried true and false but it just open the wb window. No fullscreen. Tried remove the thems.

So whats the next thing to try?

Tanks!

What are the specs of the system you are trying to run it on?

Can you run SnoopDOS and post the log?
Does AHI work correctly with other programs?
grelbfarlk is offline  
Old 11 August 2019, 22:24   #35
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 59
Quote:
Originally Posted by grelbfarlk View Post
What are the specs of the system you are trying to run it on?

Can you run SnoopDOS and post the log?
Does AHI work correctly with other programs?
Amiga 1200 Blizzard ppc 603e 240mhz 48mb ram, bvision ppc, Elbox Zorro IV, X-Surf.

Will run it tomorow. Ahi runs fine with Amigaamp and othe games.

I can start scummvm and if i dont move the pointer it do not freeze. But after a while maybe 15 sec after moving the pointer it freeze.

I have tried different stack.
anotherlife is offline  
Old 12 August 2019, 03:10   #36
amigoun
Registered User
amigoun's Avatar
 
Join Date: May 2010
Location: Czech Rep
Posts: 558
Quote:
Originally Posted by anotherlife View Post
I can start scummvm and if i dont move the pointer it do not freeze. But after a while maybe 15 sec after moving the pointer it freeze. I have tried different stack.

I had the same experience when testing it with CSPPC/CVision or BPPC/Bvision. Still havent found what is causing the freeze, seems really sensitive to mouse movement.
amigoun is offline  
Old 12 August 2019, 15:31   #37
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 59
It works with hedeon version. No mouse problem. I have tried curse of monkey island. It starts but with wrong colors and can't get past the screen where you chose hard or easy mode
anotherlife is offline  
Old 12 August 2019, 20:26   #38
Hedeon
PPC Hacker

 
Join Date: Mar 2012
Location: Leiden / The Netherlands
Posts: 1,244
Quote:
Originally Posted by anotherlife View Post
It works with hedeon version. No mouse problem. I have tried curse of monkey island. It starts but with wrong colors and can't get past the screen where you chose hard or easy mode
Can you give a listing of your libraries with a program like Scout or similar?
Hedeon is offline  
Old 12 August 2019, 21:11   #39
anotherlife
Registered User

 
Join Date: Oct 2015
Location: Sweden
Posts: 59
Quote:
Originally Posted by Hedeon View Post
Can you give a listing of your libraries with a program like Scout or similar?
Hm don't know how to make a print screen och save ä text file with Scout ?
anotherlife is offline  
Old 12 August 2019, 21:22   #40
grelbfarlk
Registered User

 
Join Date: Dec 2015
Location: USA
Posts: 2,062
Quote:
Originally Posted by anotherlife View Post
Hm don't know how to make a print screen och save ä text file with Scout ?

With the libs window up hit print and just specify a text file like ram:mylibs.txt
grelbfarlk is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
DosBox 0.74 and ScummVM 1.8.1 for Classic Amiga WarpOS grelbfarlk Coders. Releases 120 02 January 2020 02:32
GLHexen2 Warpos. Cowcat Coders. General 80 16 November 2018 19:03
ScummVM WarpOS PPC drluking support.Apps 6 29 September 2018 23:29
UAE for WarpOS 0.8.12 grelbfarlk request.Apps 0 23 November 2016 01:14
WarpOS Programming Help? esc support.Other 8 21 October 2015 10:37

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:06.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.09789 seconds with 14 queries