English Amiga Board


Go Back   English Amiga Board > Coders > Coders. Asm / Hardware

 
 
Thread Tools
Old 05 June 2019, 00:13   #1
buzzybee
Registered User

 
Join Date: Oct 2015
Location: Landsberg / Germany
Posts: 238
CD32 music audio / just a quick thank you

I recently got a message from someone who had strange sounds coming from his CD32 when booting RESHOOT R.

Had some sleepless nights after that message, since RESHOOT R ran perfectly when I tested it on CD32. Once again I found help in this forum, with JOTD pointing me in the right direction – clr.w $bfe201 was the cause. Apparently thie command sets bit 0 in $bfe001 true, which then leads to the CD32 playing CD-ROM data as if it was audio. I implemented that line very late in the development process, to ensure that firebuttons are queried correctly. Should not have done that. Replaced that command with move.w#3,$bfe201 and everything is alright.

This community is so unbelievable. Thank you guys!
buzzybee is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick CD32 Survey Amigajay Amiga scene 33 03 June 2018 00:40
CD-Audio Music in Games outspaced Nostalgia & memories 8 23 May 2018 17:33
Music from MOD to CD AUDIO on CD32 question dex request.Other 5 07 December 2014 02:48
Couple of quick CD32 questions BuckoA51 support.Hardware 11 13 May 2011 16:34

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:45.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.06028 seconds with 15 queries