English Amiga Board


Go Back   English Amiga Board > Main > Retrogaming General Discussion

 
 
Thread Tools
Old 15 May 2019, 22:34   #241
guest.r
Registered User

guest.r's Avatar
 
Join Date: May 2017
Location: EU
Posts: 283
An issue has been opened with the slang version, maybe it's exactly the same as you describe:
https://github.com/libretro/slang-shaders/issues/100

OP's problems were mostly solved by a driver update to the latest nVidia drivers, the issue persists with the D3D12 backend though.
guest.r is offline  
Old 19 May 2019, 10:32   #242
Dr.Venom
Registered User
 
Join Date: Jul 2008
Location: Netherlands
Posts: 485
Quote:
Originally Posted by guest.r View Post
An issue has been opened with the slang version, maybe it's exactly the same as you describe:
https://github.com/libretro/slang-shaders/issues/100

OP's problems were mostly solved by a driver update to the latest nVidia drivers, the issue persists with the D3D12 backend though.

Thanks for the pointer. First I updated to the "Creator Ready Driver" (it's from march), and the slang output was still bugged. Then I updated to the "Game Ready Driver" (it's from May 5th) and yess it works fine now

Lagless vsync on WinUAE also still works as great as before, so all good here also.
Dr.Venom is offline  
Old 30 May 2019, 12:13   #243
Dr.Venom
Registered User
 
Join Date: Jul 2008
Location: Netherlands
Posts: 485
Hi

Was trying out vertical games with both the MAME core and the Final Burn Neo core (fbneo_libretro.dll), which is an alternative to MAME, but am encountering an error with the Final Burn Neo core for vertical orientated games (all horizontal stuff is fine).

As an example, see below shot of Bombjack. There's a scaling issue with discoloring. Mostly it's a triangle divided by the diagonal of which one part gets discolored. In below shot there's an additional triangle..

I tried all possible options in the shader and RA video. Smart integer scaling in the shader does not help, nor does setting TATE mode. The only scaling option in RA that solves the issue is to set scaling to 1:1, but that gives wrong aspect.

When I disable the shader everything works correct, including all different scaling options in RA. Which makes me think it's a shader side issue?

Any idea?


P.S. The FB Neo core works the same as MAME, so you can load bombjack with it just as you'd do for the MAME core.


(click for large)
Dr.Venom is offline  
Old 30 May 2019, 21:38   #244
guest.r
Registered User

guest.r's Avatar
 
Join Date: May 2017
Location: EU
Posts: 283
Quote:
When I disable the shader everything works correct, including all different scaling options in RA. Which makes me think it's a shader side issue?
Probably some coord manipulation by the core or RA while rotating stuff. I would rather say that some shaders are sensitive to this and crt-guest-dr-venom already has some mechanisms built in to prevent similar glitches. Since it works with other cores that are rotating the image i would leave it be for the present. Another good question is if same happens with crt-hyllian which also supports vertical scanlines?

Edit: moved my lazy **s and tested it myself, with the same core. Could not reproduce, unfortunatelly or fortunatelly.



With different aspect ratio:



Maybe it's another nVidia issue, could you test it with an AMD card? To make sure...

Last edited by guest.r; 30 May 2019 at 22:10.
guest.r is offline  
Old 02 August 2019, 20:48   #245
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 47
Posts: 11,727
@guest.r


Could you please check bsnes v108 Windows version? Somehow your CRT Trintron shader doesn't work properly anymore (v107 is still fine).


I mean these specifically.
Attached Files
File Type: rar bnes-shaders_not working properly since v108.rar (11.0 KB, 11 views)
Retro-Nerd is online now  
Old 02 August 2019, 23:09   #246
guest.r
Registered User

guest.r's Avatar
 
Join Date: May 2017
Location: EU
Posts: 283
Quote:
Originally Posted by Retro-Nerd View Post
@guest.r


Could you please check bsnes v108 Windows version? Somehow your CRT Trintron shader doesn't work properly anymore (v107 is still fine).


I mean these specifically.
No crt shader that uses masks doesn't work properly, unless you use specific window sizes or the stretch mode. No way to fix it within shaders.

The author probably went for speed and used linear scaling so the shader isn't applied on left/right black borders.

If you have a decent machine it's best to stick with v107 for a while until this get's fixed. As i read the v108 changes are performance based, maybe with a little too much ambition enthusiasm.

Last edited by guest.r; 09 August 2019 at 15:47.
guest.r is offline  
Old 02 August 2019, 23:28   #247
Retro-Nerd
Missile Command Champion

Retro-Nerd's Avatar
 
Join Date: Aug 2005
Location: Germany
Age: 47
Posts: 11,727
Yeah, i noticed it too that it works with "stretched" mode. Thanks for the info about the linear scaling method. Byuu drives me nuts. Every new release he changes things like that.
Retro-Nerd is online now  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multipass shaders craig64 support.FS-UAE 20 10 July 2017 22:45
Shaders Zeraphine support.Amiga Forever 0 23 May 2016 23:23
CG Shaders Enverex support.FS-UAE 2 05 October 2014 18:51
fx Shaders in WinUAE 2.6.0 crazy46guy support.WinUAE 8 16 June 2013 14:30
Love Emulators? - Dgen & Hatari emulators Paul News 17 19 January 2012 18:28

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 23:21.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.07969 seconds with 16 queries