English Amiga Board


Go Back   English Amiga Board > Support > support.OtherUAE

 
 
Thread Tools
Old 10 September 2017, 12:54   #381
ransom1122
Registered User
ransom1122's Avatar
 
Join Date: Aug 2011
Location: Omnicorp
Posts: 2,558
Quote:
Originally Posted by lubomyr View Post
if i find some free time, I will try to create android port.
ransom1122 is online now  
AdSense AdSense  
Old 27 September 2017, 21:19   #382
Zol77
Registered User

Zol77's Avatar
 
Join Date: Apr 2016
Location: Hungary , Hajduszoboszlo
Posts: 10
Hi Lubomyr,

Today updated Uae4arm from play store,and not working on my devices.
I installed two devices : Oneplus 3 android 7.1.1 , and Galaxy Tab S2 android 7.0
After launch the app, loading,and black screen,and Uae4arm stopped error messages. I tried reset config to default,but did not help.
I downgraded to 1.0.0.17.

Last edited by Zol77; 28 September 2017 at 10:32.
Zol77 is offline  
Old 28 September 2017, 20:19   #383
lubomyr
AMIGA EMU DEV
lubomyr's Avatar
 
Join Date: Nov 2012
Location: Lviv, Ukraine
Posts: 511
Send a message via Skype™ to lubomyr
Zol77,
Thanks for response. When i have some free time i will try to investigate it.
Currently I tested only with my Xiaomi redmi note 4x (android 7.0). It works but i have trouble with reset when starting emulation and changing config
lubomyr is offline  
Old 28 September 2017, 21:11   #384
Zol77
Registered User

Zol77's Avatar
 
Join Date: Apr 2016
Location: Hungary , Hajduszoboszlo
Posts: 10
Thanks to the reply.

I tested another devices, and working!
Nvidia Shield TV - android 7.0
One more interest thing on 1.0.0.17:
Sometimes the onscreen keyboard stucked,and flashing on my phone,and tablet,and Shield TV when save,and renaming the config,or any text input .
Zol77 is offline  
Old 29 September 2017, 00:52   #385
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by lubomyr View Post
Zol77,
Thanks for response. When i have some free time i will try to investigate it.
Currently I tested only with my Xiaomi redmi note 4x (android 7.0). It works but i have trouble with reset when starting emulation and changing config
I get this reset problem on some of the android devices I have.
I also wanted to ask, is it possible to have an option to increase the menu button size as trying to set it up on my watch can be very fiddly.
FOL is offline  
Old 01 October 2017, 22:06   #386
BippyM
Global Moderator

BippyM's Avatar
 
Join Date: Nov 2001
Location: Nottingham, UK
Age: 42
Posts: 8,618
Has anyone been able to build this??? I have tried repeatedly and it fails as it seems to be missing files

Code:
/lib/armeabi-v7a/
folders don't exist!
BippyM is offline  
Old 03 October 2017, 17:25   #387
Zol77
Registered User

Zol77's Avatar
 
Join Date: Apr 2016
Location: Hungary , Hajduszoboszlo
Posts: 10
Hi Lubomyr,

I tested the latest beta on another devices:
Nexus 5 - android 6.0.1 , and Sony Tablet Z - android 5.1.1
not working : black screen,and exit without error message

Galaxy S3 Neo - android 4.4 - working!
Zol77 is offline  
Old 04 October 2017, 02:24   #388
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
I also ment to mention a bug thats in every build.
All sound options do not work correctly. All changes make sound run to fast.
FOL is offline  
Old 04 October 2017, 10:52   #389
Zol77
Registered User

Zol77's Avatar
 
Join Date: Apr 2016
Location: Hungary , Hajduszoboszlo
Posts: 10
Quote:
Originally Posted by FOL View Post
I also ment to mention a bug thats in every build.
All sound options do not work correctly. All changes make sound run to fast.
I did not hear any audio problem on my devices.
all build,all of my devices (Oneplus3,Galaxy TabS2,ShieldTV) sound is OK.
Zol77 is offline  
Old 04 October 2017, 11:15   #390
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by Zol77 View Post
I did not hear any audio problem on my devices.
all build,all of my devices (Oneplus3,Galaxy TabS2,ShieldTV) sound is OK.
Try changing to mono or change frequency. On default 44KHz, its fine.
FOL is offline  
Old 04 October 2017, 12:40   #391
Zol77
Registered User

Zol77's Avatar
 
Join Date: Apr 2016
Location: Hungary , Hajduszoboszlo
Posts: 10
Quote:
Originally Posted by FOL View Post
Try changing to mono or change frequency. On default 44KHz, its fine.
I tried,and really bad/fast.
One question:
If the default audio settings is good,why change to weaker quality,and wrong playback "mode" ?
Zol77 is offline  
Old 04 October 2017, 13:17   #392
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by Zol77 View Post
I tried,and really bad/fast.
One question:
If the default audio settings is good,why change to weaker quality,and wrong playback "mode" ?
Some things arent so good on some device's.

If I recall. When I was adding Turbo CPU function to PSPUAE. I had to devide the CPU cycles depending on what frequency was selected. However Im only guessing as that was a long time ago and I would need to look at code to remind me.
FOL is offline  
Old 04 October 2017, 21:28   #393
gururise
Registered User

 
Join Date: May 2016
Location: Los Angeles
Posts: 28
Quote:
Originally Posted by lubomyr View Post
Uae4arm Beta version
https://play.google.com/apps/testing...anddev.uae4arm

- implemented hiding of system mouse pointer (only for device with android 7.x or higher)
Not Tested.
Curious. How did you hide the system mouse pointer in Android? I thought it was impossible. Did Android 7.x expose some new API?
gururise is offline  
Old 04 October 2017, 21:32   #394
BippyM
Global Moderator

BippyM's Avatar
 
Join Date: Nov 2001
Location: Nottingham, UK
Age: 42
Posts: 8,618
Quote:
Originally Posted by gururise View Post
Curious. How did you hide the system mouse pointer in Android? I thought it was impossible. Did Android 7.x expose some new API?
It's an Android 7 "feature".. It's a bit shit lol

Sent from my SM-G935F using Tapatalk
BippyM is offline  
Old 04 October 2017, 21:37   #395
DDNI
Targ Explorer

DDNI's Avatar
 
Join Date: Mar 2006
Location: Northern Ireland
Age: 43
Posts: 5,088
Send a message via ICQ to DDNI Send a message via MSN to DDNI
does this euae build support serial.device?
DDNI is offline  
Old 05 October 2017, 11:43   #396
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by DDNI View Post
does this euae build support serial.device?
Wrong thread I suspect. This is android version.
FOL is offline  
Old 05 October 2017, 14:13   #397
DDNI
Targ Explorer

DDNI's Avatar
 
Join Date: Mar 2006
Location: Northern Ireland
Age: 43
Posts: 5,088
Send a message via ICQ to DDNI Send a message via MSN to DDNI
Quote:
Originally Posted by FOL View Post
Wrong thread I suspect. This is android version.
oops my mistake
DDNI is offline  
Old 07 October 2017, 15:45   #398
BippyM
Global Moderator

BippyM's Avatar
 
Join Date: Nov 2001
Location: Nottingham, UK
Age: 42
Posts: 8,618
There are issues with sound. Put it on mono

Sent from my SM-G935F using Tapatalk
BippyM is offline  
Old 09 October 2017, 11:02   #399
FOL
PSPUAE DEV

FOL's Avatar
 
Join Date: Nov 2006
Location: Barry / UK
Age: 39
Posts: 5,584
Send a message via MSN to FOL Send a message via Skype™ to FOL
Quote:
Originally Posted by BippyM View Post
There are issues with sound. Put it on mono

Sent from my SM-G935F using Tapatalk
I already said, post #390 and #392, .
FOL is offline  
Old 18 October 2017, 22:36   #400
lubomyr
AMIGA EMU DEV
lubomyr's Avatar
 
Join Date: Nov 2012
Location: Lviv, Ukraine
Posts: 511
Send a message via Skype™ to lubomyr
Zol77,
Try to check latest beta 1.0.0.19 in google play on startup crashes with your devices.

FOL, BippyM
I don't have any solution how to fix these audio problems (mono, frequency etc.)
lubomyr is offline  
AdSense AdSense  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
IPF and ARM jonathan project.SPS (was CAPS) 24 14 October 2015 20:19
DO OR DIE,x86 or ARM? hydragon Amiga scene 19 21 March 2014 13:05
WinUAE for Windows 8 ARM? Mequa request.UAE Wishlist 6 27 October 2011 20:40
Made in Britain - ARM DDNI Nostalgia & memories 2 30 June 2011 11:53
Minimig mod for ARM lolafg support.Hardware 7 17 October 2010 21:43

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:29.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Page generated in 0.21847 seconds with 15 queries