English Amiga Board


Go Back   English Amiga Board > Support > support.Other

 
 
Thread Tools
Old 14 July 2019, 14:29   #301
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 35
Posts: 98
So I have Amiga forever 8 and the installer recognises my roms just fine and it sees that I have AmigaOS 3.1 ADF images just fine but when I go to build the HDF the Amiga OS installation shows N/A on Amiga OS 3.1 from adf files as if it can't see them.

The log below shows it has found them all by MD5 apart from the Install disk which is odd.

enigma776 is offline  
Old 14 July 2019, 23:30   #302
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by enigma776 View Post
So I have Amiga forever 8 and the installer recognises my roms just fine and it sees that I have AmigaOS 3.1 ADF images just fine but when I go to build the HDF the Amiga OS installation shows N/A on Amiga OS 3.1 from adf files as if it can't see them.

The log below shows it has found them all by MD5 apart from the Install disk which is odd.

I just tried with a fresh download of Amiga Forever 8 iso and copied of adf files from "\Amiga Files\Shared\adf" to my images "amigaos" directory. This detected Amiga 3.1 adf files incl. install disk by MD5.

Do you know if your Install Disk could have been modified? If so MD5 will not match and it won't detect the install disk.

Please retry with fresh install of Amiga Forever 8 or just copy adf files from iso.

Otherwise select "MD5 & mount adf" when asked for detection method to use. This will detect Amiga OS 3.1 by examining files on adf files to determine valid Amiga OS 3.1 adfs and will most likely accept Amiga OS 3.1 adf with slight differences.
Attached Thumbnails
Click image for larger version

Name:	af8_md5.png
Views:	20
Size:	27.9 KB
ID:	63752   Click image for larger version

Name:	detection_method.png
Views:	20
Size:	12.5 KB
ID:	63753  

Last edited by cyberhead97; 14 July 2019 at 23:37.
cyberhead97 is offline  
Old 14 July 2019, 23:35   #303
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by cyberhead97 View Post
I have started converting ClassicWB UAE to a package for HstWB Installer and add Amiga OS 3.1.4 support at the same time. I will also include ClassicWB GAAE in this process.

It will delay the release a bit.

I have also considered converting BestClassicWB.
After looking through ClassicWB UAE setup, I won't include or convert this for next release. It's basically the same as installing ClassicWB P96 and ADVSP separately on each their image and those are already included in HstWB Installer where such images can be created.
cyberhead97 is offline  
Old 15 July 2019, 01:31   #304
enigma776
Bringer of Death

enigma776's Avatar
 
Join Date: Apr 2017
Location: UK
Age: 35
Posts: 98
Quote:
Originally Posted by cyberhead97 View Post
I just tried with a fresh download of Amiga Forever 8 iso and copied of adf files from "\Amiga Files\Shared\adf" to my images "amigaos" directory. This detected Amiga 3.1 adf files incl. install disk by MD5.

Do you know if your Install Disk could have been modified? If so MD5 will not match and it won't detect the install disk.

Please retry with fresh install of Amiga Forever 8 or just copy adf files from iso.

Otherwise select "MD5 & mount adf" when asked for detection method to use. This will detect Amiga OS 3.1 by examining files on adf files to determine valid Amiga OS 3.1 adfs and will most likely accept Amiga OS 3.1 adf with slight differences.
Oh right yeah this makes sense now thinking of it, as I change the Hard disk tool to a different device which will throw it all out of wack. Forgot all about this. Will keep a fresh untouched set of disks from now on.
enigma776 is offline  
Old 15 July 2019, 07:54   #305
symbios24
Registered User

 
Join Date: Jun 2019
Location: greece
Posts: 17
Os 3.9

add Amiga OS 3.1.4 support at the same time

cyberhead97 you mean 3.9 support?

it will be great to include also BestWB
symbios24 is offline  
Old 16 July 2019, 23:04   #306
fubs
Registered User

 
Join Date: Dec 2018
Location: Finland
Posts: 1
I don't normally write here as opposed to just lurking, but, cyberhead97, you rock man
fubs is offline  
Old 17 July 2019, 00:08   #307
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by fubs View Post
I don't normally write here as opposed to just lurking, but, cyberhead97, you rock man
Thanks, that’s a great booster for me
cyberhead97 is offline  
Old 17 July 2019, 00:15   #308
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
The last days I have been tweaking ClassicWB OS39 to work with Amiga OS 3.1.4 and it seems to work. ClassicWB OS39 package can now be installed with both Amiga OS 3.9 and 3.1.4

It’s of course missing some programs that only exist in OS 3.9 like AmiDock.
Attached Thumbnails
Click image for larger version

Name:	C3719BA9-BA82-408A-A0BE-D1724B911A94.png
Views:	37
Size:	69.3 KB
ID:	63777   Click image for larger version

Name:	057D7102-7B67-47A9-950C-B011B4B3123F.png
Views:	31
Size:	52.1 KB
ID:	63779   Click image for larger version

Name:	E6551A6D-5785-4460-A0AE-C17592ABC2AA.png
Views:	35
Size:	24.5 KB
ID:	63780   Click image for larger version

Name:	6113195B-4A53-4D52-B19E-6CD9311DB879.png
Views:	29
Size:	53.2 KB
ID:	63781  

Last edited by cyberhead97; 17 July 2019 at 00:16. Reason: Forgot to mention missing programs
cyberhead97 is offline  
Old 17 July 2019, 10:29   #309
frozen
Registered User

 
Join Date: May 2019
Location: Italy
Posts: 9
Quote:
Originally Posted by cyberhead97 View Post
The last days I have been tweaking ClassicWB OS39 to work with Amiga OS 3.1.4 and it seems to work. ClassicWB OS39 package can now be installed with both Amiga OS 3.9 and 3.1.4

It’s of course missing some programs that only exist in OS 3.9 like AmiDock.

And we can apply the new update to OS 3.1.4.1 to this without problems?
frozen is offline  
Old 17 July 2019, 11:23   #310
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by frozen View Post
And we can apply the new update to OS 3.1.4.1 to this without problems?
I haven't tested that yet, but I will try install 3.1.4 update later today and see what happens. If it just installs new devices, libraries and doesn’t modify startup sequence too much, then I would expect it to work.
cyberhead97 is offline  
Old 17 July 2019, 11:31   #311
frozen
Registered User

 
Join Date: May 2019
Location: Italy
Posts: 9
Quote:
Originally Posted by cyberhead97 View Post
I haven't tested that yet, but I will try install 3.1.4 update later today and see what happens. If it just installs new devices, libraries and doesn’t modify startup sequence too much, then I would expect it to work.

Ok thanks for your work.
frozen is offline  
Old 17 July 2019, 17:30   #312
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by frozen View Post
Ok thanks for your work.
It works! I installed Amiga OS 3.1.4.1 update on my freshly installed Amiga OS 3.1.4 with ClassicWB OS39 and I didn't encounter any issues.

Note that it says 2019 in the title bar, so it appears to be updated.
Attached Thumbnails
Click image for larger version

Name:	classicwb_os39_3.1.4.1.png
Views:	40
Size:	11.6 KB
ID:	63789  
cyberhead97 is offline  
Old 17 July 2019, 19:43   #313
frozen
Registered User

 
Join Date: May 2019
Location: Italy
Posts: 9
Quote:
Originally Posted by cyberhead97 View Post
It works! I installed Amiga OS 3.1.4.1 update on my freshly installed Amiga OS 3.1.4 with ClassicWB OS39 and I didn't encounter any issues.

Note that it says 2019 in the title bar, so it appears to be updated.

Wonderful.....
frozen is offline  
Old 18 July 2019, 10:09   #314
symbios24
Registered User

 
Join Date: Jun 2019
Location: greece
Posts: 17
Can you include the update of amiga OS 3.1.4 to 3.1.4.1 ??

http://www.generationamiga.com/2019/...hat-to-expect/

Thanks
symbios24 is offline  
Old 18 July 2019, 10:56   #315
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by symbios24 View Post
Can you include the update of amiga OS 3.1.4 to 3.1.4.1 ??

http://www.generationamiga.com/2019/...hat-to-expect/

Thanks
Sure, I working on updating Amiga OS 3.1.4 installation to detect 3.1.4.1 update adf and apply it after installing Amiga OS 3.1.4
cyberhead97 is offline  
Old 19 July 2019, 02:19   #316
cloverskull
Registered User

 
Join Date: Sep 2018
Location: California
Posts: 50
What from 3.9 is missing? Is there no way to get amidock back?
cloverskull is offline  
Old 19 July 2019, 10:45   #317
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by cloverskull View Post
What from 3.9 is missing? Is there no way to get amidock back?
An alternative could be installed from aminet. I don't have much experience with docks for Amiga OS. Maybe http://aminet.net/package/util/boot/AmiDock could work. MacLikeDock https://www.generationamiga.com/2017...-a-macos-look/ looks nice, but I can't find any download that work and I don't know if it would work with Amiga OS 3.1.4.
cyberhead97 is offline  
Old 19 July 2019, 18:18   #318
symbios24
Registered User

 
Join Date: Jun 2019
Location: greece
Posts: 17
maybe the update fixes the amidock
symbios24 is offline  
Old 19 July 2019, 22:56   #319
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
Quote:
Originally Posted by symbios24 View Post
maybe the update fixes the amidock
Unfortunately updating doesn't fix AmiDock. It only exists in Amiga OS 3.9.

I have managed to install a simple replacement from Aminet called AmiDock, but it's not the same as the one in Amiga OS 3.9.

It doesn't seem to support colorful icons, but it works and is good enough as a start. If anyone have another solution with better color support, please let me know about it and how to configure it.
Attached Thumbnails
Click image for larger version

Name:	classicwb_os39_3.1.4_1.png
Views:	24
Size:	66.4 KB
ID:	63818   Click image for larger version

Name:	classicwb_os39_3.1.4_2.png
Views:	24
Size:	15.0 KB
ID:	63819   Click image for larger version

Name:	classicwb_os39_3.1.4_3.png
Views:	24
Size:	30.0 KB
ID:	63820  
cyberhead97 is offline  
Old 20 July 2019, 00:30   #320
cyberhead97
Registered User

 
Join Date: Feb 2016
Location: Denmark
Posts: 194
I look a bit around and ToolManager seems like a better AmiDock replacement http://www.mfilos.com/2012/04/guide-...-dock.html?m=1
cyberhead97 is offline  
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Similar Threads
Thread Thread Starter Forum Replies Last Post
Legal Issues if Sharing RP9 Snapshots? tygre Retrogaming General Discussion 17 18 September 2014 20:04
ImageStudio preinstalled retrogamer request.Apps 5 31 March 2011 05:59
Making cf_ClassicWB_FULL.hdf bigger? emuola project.ClassicWB 3 06 June 2009 00:23
New ruling making retro-archives legal? Bloodwych Retrogaming General Discussion 3 24 November 2006 19:30

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:30.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Page generated in 0.09858 seconds with 16 queries